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Course Description 
Master the essential Excel skills required to earn the Microsoft Office Specialist: Excel Associate 
Certification and demonstrate proficiency in creating and managing workbooks, applying formulas 
and functions, and visualizing data with charts and tables.  

This course provides comprehensive, hands-on instruction in key Excel functionalities, ensuring you 
develop the skills to confidently work with worksheets, manipulate data, apply advanced 
formatting, and perform calculations. You will gain expertise in importing data, managing named 
ranges, formatting tables, and applying conditional formatting to analyze and present data 
effectively.  

Beyond spreadsheet fundamentals, you will explore customizing workspaces, preparing workbooks 
for collaboration, and managing charts, allowing you to produce professional-grade reports, 
financial statements, and performance analytics.  

Whether you are seeking certification, career advancement, or improved Excel proficiency, this 
course will prepare you for success. 

       Suggested Course Length: 23-41 Hours 

Course Series 
This guide is part of CCI’s Microsoft series.  

Course Requirements 
There are no pre-requisites for this course. 
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Course Objectives 
This course book teaches the skills you will need to successfully complete the Microsoft Excel 
Certification Exam (MO-210) offered by Certiport. These skill sets are introduced using multiple types 
of exercises and review materials. 

After completing this course, you will understand the following:  

 Manage Workbooks & Worksheets: Import, navigate, and format workbooks with named 
ranges, hyperlinks, and custom views.  

 Data Management & Formatting: Organize and manipulate data using sorting, filtering, 
Auto Fill, and number formatting.  

 Tables & Structured Data: Create, format, and modify Excel tables, including total rows and 
conditional formatting.  

 Advanced Formulas & Functions: Utilize essential functions such as AVERAGE(), IF(), 
UNIQUE(), and structured references.  

 Text & Data Transformation: Modify and format text using CONCAT(), MID(), LEFT(), RIGHT(), 
and case functions.  

 Charts & Data Visualization: Create and modify charts, apply styles, and switch between 
rows and columns for meaningful insights.  

 Collaboration & Workbook Preparation: Configure print settings, manage comments, and 
ensure accessibility with alternative text.  

 
By mastering these tools, you will be fully prepared to earn your Microsoft Excel Associate 
Certification and gain a recognized credential that validates your Excel expertise for career growth 
in business, finance, data analysis, and beyond! 

Download Learner Files 
To complete the exercises in this course, you will need the provided exercise files. Follow these steps 
to download them.  

1. Launch your browser and navigate to the Student Data Files page on CCI Learning’s website, 
located at http://www.ccilearning.com/data.  

2. Enter: 3283 in the Courseware # field, then select Find Data.  

Note: Depending on the browser you are using, the ZIP file may be automatically saved in your 
Downloads folder, or you may be prompted to open or save the file.   

3. Right-click the ZIP file, then select Extract All to display the Extract Compressed (Zipped) 
Folders dialog box.  

4. Use the Browse button to navigate to the desired location to save your documents. 

  

http://www.ccilearning.com/data
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Course Design 
This course book was developed for instructor-led training and will assist you during class. Together 
with comprehensive instructional text and objectives checklists, this course book provides a 
glossary of course-specific terms. This course book is organized in the following manner: 

 Microsoft Excel 

 

 Table of Contents 

 Unit 

  Lessons 

 

 Lesson Objectives 

  Lesson Topics 

 Unit Key Terms 

 Appendices 

  Course Book Mapping 

 
 Key Terms 

 Index  

You will find this course book to be a valuable resource for reviewing exercises and applying the 
skills you have learned. After each lesson, navigate to the learning platform or student files to 
practice new skills and review the material. These questions are provided as a study resource only 
and in no way guarantee a passing score on a certification exam. 

  



About This Course Book  Preface 

x  3283-2 © CCI Learning Solutions Inc. 

Conventions and Graphics 
The following conventions are used in CCI learning materials. 

Key Terms – Vocabulary terms that are presented in the narrative appear in bold italic font style. 

Procedures – Procedures and commands you are instructed to activate are indicated in bold font 
style. 

Technical Notes point out exceptions or special circumstances that you may find when working 
through a particular process or may indicate there is another method to complete the task. 

Assessment Alerts – These alerts will let you know when to access the Learner Workbook to 
practice a skill or to complete lesson or unit assessments. 

 

 

 

Assessment Alerts – These alerts indicate differences in features and instructions between the 
desktop and online versions of the application. 
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Unit 1: Getting to Know Excel 
Unit Objectives 
In this unit, you will learn about and work in Excel. You will add and edit different types of data, work 
with worksheets and workbooks, work with lists and fill options, and change views. You will also 
learn how to set up a workbook for printing, including checking for accessibility, protecting 
sensitive information, and inspecting for hidden content. Upon successful completion of this unit, 
you should understand the following: 

 Work with Excel 

 Construct Cell Data 

 Work with Workbooks 
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Lesson 1: Work with Excel 
Lesson Objectives 
In this lesson, you will be introduced to the Microsoft Excel application, identify the components of 
the Excel environment, and learn how to move around within the application. You will also learn to 
customize the Quick Access Toolbar and Ribbon, create and save workbooks, and work with files. 
Upon completion of this lesson, you should be able to understand the following: 

 Startup and Application Window 

 Worksheet Window  

 Ribbon 

 Customize the Quick Access Toolbar 

 Access Workbook Properties 

 Check for Issues 

 Create a New Workbook 

 Save a Workbook 

 Manage Worksheets 

 Move or Copy Worksheets 
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Startup and Application Window 
When Excel starts, the startup screen appears from which you can open a workbook, start a new 
blank workbook, or create a new workbook based on a template.  

 

Your workspace in Excel is the Excel application window. It contains components including the 
Ribbon and the Quick Access Toolbar that you might be familiar with from working with other 
Office applications such as Microsoft Word.  

 

The table discusses components of the Excel window: 

File tab Select the File tab to open the Backstage view, from which you 
can select commands to manage files, including New, Open, Save 
As, and Print.  

Ribbon Each Ribbon tab contains buttons, menus, and other controls you 
use to perform certain actions in Excel. 

Quick Access Toolbar (QAT) Located above the Ribbon, the QAT provides quick and 
customizable access to frequently used commands.  

Title bar Located at the top of the screen, the title bar’s main purpose is to 
display the open file’s name. 

Minimize, Maximize/Restore 
Down, Close 

Located in the upper right-hand corner of the window, these 

buttons enable you to minimize ( ) the application window to 

a button on the taskbar, maximize ( ) the program to full 
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screen, restore ( ) the window to its original size, or close ( ) 

the application window.  

Ribbon A collection of tabs (such as File, Home, and Insert) that provides 
access to commands used to complete a task.  

Ribbon group Each Ribbon tab contains groups of related commands. Some 
groups include a dialog box launcher button at the bottom right 

( ), which opens a dialog box or pane with more commands and 
options. 

Ribbon Display Options Controls whether to hide or display the Ribbon with the tabs or 
with both tabs and command buttons.  

 

Worksheet Window 

 
The table discusses the elements found in the worksheet window: 

Name Box Located beside the Formula bar, the Name box displays the cell address of 
the active cell.  

Insert Function This tool opens a dialog box to help you choose and insert a built-in 
function.  

Formula Bar Located to the right of the Name Box, the Formula Bar displays the 
contents of the active cell. 

Active cell The selected cell. Entered values will be inserted into the active cell.  

Column headings Sequential letters at the top of each column enable you to track columns. 

Row headings Sequential numbers on the left side of each row enable you to track rows. 
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Sheet tab The rectangular box at the bottom of a worksheet by which worksheets 
are accessed and identified.  

Status bar Displays the current cell mode, auto calculations, the View buttons, and 
the Zoom slider. 

Scroll bars Scrolls the spreadsheet to view content that is offscreen and not visible. 

View buttons These buttons change the on-screen views for the worksheet. The views 
are Normal, Page Layout, and Page Break Preview. 

Zoom slider The buttons at either side of the slider allow you to increase or decrease 
the zoom by 10% or drag the slider button to choose a particular zoom 
percentage. 

 

Ribbon 

 

Use the Ribbon to find commands you require to complete a task.  

Commands are arranged in tabs that appear on the Ribbon, and each tab's commands relate to a 
specific type of activity, such as inserting items, changing the view, or formatting text in the 
document.  

To reduce screen clutter, contextual tabs appear only when they are applicable. For example, the 
Shape Format tab appears when a graphic object is selected. 

 

Each tab on the Ribbon contains groups with similar commands. For example, the Home tab has a 
Clipboard group that contains commonly used commands like Copy and Paste. 

 

Some groups have a gallery with vertical scroll bars and a third button called the More button to 
access the expanded gallery. 
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To display only the Ribbon tabs and create more vertical space to work in, minimize the Ribbon 
with one of the following methods: 

• Select the Ribbon Display Options ( ) button at the upper right of the screen, then select 

Show Tabs 

• Right-click (or access the context menu) anywhere on the Ribbon and then select Collapse the 
Ribbon 

You can also hide the Ribbon, Quick Access Toolbar, and Status Bar. This maximizes the Excel 
window to give you more space to view the worksheet data.  

• Select the Ribbon Display Options ( ) button at the upper right of the screen, then select 

Auto-hide Ribbon 

You can reset the Ribbon to its default which shows tabs and commands. 

• Select the Ribbon Display Options ( ) button at the upper right of the screen, then select 

Show Tabs and Commands 

Microsoft 365 (Web) and Online 

To customize the ribbon display: 

1. Select the Ribbon drop-down arrow in the bottom-right corner of the Ribbon 

2. Under Show Ribbon, select from the following display options: 

Always show ribbon - Keeps all the tabs and commands on the ribbon visible all the time 

Show tabs only - Displays the tabs without their groups and commands 

Adjust Automatically - Hides the ribbon to maximize screen space when not in use, displays it 
only when you hover your cursor at the top of the screen 

 

 



Unit 1: Getting to Know Excel  Lesson: Work with Excel 

3283-2 © CCI Learning Solutions Inc.  7 

Customize the Quick Access Toolbar 

 

 

The Quick Access Toolbar (QAT) is located at the left of the title bar 
above the Ribbon. By default, it contains the AutoSave indicator and 
the Save, Undo, Redo, and Touch/Mouse Mode command buttons. 
Position the Quick Access Toolbar above or below the Ribbon using 
one of the following methods: 

• Select Customize Quick Access Toolbar > Show Below the Ribbon 

• Right-click the Ribbon and then select Show Quick Access Toolbar Below the Ribbon 

If you frequently use certain Excel commands and features, add them to the QAT. Customize the 
QAT with one of the following methods: 

 

• Right-click any command in the Ribbon and select Add 
to Quick Access Toolbar 

• Select Customize Quick Access Toolbar at the end of 
the QAT and select a command from the displayed list of 
commands  

• Select File > Options > Quick Access Toolbar (or select 
More Commands from the QAT commands list), select a 
category from Choose commands from, select a 
command from the list on the left and select Add. Repeat 
this step for each command you want to add, and then 
select OK 
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Access Workbook Properties 

 

Metadata is information about a file that’s stored within the file. In Excel, metadata is called 
Properties. Some properties are generated automatically by Excel, such as the date and time the 
file was created and last modified, who created it, and the size of the file. You can add additional 
metadata such as a workbook Title or your company name. 

Properties can be useful for sorting, organizing, and finding workbooks in Windows File Explorer. 
Some properties, such as the Title, are used to help people with disabilities understand more about 
the file. 

To add or change properties: 

• File tab > Info, and then enter the property values 

• To access all properties, select the Show All Properties link at the end of the list of Properties  

• To access Advanced Properties, select the Properties drop-down menu > Advanced Properties 

   

Microsoft 365 (Web) and Online 

To view limited properties: 

• Select File tab > Info 
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Check for Issues 

 

Excel contains several tools you can use to inspect your workbook for issues such as hidden personal 
information or accessibility issues.  

The Document Inspector is designed to find hidden or private information in a workbook and 
report it to you in a report. You can decide whether it’s appropriate to leave or remove the data. 

Some of these items include: 

• Comments 

• Metadata 

• Personal Information 

• Hidden data 

To inspect a workbook, select File > Check for Issues > Inspect Document. The Document 
Inspector dialog box presents a list of items for which it can check. Leave selected only those items 
you want to include and select Inspect. The results of the inspection will appear. 

   

Review the results of the inspection. Select Remove All for the types of content you want Excel to 
remove from your workbook. Select Reinspect to check the workbook again or select Close to exit 
the Document Inspector dialog box. 

 

Use the Accessibility Checker to help ensure that users with 
disabilities can access the content in the workbook.  

To use the Accessibility Checker, select the Review tab > Check 
Accessibility. The Accessibility Checker task pane will display the 
inspection results and suggest improvements that can be made.  

Selecting an error item in the Accessibility Checker pane selects the 
item in the worksheet and displays information about how to remedy 
the issue.  
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Select the drop-down arrow to the right of the item in the task pane 
and select one of the Recommended Actions.  

Check Compatibility options is used to check for features not 
supported by earlier versions of Excel.  

Like the Document Inspector, it returns a report which you use to 
determine if the document requires changes before saving to an 
earlier version of Excel or sharing with someone using an earlier 
version. 

To check compatibility, select File > Info > Check for Issues > Check 
Compatibility. 

Microsoft 365 (Web) and Online  

To use the Accessibility Checker: 

• Select the Review tab > Proofing group > Check Accessibility 

 

• The Accessibility Assistant pane appears to the right of the worksheet, listing possible errors and 
warnings. 

 

Note: The Document Inspector and Compatibility are not available online. 
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Create a New Workbook 
To create a new, blank workbook, select File > New > Blank workbook, or CTRL+N.  

 

You can also create a workbook using a template, which is a type of workbook that typically 
contains data, formulas, and formatting, and makes a copy of itself for you to use. The New page 
displays some template examples. 

To create a new workbook from a template, select File > New, select a template, and Create. 

• If you don’t locate a template you want to use, you can enter a search term in the Search for 
online templates field 

• Excel templates that you create and save will appear if you select the Personal tab 

Microsoft 365 (Web) and Online 

To create a new, blank workbook: 

• App launcher (grid icon in the top left corner) > Excel > Create blank workbook or Upload a 
file 
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Save a Workbook 

 

To save a new workbook, select File > Save. 

The first time you save a new workbook, Excel displays the Backstage screen for you to select where 
to save the file. Select a folder from the list of folders recently used to enter the file name or file type. 

Select Browse to display the Save As options so you can enter a file name, file type, and save 
location.  

 
In the Save As dialog box, select Save as type and specify the file type, specify the file location, enter 
a file name without the extension, and then select Save. 

 

Note: The last four characters in the file name are the file extension. It indicates the type of Excel 
file it is (for example, .xlsx is a workbook and .xlst is a template). You don’t need to type the extension 
– it's added automatically when you choose a file type. 
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To save changes to a workbook using the same file name, type, and location use one of the following 
options: 

• Select File > Save 

• On the Quick Access Toolbar, select Save 

• CTRL+S 

To make a copy of an existing file with a new name or change the file location or type: 

• File > Save As, select Save as type and specify the file type, specify the file location, enter a file 
name without the extension, and then select Save 

Microsoft 365 (Web) and Online 

Workbooks are saved automatically in Microsoft 365 (Web) and Online. The file is saved to OneDrive 
and changes are automatically saved as you work.  

To save a copy of the workbook:  

1. File tab > Create a Copy 

 

• Choose Create a copy online > modify the file name if needed and select the location > 
Create a Copy 

 

• When you select Download a copy, a copy of the workbook is saved directly to your 
computer 

To change the workbook name: 

• Select directly in the File Name field in the top-left section of the workspace 

• File tab > Rename > change the name in the File Name field > ENTER 
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Manage Worksheets 
To view a worksheet, select its worksheet tab.  

To show worksheet tabs that aren’t visible, use the tab scrolling buttons at the bottom left of each 
workbook’s window. Alternatively, you can view more worksheet tabs by dragging the resize handle 
to the right which will decrease the width of the horizontal scroll bar.  

  

When you create a new workbook, Excel includes one worksheet by default. You can add more 
worksheets to a workbook. To insert a new blank worksheet into a workbook, use one of the 
following methods: 

• Select the Home tab > Cells group > Insert > Insert Sheet. Excel will add the new worksheet to 
the left of the active worksheet 

• Select the New sheet button . Excel will add the new worksheet to the right of the active 

worksheet 

When you no longer need a worksheet, you can remove it from the workbook by using one of the 
following methods: 

• Right-click (or access the context menu) the sheet tab and select Delete 

• Select the sheet tab and then select Home tab > Cells group > Delete > Delete Sheet 

Before deleting a worksheet: 

• Ensure no formulas elsewhere in the workbook depend on values in the worksheet. 

• Save your workbook before deleting a worksheet because, once deleted, you cannot retrieve a 
worksheet with the Undo command. 
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By default, the first worksheet is named Sheet1, and every new worksheet added is given the next 
number. Rename worksheets to replace these default names with descriptive ones. To rename a 
worksheet, use one of the following methods: 

• Double-click the existing worksheet tab and enter a new name 

• Right-click (or access the context menu) the sheet tab and select Rename 

• Select the sheet tab > Home tab > Cells group > Format > Rename Sheet. 

 

Move or Copy Worksheets  

 

Change the sequence in which the worksheets appear in a workbook to help organize multi-
worksheet workbooks. To move a worksheet within a workbook, use one of the following methods: 

• Right-click (or access the context menu) the sheet tab and select Move or Copy, select a sheet 
in the Before sheet list, and then select OK 

• Drag the sheet tab to the new location 

To create a new worksheet based on an existing one, make a copy of a worksheet. To copy a 
worksheet within a workbook, use one of the following methods: 

• Right-click (or access the context menu) the sheet tab and select Move or Copy, select a sheet 
in the Before sheet list, select the Create a copy checkbox, and then select OK 

• CTRL and drag the sheet tab to the new location 

Microsoft 365 (Web) and Online 

To move a worksheet within a workbook: 

• Drag the sheet tab to the new location 

• Right-click the sheet tab > Reorder… > Reorder selected sheet window > Before sheet: select 
the desired sheet or (move to end) 

     

 To make a copy of a worksheet: 

• Right-click the sheet tab and select Duplicate 
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Lesson 2: Construct Cell Data 
Lesson Objectives 
In this lesson, you will learn about data types and how to enter data, how to move and copy it, and 
basic and advanced paste options. You will discover the Auto Fill tool and how to work with 
columns, rows, and cells. Upon completion of this lesson, you should understand the following: 

 Types of Data 

 Paste Special 

 Advanced Paste Special Options 

 Auto Fill 

 Insert and Delete Columns 

 Insert and Delete Rows 

 Insert and Delete Cells 

 Change Column Width 

 Change Row Height 
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Types of Data 
You can make three main types of entries when you insert data into worksheet cells: 

• Numeric – Numbers, date, or time values. By default, numeric values align to the right in a cell 

• Text – Alphabetic and numeric characters and most printable symbols. If you enter a text value 
that is wider than the cell, it will flow into the adjacent cells if those cells are empty. By default, 
text aligns to the left in a cell 

• Formulas – Formulas are composed of values, cell references, arithmetic operators, and special 
functions for calculating and displaying results. Each cell can have only one formula, for 
example, =A1*.15. When the active cell contains a formula. The formula will appear in the Formula 
bar, whereas the cell will display the result of the formula 

 

 

Paste Special 

 

To control components of what is pasted, use the Paste Options button, the Paste drop-down arrow, 
or the Paste Special dialog box. 

To specify paste options when you paste, copy the data, select where you want to paste it, and then 
use one of the following options: 

• Home tab > Clipboard group > Paste drop-down and select an option 

• Home tab > Clipboard group > Paste drop-down > Paste Special, select options in the Paste 
Special dialog box 

 

To access Paste Special options after pasting, select the Paste Options button at the bottom of the 
pasted range, point to the options in the shortcut menu to preview how the pasted item will appear, 
then select an option to apply it. 
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Use Paste Values to paste only values to remove formulas and formatting.  

To paste only values, select the range, select the location to paste, then select Home tab > Clipboard 
group > Paste drop down > Values. 

 
The pasted content has only values and no formatting. 

 

Use Transpose to rotate copied data when pasting, so the column data is pasted as a row, and row 
data is pasted as a column.  

To transpose a paste, select the range, select the location to paste, Home tab > Clipboard group > 
Paste drop-down arrow > Transpose.  
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Microsoft 365 (Web) and Online 

To use paste special options:  

• Home tab > Clipboard group > Paste drop-down arrow > Paste Special 

 

 

Advanced Paste Special Options 

 

More Paste Special options are available in the Paste Special dialog box.  

Select the Home tab > Clipboard group > Paste drop-down arrow > Paste Special, select an option, 
and select OK. 

 

• Paste - Specifies what components of the data in the Clipboard are pasted to the target cells 

• Operation - Specifies the operation that combines the target cells and data pasted into the 
target cells 

• Skip blanks - Avoids overwriting any existing data in the target cells if there is no copied data 
to be put into that cell 

• Transpose - Rotates the data, so copied data as a column will be pasted as a row, and vice-versa  

When you use Paste Special and Add Operation, the values in the clipboard are added to the values 
already in the paste location range. 
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To use the Paste Special Operation option, copy the range of cells, select the cell where you want to 
paste them, and then use Home tab > Clipboard group > Paste drop-down > Paste Special, select 
the Operation option (Add, Subtract, Multiply, or Divide), and select OK. 

 
Use the Column width option to paste a range of data and include the column widths of the original, 
copied data.  Copy the range of cells, select the cell where you want to paste them, and then use 
Home tab > Clipboard group > Paste drop-down > Paste Special, choose the Column widths, and 
select OK. 

 

Auto Fill 

 

Auto fill is a useful feature that allows you to quickly copy data or extend a data series (like dates, 
numbers, or formulas) across adjacent cells. 

To use Autofill, enter data in a cell (for example, “January” or “1”) and in the following cell. Select both 
cells, then move your cursor to the bottom-right corner of the cell until it becomes a small black 
cross (this is the fill handle). Select and drag the fill handle across the cells where you want to apply 
Autofill.  

Excel will automatically fill the cells based on the pattern it detects (e.g., increasing numbers, 
continuing months, copying formulas). If Excel does not detect a pattern, it will copy the original 
cell value across the selected cells. 

After releasing the fill handle, a small icon appears near the filled cells. Select the drop-down arrow 
to choose one of the following options: 

• Copy Cells – Repeats the original value 

• Fill Series – Continues a pattern (e.g., 1, 2, 3…) 

• Fill Formatting Only – Applies formatting without changing values 

• Fill Without Formatting – Copies values but ignores formatting 

• Flash Fill – Automatically fills based on detected patterns (e.g., splitting names or formatting 
phone numbers) 
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Microsoft 365 (Web) and Online 

To use the Auto fill feature: 

Follow the same steps that you would use in the desktop app, and select the Auto fill menu drop-
down arrow, then select the Copy Cells, Fill Series or Flash Fill option. 

 

 

Insert and Delete Columns 

 

You can insert new columns in an Excel worksheet anywhere, even between columns containing 
data. New columns are inserted to the left of the cell (or column).  

To insert a column, do one of the following: 

• Select a cell or column, Home tab > Cells group > Insert arrow > Insert Sheet Columns 

 

• Select the column heading to the right of the location where the new column will be, and Home 
tab > Cells group > Insert 
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• Right-click (or access the context menu) a cell in the column and select Insert 

 

When you insert multiple columns, the same number of columns you selected will be inserted to 
the left of the selected columns. 

To insert multiple columns, select the same number of columns to the right of where you want the 
new columns to appear, and then do one of the following: 

• Home tab > Cells group > Insert drop-down arrow > Insert Sheet Columns (or Insert) 

• Right-click the selected column headings and select Insert 

Before you delete one or more columns, verify that the columns do not contain any valuable data 
in a portion of the worksheet that is not visible on the screen.  

To delete one column, use one of the following: 

• Select a cell in the column, Home tab > Cells group > Delete drop-down arrow > Delete Sheet 
Columns 

• Right-click a cell in the column to be deleted, select Delete > Entire column > OK 

 

To delete multiple columns, select the column headings for the columns to be deleted, and then 
use one of the following: 

• Home tab > Cells group > Delete 

• Right-click (or access the context menu) the column heading(s) and select Delete 

Microsoft 365 (Web) and Online 

To insert columns: 

• Select a cell or column, Home tab > Cells group > Insert drop-down arrow > Insert Columns to 
the Left 
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To insert multiple columns: 

1. Select the same number of columns to the right of where you want the new columns to 
appear. 

2. Home tab > Cells group > Insert drop-down arrow > Insert Columns. 

To delete one column: 

• Select a cell in the column, Home tab > Cells group > Delete drop-down arrow > Delete Columns 

 

 

Insert and Delete Rows 

 

You can insert new rows in an Excel worksheet anywhere, even between rows containing data. New 
rows are inserted directly above the cell or row you select before issuing the insert command.  

To insert a row, do one of the following: 

• Home tab > Cells group > Insert drop-down arrow > Insert Sheet Rows 

• Select the row heading below the location where the new row is to be inserted, Home tab > 
Cells group > Insert 

• Right-click (or access the context menu) a row heading and select Insert 

To insert multiple rows, select the number of rows below where you want the new rows and then 
use the Insert command. The new inserted rows (the same number as the number of rows you 
selected) will appear above the two highlighted rows.  

To insert multiple rows, select the rows below where you want the new rows to appear and then do 
one of the following: 

• Home tab > Cells group > Insert drop-down arrow > Insert Sheet Rows (or Insert) 

• Right-click (or access the context menu) the selected rows’ headings and select Insert 

Before you delete one or more rows, verify that the rows do not contain any valuable data in a 
portion of the worksheet that is not visible on the screen.  

To delete one row: 

• Select a cell in the row, then Home tab > Cells group > Delete drop-down arrow > Delete Sheet 
Rows 
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• Right-click (or access the context menu) a cell in the row to be deleted, Delete > Entire row > 
OK 

 

• Select the row heading(s) for the row(s) to be deleted, and then Home tab > Cells group > 
Delete. 

• Select the row heading(s) for the row (s) to be deleted, and then right-click (or access the context 
menu) the row heading(s) and Delete 

Microsoft 365 (Web) and Online 

To insert a row: 

• Select a cell or row, Home tab > Cells group > Insert drop-down arrow > Insert Rows Above 

 

To insert multiple rows: 

1. Select the same number of rows below where you want the new rows to appear. 

2. Home tab > Cells group > Insert drop-down arrow > Insert Rows Above. 

To delete a row: 

• Select a cell or row, Home tab > Cells group > Delete drop-down arrow > Delete Rows 
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Insert and Delete Cells 
You can insert or delete one or several cells. Be cautious when inserting and deleting cells because 
rows or columns of data elsewhere might become misaligned. In this example, selecting Shift cells 
down causes the data in column A to become misaligned with the remainder of the data. 

 

In the same example, selecting Entire row keeps the data in each row together. 

 
To insert cells, select a cell or range of cells and then use one of the following options: 

• Home tab > Cells group > Insert (Note that this option doesn’t prompt you to choose whether 
to shift other cells to the right or down.) 

• Home tab > Cells group > Insert drop-down arrow > Insert Cells > Shift cells right or Shift cells 
down 

• Right-click the selected cells and select Insert > Shift cells left or Shift cells up  

When you delete existing cells, Excel shifts the remaining cells over from the right or below to 
replace the deleted cell(s).   

Warning! When you delete cells, any formulas that reference the cell(s) will display an error. 

To delete cells, select a cell or range of cells and then use one of the following options: 

• Home tab > Cells group > Delete (Note that this option doesn’t prompt you to choose whether 
you want to shift other cells to the left or up.)  

• Home tab > Cells group > Delete drop-down arrow > Delete Cells > Shift cells left or Shift cells 
up 

• Right-click the selected cells and select Insert > Shift cells left or Shift cells up  
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Change Column Width 
The standard column width in a new worksheet may not be wide enough to accommodate your 
data. If the column is too narrow and the data is: 

• Text -Excel will display the text by overflowing into adjacent (empty) cells. If those adjoining cells 
have entries, the text will be truncated 

• Numbers - Excel uses several different rules to determine how to display a numeric value in a 
cell: 

▪ If you enter a numeric value slightly larger than the current column width, Excel 
automatically widens the width  

▪ If you enter a numeric value that is much larger than the current column width, Excel 
automatically changes the cell format to scientific notation 

▪ If you reduce the width of a column that contains numbers or dates and Excel can't 
display the number, a series of pound signs (######) will be displayed 

 

To change the width for a column manually use one of the following options: 

• Home tab > Cells group > Format > Column Width 

• Point at the vertical line on the right of the column heading for the column until the pointer 

changes to the  symbol, and then drag to the desired width 

• Right-click the column heading for the column to be adjusted, and select Column Width 

Use AutoFit to change the column’s width to fit the contents use one of the following options: 

• Select the column or a cell in the column and select Home tab > Cells group > Format > AutoFit 
Column Width 

• Or point at the vertical line on the right of the column heading for the column you want to 

adjust until the pointer changes to a  (double-headed arrow) and then double-click. 

To change the width of multiple columns, select the columns first and then use either of these two 
methods. 

You can hide a column(s) in your worksheet for various reasons including printing considerations, 
hiding calculations or data that might confuse the reader, or to prevent other users from viewing 
the data or formulas in the column(s). 

Identify hidden columns by the gaps in the column headers and double-line header divisions. 
Hidden columns remain hidden until you unhide them again. Excel will continue to correctly 
calculate any formulas in hidden cells, or formulas in visible cells that reference hidden cells.  
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To hide one or more columns, select the column heading(s) first and then use one of the following 
options: 

• Home tab > Cells group > Format > Hide & Unhide > Hide Columns 

• Right-click the selected columns and select Hide 

• Drag the right edge of the column header(s) to the left until it is hidden 

To unhide a row or column, select the column headings on both sides of the hidden column(s), and 
then use one of the following options: 

• Home tab > Cells group > Format > Hide & Unhide > Unhide Columns  

• Right-click the double line header division and select Unhide 

• Drag the right edge of the hidden column header(s) to the right  

 

 

Change Row Height 
The standard row height in a new worksheet may not be wide enough to accommodate your data.  

To adjust the height for a row, follow these steps: 

• Select the row or a cell in the row and select Home tab > Cells group > Format > Row Height, 
enter a row height and select OK 

• Point at the bottom of the row heading to be adjusted until the pointer changes to a  symbol 
and then drag. 

• Right-click the row heading for the row to be adjusted and select Row Height. 

 

AutoFit is a time-saving feature of Excel that will automatically adjust row height for you.  
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To change the row height to fit the contents: 

• Select the column or a cell in the row and select Home tab > Cells group > Format > AutoFit 
Row Height 

• Double-click the bottom of the row heading 

You might want to hide one or more rows in your worksheet for reasons similar to why you would 
hide columns. Identify hidden rows by the gaps in the row or column headers and double-line row 
divisions.  

Hidden rows will remain hidden until you unhide them again. Excel will continue to correctly 
calculate any formulas in hidden cells, or formulas in visible cells that reference hidden cells.  

To hide one or more rows, select the row(s) first and then use one of the following options: 

• Home tab > Cells group > Format > Hide & Unhide > Hide Rows 

• Right-click (or access the context menu) the selected rows and select Hide 

• Drag the bottom edge of the row upwards until it is hidden 

To unhide a row, select the row headings on both sides of the hidden row(s) and then use one of 
the following options: 

• Home tab > Cells group > Format > Hide & Unhide > Unhide Rows 

• Right-click the double line header division and select Unhide 

• Drag the bottom edge of the hidden row downwards 
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Lesson 3: Work with Workbooks 
Lesson Objectives 
In this lesson, you will learn about working with Excel views and techniques to work efficiently with 
large worksheets. You’ll also learn how to prepare your workbooks for printing by exploring Page 
Layout and Page Setup options, header and footers, and other print options. Upon completion of 
this lesson, you should understand the following: 

 Window View Options 

 Split View 

 Workbook Views 

 Freeze Panes 

 Page Layout 

 Page Setup 

 Headers and Footers 

 Print Options   
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Window View Options 

 

Change how the worksheet is displayed by using the commands on the View tab of the Ribbon. 

 
Commands in the Zoom group (Zoom, 100%, and Zoom to Selection) change the magnification 
percentage.  

 
To change the zoom by choosing a percentage, select View tab > Zoom group > Zoom, then choose 
a Magnification option in the Zoom dialog box or enter a value in the Custom field. 

 

To change the zoom by fitting a selection, select a range of cells, View tab > Zoom group > Zoom > 
Fit Selection. 

Commands in the Window group change the Excel window. 

 

New Window Opens a second window of the workbook. 

Arrange All Arranges all the Excel windows on the screen in one of four layouts. 

Freeze Panes Locks in place the rows above and the columns to the left of a selected 
cell. 

Split Splits the worksheet into two or four panes based on the cell pointer 
position. 

Hide Hides the active window from the screen. 

Unhide Displays a dialog box listing the windows you’ve hidden to unhide them. 

View Side by Side Places two open workbooks side by side, either vertically or horizontally. 
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Synchronous 
Scrolling 

Scrolls through the worksheets in each pane simultaneously. 

Reset Window 
Position 

Resets the displayed worksheets to equal sizes. 

Switch Windows Lists the files currently open in Excel so you can bring a workbook to the 
front by selecting it. 

  

 

To use New Window to open another window of the active workbook, select 
View tab > Window group > New Window. 

Use Arrange All to arrange additional windows on your screen, select View 
tab > Window group > Arrange All and then, in the Arrange Windows 
dialog box, select Tiled, Horizontal, Vertical, or Cascade. 

 

 

Tiled – All windows are positioned next 
to each other  

 

Horizontal – Each window stretches 
across the entire width of the Excel 
application window 

 

Vertical – Each window stretches from 
the top to the bottom of the Excel screen 
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Cascade – Rearrange worksheets so that 
each one is on top of the next and slightly 
offset to give you a three-dimensional 
view of all open workbooks- 

 

Microsoft 365 (Web) and Online 

The View tab also offers view options in the Zoom and Open groups. 

 

To use the Zoom feature: 

• View tab > Zoom group > Zoom drop-down arrow, then choose a Magnification option. If you 
need to return to 100% zoom, select the Zoom to 100% button (the blue 100 next to 100%)  

To open another window of the active workbook, select View tab > Open group > New Window. 

 

Split View 

 

Use the split feature to view and work in the current active worksheet using two or four window 
panes. You can move within each of the split panes to view and work in different parts of the 
worksheet. Each split pane has its own scrollbar. 

The split will occur above and to the left of the active cell. You’ll get two or four panes, depending 
on the active cell. The example is four panes with D7 as the active cell. 
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To use Split: 

• Select a cell in the worksheet, then on the View tab > Window group > Split. Alter the position 
of either the horizontal or vertical split bar by dragging it with your mouse 

To remove both split bars, go to the View tab > Window group > Split. 

• To remove the vertical split bar, drag it to the far left or far right of the worksheet 

• To remove the horizontal split bar, drag it to the top or bottom of the worksheet 

• Double-click either of the split bars  

 

Workbook Views 

 

You can use three views when working in Excel: Normal, Page Break Preview, and Page Layout.  

Use the View buttons on the status bar to change the view at the bottom right of the screen. 

 

You can change the view in the View tab > Workbook Views group > and choose one of the 
following:  

Normal – The default view uses this view for entering data and working with data. Only the 
worksheet rows, columns, and headers appear. The page break lines only appear if you activate a 
print-related feature such as inserting page breaks or seeing a print preview of the workbook.  

 

Page Break Preview – Use this view to manage and control vertical and horizontal page breaks, 
especially if your worksheet is long, wide, or both. Watermarks display on your worksheet to identify 
which rows and columns will appear on which pages, with the page break lines to mark the 
boundaries. Dotted lines are automatic page breaks; solid lines are manual. To move a page break 
in this view, drag it with your mouse. 
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Page Layout – Use this view to add header and footer information, change margins and layout, and 
adjust how the printed document will appear.  

 

Custom Views – Allow you to save your current page layout settings with a name so that you can 
re-activate them later. 

 

Freeze Panes 

As your worksheet grows, it becomes difficult to view all the data on the screen at the same time. 
When you can’t view row and column headings on the screen as you scroll down or across a large 
worksheet, use Freeze Panes to lock the top row(s) and/or left-most column(s). This will keep row 
and column titles visible while you scroll to a remote part of the worksheet. 

Note: Excel does not allow you to use Freeze Panes and Split Panes at the same time. 
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To use freeze panes, select View tab > Window group > Freeze Panes and then choose one of the 
following: 

• Freeze Panes – The active cell serves as an anchor - all rows above and all columns to the left of 
the active cell remain in view until the feature is turned off. You may freeze more than one row 
or column in place. You can also freeze just the top row(s) or just the leftmost column(s). 

• Freeze Top Row – Excel will freeze the row currently displayed at the top of the worksheet 
window 

• Freeze First Column – Excel will freeze the column currently displayed at the far left of the 
worksheet window 

To unfreeze panes, select View tab > Window group > Freeze Panes and then select Unfreeze 
Panes. 

Microsoft 365 (Web) and Online 

To use Freeze panes: 

• Select the View tab > Freeze group > Freeze Panes 

 

The following menu options are available: 

• Freeze at selection – The active cell serves as an anchor, all rows above and all columns to the 
left of the active cell remain in view until the feature is turned off 

• Top Row – Excel will freeze the row currently displayed at the top of the worksheet window 

• Up to Row – Excel will freeze all rows above the selected cell 

• First Column –Excel will freeze the column currently displayed at the far left of the worksheet 
window 

• Up to Column – Excel will freeze all columns to the left of the selected cell 

 

Page Layout 

 
The Page Layout tab contains three groups you can use to adjust the layout and print settings for 
your worksheet: Page Setup, Scale to Fit, and Sheet Options.  
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The Page Setup group on the Page Layout tab includes the following options: 

 

• Margins – The amount of white space (measured in 
inches) from the edge of the page 

• Orientation – Portrait (vertical) or Landscape 
(horizontal) 

• Size – The size of paper to use for printing 

• Print Area – After selecting a group of cells, select Print Area > Set Print Area to specify to print 
only the range defined as the print area. To clear the print area, select Print Area > Clear Print 
Area 

• Breaks – Manually insert page breaks  

• Background – Insert a picture as a background for the worksheet 

• Print Titles – Specify rows and/or columns that appear at the top/left of every page of printed 
output  

Microsoft 365 (Web) and Online 

 

To access Page Setup options: 

• Page Layout tab > Page Setup group > Page Setup, to adjust the layout 
and print settings for your worksheet 

The Page Setup button includes the following menu options: 

• Printer selection 

• Print area 

• Paper size 

• Orientation 

• Page margins 

• Scaling 

Format and Center on Page options 

When you want to exit the Page Setup view, select ← Back to workbook in the top-left corner of 
the sheet. 

 

Page Setup 

 

Use the Page Setup dialog box to access all the commands found on the Page Layout tab as well 
as additional page formatting options that aren’t available in the Ribbon. 

To open the Page Setup dialog box: 

• File tab > Print > Page Setup 
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• Page Layout tab > Page Setup group > Page Setup dialog box launcher ( ) 

Some commands are only accessible in the Page tab, such as: 

• Scaling – Specifies a percentage to magnify or shrink the size of the worksheet proportionally. 
Use the Fit option to fit the worksheet into the specified number of pages 

• Print quality – Determines the density, or quality, of the print  

• First page number – Specifies the starting page number for the printed worksheet 

 

Use the Margins tab to specify the following print parameters: 

• The amount of white space to leave on each side of the page 

• The distance between the Header and Footer and the top/bottom edge of the page 

• Whether to center the worksheet on the page horizontally or vertically, or both 
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The Sheet tab of the Page Setup dialog box includes the following features: 

• Print area – Specifies a range of cells as the print area 

• Print titles – Specifies rows or columns (or both) to print on every page of the printed output 

• Print – Select options in this section if you want them to appear on the printed pages 

• Page order – By default, Excel prints down the rows, and then across the columns 

 
Additional tools to modify the worksheet are found on the Ribbon. In the Page Layout tab > Page 
Setup group, choose from the following commands: 

• Margins – Choose from preset margin settings  

• Size – Select from various page, envelope or index card sizes  

In the Page Layout tab > Scale to Fit group, choose from the following options:  

• Use the Width and Height options to calculate the correct scale value to fit the worksheet into 
the specified number of pages vertically and horizontally 

• The Scale option enables you to magnify or shrink the size of the worksheet proportionally on 
the page for printing  

 

In the Page Layout tab > Sheet Options group, select the following: 
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• Gridlines - Displays or prints non-printing lines around each cell 

 

• Headings - Displays or prints column (A, B, C) and row (1, 2, 3) headings 

Microsoft 365 (Web) and Online 

To adjust Print area, Paper Size, Orientation, Page margins, Scaling, Format options and center on 
page in the Printer task pane, choose one of the following to open the Printer pane: 

• File tab > Print 

• Page Layout tab > Page Setup 

 

 

Headers and Footers  

 

Headers and footers appear at the top and bottom of every printed page, respectively. Headers 
and footers apply only to the active or selected worksheet(s). Create or modify a worksheet header 
or footer using the Page Setup dialog box or the Print Layout view.  

To create a header and/or footer with the Page Setup dialog box, select the worksheet(s), Page 
Layout tab > Page Setup group > Page Setup dialog box launcher. In the Header & Footer tab, 
choose a preset from the Header and Footer drop-down menus, set additional formatting by 
selecting the checkboxes, and then select OK.  
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For additional options, select Custom Header or Custom Footer. Enter header or footer information 
into the three sections (Left, Center, and Right) or use the command buttons to enter a code such 
as &[Page] to display the page number, and then select OK. 

 

The command buttons listed on the Header and Footer dialog box are: 

• Format Text – Changes the appearance of text 

• Page Number – Current page number 

• Number of Pages – Total number of pages 

• Date – Inserts today’s date 

• Time – Inserts the current time 

• File Path – Current file name and path displayed 

• File Name – Name of the file 

• Sheet Name – Name of the current sheet 

• Picture – Inserts an image 

• Format Picture – Changes the appearance of a picture 

To add or modify a header or footer: 

• Insert tab > Text group > Header & Footer 
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• View tab > Workbook Views group > Page Layout > insert your cursor in the left, middle, or 
right box for the Header or Footer. Then enter text or use the command buttons in the Header 
& Footer tab 

 

 

In the Header & Footer group, select the drop-down arrows to display preset options to apply to 
the header or footer.  

   

Alternatively, choose one of the commands available in the Header & Footer Elements group.  
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Print Options 

 

Set Print Titles to designate specific data rows or data columns (or both) to print on every page of 
the printed output.  

To set print titles in the Page Setup dialog box: 

• Page Layout tab > Page Setup group > in the Print Titles section select the collapse button (

) for the Rows to repeat at top field to shrink the dialog box, and then in the worksheet, 
select the row header(s) for the row(s) (they must be contiguous rows) you want to use as titles 
and ENTER 

• Repeat this process for columns to repeat at the left 

 

• Specify a range of cells as the Print Area so only that range will print by default 

To specify a range of cells as a print area: 

• Select the cell range in the worksheet, then Page Layout tab > Page Setup group > Print Area 
> Set Print Area 

Alternatively, to select a range of cells to print:  

• Select the range of cells on the worksheet, then File > Print, and then under Settings, Print 
Active Sheets > Print Selection 

The Print page in Backstage view contains options for printing including Print Area, Orientation, 
Page Size, Margins, and Scaling. The Print Area drop-down menu includes Print Active Sheets, Print 
Entire Workbook, Print Selection, and Ignore (previously set) Print Area.  

 

The Backstage view Print Settings allows you to select one of four options for printing: 

• Print Active Sheets – Prints the current active worksheet (or multiple selected sheets) 
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• Print Entire Workbook – Prints all worksheets in the entire workbook 

• Print Selection – Prints the currently selected range of cells in the current active worksheet 

• Ignore Print Area – Ignores any previously set print areas 

To print more than one worksheet, but not the entire workbook: 

• Hold CTRL (or SHIFT if the sheets are contiguous), select all the worksheets you want to print, 
then, File tab > Print, ensure Print Active Sheets is selected, and select Print 

Microsoft 365 (Web) and Online 

To modify print options, go to the File tab > Print. 

In the Print Preview window, select from the following options: 

• Print - Choose to print the Active sheet(s), the Entire workbook, or the Current selection  

 

• Format Options - Select to include the Gridlines, Row and Column headings or to print in Black 
and white  

 

To specify a range of cells as a print area: 

• Select the cell range that you would like to print, then on the Page Layout tab > Page Setup 
group > Print Area drop-down arrow, select to Set Print Area, Clear Print Area or Add Print 
Area 

\ 
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Unit 1 Key Terms 
Term Definition 

Accessibility 
Checker  

A tool used to find issues that might make it difficult for users with 
disabilities to access the content in the workbook.  

Active Cell  The cell where you are entering data.  

Auto Fill  Use to copy data or continue sequential patterns in entered data.  

AutoFit  Change a row’s height or column’s width to fit the contents.  

Column Headings  Sequential letters at the top of each column enable you to identify 
columns.  

Contextual Tab  Tabs that appear only when they are applicable.  

Custom Views  Allows you to save your current page layout settings with a name so that 
you can re-activate them later.  

Document 
Inspector  

A tool used to find hidden or private information in a workbook and report 
it to you in a report.  

Extension  The last four characters in the file name that indicate the type of Excel file 
it is.  

File Tab  Select the File tab to open the Backstage view.   

Footers  Footers appear at the bottom of every printed page.  

Formula Bar  Displays the contents of the active cell and can be used to add or edit 
data.  

Formulas  Formulas are composed of values, cell references, arithmetic operators, 
and special functions for calculating and displaying results.  

Freeze Panes  Locks in place the rows above and the columns to the left of a selected 
cell.  

Gallery  Type of menu in the ribbon that displays multiple formatting options.  

Headers  Appear at the top of every printed page.  

Insert Function  Opens a dialog box to help you choose and insert a built-in function.  

Metadata  Information about a file that’s stored within the file.  

Minimize, 
Maximize/Restore 
Down, Close  

Located in the upper right-hand corner of the window, these buttons 
enable you to minimize the application window to a button on the 
taskbar, maximize the program to full screen, restore the window to its 
original size, or close the application window.   

More Button  Button that opens a gallery.  

Name Box  Displays the cell address of the active cell.  

Normal View  The default view used for entering data and working with data.  

Numeric  Numbers, date, or time values, aligns to the right by default.  

Page Break Preview 
view  

Used to manage and control vertical and horizontal page breaks.  
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Page Layout  A tab on the Ribbon where you find controls and settings for printing.  

Page Layout View  Use to add header and footer information, change margins and layout, 
and adjust how the printed document will appear.  

Paste Special  Paste options to control components of what is pasted.  

Print Titles  Specifies rows or columns (or both) to print on every page of the printed 
output.  

Properties  Metadata in Excel, some that’s generated automatically by Excel (such as 
the date and time the file was created and last modified, who created it, 
and the size of the file), and some you add (such as a workbook Title or 
your company name).  

Quick Access 
Toolbar (QAT)  

Located above the Ribbon, the QAT provides quick and customizable 
access to frequently used commands.  

Ribbon  A collection of tabs (such as File, Home, and Insert) that provides quick 
access to commands used to complete a task. Each Ribbon tab relates to 
a type of activity.  

Ribbon Display 
Options  

Button to control what displays on the ribbon: Auto-hide, Tabs, Tabs, or 
Tabs and Commands.  

Ribbon Group  Each Ribbon tab contains groups of related commands to edit, format, or 
enhance items in your documents. Some groups include a dialog box 
launcher button at the bottom right which opens a dialog box or pane 
with more commands and options.  

Ribbon Tab  Commands are arranged in tabs that appear on the Ribbon, and each 
tab's commands relate to a specific type of activity.  

Row Headings  Sequential numbers on the left side of each row enable you to identify 
rows.  

Scroll Bars  Scrolls the spreadsheet to view content that is offscreen and not visible.  

Sheet Tab  The rectangular box at the bottom of a worksheet by which the 
worksheet is accessed and identified.  

Split  Splits the worksheet into two or four panes based on the cell pointer 
position.  

Status Bar  Displays the current cell mode, auto calculations, the View buttons, and 
the Zoom slider.  

Template  A type of workbook that typically contains data, formulas, and formatting, 
and makes a copy of itself for you to use.  

Text  Alphabetic and numeric characters and most printable symbols, aligns to 
the left by default.  

Title Bar  Located at the top of the screen, the title bar indicates the contents of the 
window.   

View Buttons  Change the on-screen views for the worksheet: Normal, Page Layout, and 
Page Break Preview.  

Zoom Slider  Drag the slider button to choose a particular zoom percentage or use the 
buttons at either side of the slider.   
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Unit 2: Formatting Worksheets 
Unit Objectives 
In this unit, you will be able to effectively format worksheets, create and utilize named ranges, 
implement tables, and utilize sort and filter functions to organize and analyze data in Microsoft 
Excel. Upon successful completion of this unit, you should understand the following: 

 Format Worksheets 

 Named Ranges 

 Tables 

 Sort and Filter 
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Lesson 1: Format Worksheets 

Lesson Objectives 
In this lesson, you will use a variety of methods to format cells in a worksheet. Upon completion of 
this lesson, you should be able to understand the following: 

 Format Data 

 Format Numbers 

 Format Dates 

 Format Times 

 Format Decimals 

 Cell Alignment, Indent and Orientation 

 Wrap Text 

 Merge Cells 

 Format Font 

 Format Borders 

 Format Cells 

 Cell Styles 

 Format Grouped Worksheets 

 Conditional Formatting 

 Remove Conditional Formatting 

 Format Painter 

 Clear Cell Contents and Formatting 
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Format Data 

 

How you present your worksheet is almost as important as the data it contains. Formatting is all 
about changing the appearance of the data. You are using the various features of Excel to draw 
attention to parts of the worksheet, or to make the data presented easier to understand. When you 
change the format of a cell, you do not alter its underlying value. 

You should note the following important points: 

• You can format a cell, or a range of cells, either before or after you enter the data. You can even 
format an entire row or column at one time. 

• A cell remains formatted even after you clear the contents of the cell, unless you also clear the 
format or reformat the cell. When you enter new data in the cell, Excel displays the data in the 
existing format. 

• When you paste or fill a cell from another cell, by default you copy the format and the contents 
of the originating cell. This feature enables you to save time, provided you apply the formatting 
before copying. 

Some of the formatting features to change the appearance of your document include different 
fonts or sizes, bold and italic styles, borders around a cell or group of cells, and shading of cells. You 
will find the most used formatting features displayed on the Home tab as well as on the Mini toolbar. 

To format a cell, select the cell, and then use one of the following methods: 

• Home tab > Font, Alignment or Number groups > select the appropriate button 

• Right-click and choose the appropriate formatting from the Mini toolbar 

• Home tab > Font, Alignment or Number group > select the dialog box launcher 

 

Microsoft 365 (Web) and Online 

In Excel Online, you can format cells using the Ribbon or mini toolbar which activates the Format 
pane. 

• Home tab > Font, Alignment or Number groups > select the appropriate button 

• Right-click and choose the appropriate formatting from the Mini toolbar 
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• Home tab > Cells group > Format drop-down arrow > Format Cells 

 

 

Format Numbers 

 

The most common type of formatting in a worksheet is number formatting. Excel provides many 
built-in formats so numbers can be displayed in ways that make them easier to read and 
understand. Even though the appearance of a number may change, the underlying value in the cell 
stays the same. For example, the actual value might be 6798.52, but depending on the format, Excel 
could show it as 6,798.52, $6,798.52, or (6,799). 

To format numbers: 

• Select the cell/s which contain the numbers you want to format, then on the Home tab > 
Number group > Number Format dialog box launcher > Number  

Options in the Number category include: 

• Decimal places - Choose how many digits appear after the decimal (default is 2). If the number 
doesn’t have enough digits, Excel fills with zeroes 

• Comma separator - Adds commas for thousands (example: 6,798.52) 

• Negative numbers - Display in red, with a minus sign, or in parentheses 
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The Currency format is similar to the Number format, but it automatically includes a currency 
symbol (such as $) and shows the comma separator for thousands. 

To apply the Currency format: 

• Select the cell/s which contain the numbers you want to format, then on the Home tab > 
Number group > Number Format dialog box launcher > Currency  

Options in the Currency category include: 

• Decimal places – Choose how many digits appear after the decimal 

• Currency symbol – Select from $, €, £, or other symbols 

• Negative numbers – Display in red, with a minus sign, or in parentheses 

 

 

The Accounting format is also used for monetary values, but it looks slightly different from the 
Currency format. 

To apply the Accounting format: 

• Select the cell/s which contain the numbers you want to format, then on the Home tab > 
Number group > Number Format dialog box launcher > Accounting  

In Accounting formatted cells: 

• Decimal points line up vertically, making columns of numbers easier to compare 

• The currency symbol is aligned to the far left of the cell 

• Negative numbers are always shown in parentheses (this cannot be changed) 

  

Microsoft 365 (Web) and Online 

To apply formatting in the online apps, go to the Home tab > Number group > Number Format 
drop-down arrow > More Numbers Formats… In the All formatting options task pane, choose your 
category and formatting options. 



Lesson: Format Worksheets  Unit 2: Formatting Worksheets 

52  3283-2 © CCI Learning Solutions Inc. 

   

 

Format Dates 

 

The Date format displays numbers as calendar dates. The way a date appears depends on your 
computer’s regional settings: 

• In the United States, the default format is m/d/yyyy (for example, 3/14/2025). 

• In the United Kingdom, the default format is dd/mm/yyyy (for example, 14/03/2025). 

To format dates: 

• Select the cell/s which contain the numbers you want to format, then on the Home tab > 
Number group > Number Format dialog box launcher > Number tab > Date  

▪ Type - Choose your desired format from the list 

▪ Locale (location) - Choose your language/region 

 

Note that the asterisk (*) indicates that this format changes with the computer’s region setting, as 
described at the bottom of the dialog box. 
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Microsoft 365 (Web) and Online 

To format dates: 

• Home tab > Number group > Number Format drop-down arrow > More Number Formats… > 
Number tab > Date 

▪ Type - Choose your desired format from the list 

▪ Locale (location) - Choose your language/region 

 

 

Format Times 

 

The Time format displays numbers as time values. Excel will automatically apply a time format 
based on how you enter the value (for example, 9:30 AM or 21:30). You can then choose a different 
style from the Time category. 

To format times: 

• Select the cell/s which contain the numbers you want to format, then on the Home tab > 
Number group > Number Format dialog box launcher > Number tab > Time 

▪ Type - Choose your desired format from the list 

▪ Locale (location) - Choose your language/region 
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Microsoft 365 (Web) and Online 

To format times: 

• Home tab > Number group > Number Format drop-down arrow > More Number Formats… > 
Number tab > Time 

▪ Type - Choose your desired format from the list 

▪ Locale (location) - Choose your language/region 

 

 

Format Decimals 

 

Percentage – Excel always shows percentage values as 100 times the number value of a cell. For 
example, if a cell value is 0.1234, the cell value will appear as 12.34%. This format shows a percentage 
sign at the right side of the cell. You can also specify the number of decimal places (the default is 2). 

Fraction – The Fraction format converts decimal digits to fractional values based on the fraction 
type that you select. For example, if .25 is the value in the cell, Fraction will change it to ¼. You can 
specify the number of digits or fraction format under Type. 

Scientific – You will usually use this format in scientific applications for very large and very small 
numbers. Excel shows only one digit to the left of the decimal point and you control the number of 
significant digits by specifying the number of decimal places. 

To format decimals, choose one of the following: 

• Home tab > Number group > Number Format dialog box launcher > Number tab > Select from 
one of the following categories: Percentage, Fraction or Scientific. Enter your desired decimal 
places in the Decimal places field 
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• Home tab > Number group > Select the Increase Decimal or Decrease Decimal buttons 

 

Microsoft 365 (Web) and Online 

To format decimals, choose one of the following: 

• Home tab > Number group > Number Format drop-down arrow > More Number Formats… > 
Number tab. Select from one of the following categories: Percentage, Fraction or Scientific. 
Enter your desired decimal places in the Decimal places field 

 

• Home tab > Number group > Select the Increase Decimal or Decrease Decimal buttons  
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Cell Alignment, Indent and Orientation 

 

Alignment refers to how data is positioned within a cell. In Excel, you can align content both 
horizontally (left, center, right) and vertically (top, middle, bottom). 

By default, Excel applies General alignment to new values: 

• Numbers and dates are aligned to the right 

• Text is aligned to the left 

 

You can also indent text within a cell. For example: 

• Country names might use normal alignment 

• State or province names might be indented once 

• City names might be indented twice 

 

To change alignment: 

• Select the cell/s which contain the numbers you want to format, then on the Home tab > 
Alignment group 

Options include: 

• Horizontal alignment – Left, Center, Right, or Justify 

• Vertical alignment – Top, Middle, or Bottom 

• Indent – Increase or decrease indent levels within the cell 

• Orientation – Change the text direction (for example, rotate text vertically or diagonally) 
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The Orientation button allows you to change the direction of the text in a cell. This is useful for labels, 
headings, or when you want to save space on the worksheet. 

To change orientation: 

• Select the cell/s which contain the numbers you want to format, then on the Home tab > 
Alignment group > Orientation 

Options include: 

• Angle Counterclockwise – Rotates text upward to the left 

• Angle Clockwise – Rotates text upward to the right 

• Vertical Text – Displays letters stacked vertically, one below the other 

• Rotate Text Up – Rotates text 90° upward 

• Rotate Text Down – Rotates text 90° downward 

• Format Cell Alignment – Opens the Format Cells dialog box for more detailed control 

 

For more detailed options, go to the Home tab > Alignment group > Alignment Settings dialog box 
launcher > Alignment tab. 
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Microsoft 365 (Web) and Online 

The most common orientation options are the same as the desktop version and can be found on 
the Home tab > Alignment group.  

Additional Alignment options are available when accessing the All formatting options task pane via 
the Home tab > Number group > Number Format drop-down arrow > More Number Formats… > 
Alignment tab. 

 

 

Wrap Text 
Excel allows you to enter very long text in a cell -up to 32,767 characters. By default, if the text is 
longer than the cell width, it will spill over into the empty cells to the right. A way to circumvent this 
is to wrap text so that it stays within the borders of the cell. 

 

To wrap text: 

• Select the cell/s which contain the text you want to wrap, then on the Home tab > Alignment 
group > Wrap Text 

When Wrap Text is turned on: 

• Excel adjusts the row height automatically to fit the text 

• In some cases, you may need to adjust the row height manually 

• Turning Wrap Text off reverts the text to a single line 
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Another option is to shrink the text so it fits on one line inside the cell. 

To apply Shrink to Fit: 

• Select the cell/s which contain the text you want to shrink, then on the Home tab > Alignment 
group > Alignment Settings dialog box launcher > Alignment tab > Text Control > Shrink to 
Fit   

 

When Shrink to Fit is turned on: 

• Excel automatically reduces the font size until the text fits within the cell width 

• Best used for short text that slightly overflows the cell 

• Not recommended for very long text, as the font may become too small to read 

Note: Shrink to Fit is only available in the desktop version of Excel. 

 

Merge Cells 
Merging cells combines two or more cells into one larger cell. This is often used for labels that cover 
a group of cells. 

As illustrated in the example below, January to March can be labeled as Quarter 1 by merging the 
cells above them and April to June can be labeled as Quarter 2 in the same way. When you merge 
cells, Excel removes the dividing lines between them and treats the group as a single cell. 



Lesson: Format Worksheets  Unit 2: Formatting Worksheets 

60  3283-2 © CCI Learning Solutions Inc. 

 
To merge cells and center text: 

• Select the cells, then on the Home tab > Alignment group > Merge & Center to merge the 
selected cells (horizontally or vertically) and center the text across the merged cell 

 
Alternatively, select the drop-down arrow next to Merge & Center for more choices: 

• Merge Across – Merges cells in each selected row but retains original text alignment. Does not 
merge vertically 

• Merge Cells – Merges the selected cells without centering the text 

• Unmerge Cells – Splits merged cells back into their original separate cells  

 

Format Font 
A font is the style of text used in your worksheet. Changing the font affects the appearance of text, 
numbers, and dates without altering the underlying values. Fonts can make your worksheet easier 
to read or help highlight important information. 

The most used font options are available directly on the Ribbon in the Home tab > Font group. 

Font formatting options include: 

• Font – Choose the typeface (e.g., Calibri, Arial) 

• Font Size – Increase or decrease the size of the text 

• Bold – Make text heavier for emphasis 

• Italics – Slant text for emphasis 

• Underline – Add a single or double underline 

• Font Color – Change the color of text 
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For additional settings, go to the Home tab > Font group > Font Settings dialog box launcher. This 
opens the Format Cells dialog box with the Font tab selected. Here, you can access more advanced 
formatting commands such as: 

• Strikethrough – Draw a line through text 

• Superscript / Subscript – Raise or lower text (useful for math or chemical formulas) 

• Special effects – Combine styles such as bold, italic, and underline 

 

The most common formatting menu options are discussed in the table below: 

Font This refers to the typeface of the text characters Excel displays. A set of 
characters in the same typeface is a font. 

Font style Most fonts can be formatted bold, italicized, or both. 

Size Size refers to the height of a character, with a proportionate width. Most of the 
fonts are scalable. That is, they have a variety of sizes. A point is equal to a 
seventy-second of an inch. Thus, twelve-point type is twelve seventy-seconds of 
an inch high, or 1/6th of an inch high. 

Underline You can select various underline styles such as single, double, single 
accounting, or double accounting. 

Color You can select and change the color of the characters. 

Effects You can use special character effects, such as Strikethrough, Superscript and 
Subscript.  

As you select different options in this dialog box, the Preview box shows sample text with the 
options displayed. 
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Format Borders 

 

Borders are lines you can add around cells or ranges of cells to separate groups of data. Borders 
improve readability, especially in worksheets with a large volume of numbers. 

The border feature allows you to: 

• Draw lines on any or all four sides of a cell 

• Choose line thickness, style, and color 

• Add diagonal lines within a cell if needed 

To modify borders, select the cell/s, then on the Home tab > Font group > Borders drop-down arrow. 
Select from the preset options or customize and draw borders. To access further options, select the 
More Borders command to open the Format Cells dialog box. 

  
Border options are discussed in the table below: 

Line Choose a line style or color for the border(s). If you want different lines or colors 
for specific borders, you must select the style or color and then select in the 
Border area for the appropriate border. 

Presets Remove all borders, apply borders on all four outside edges or apply borders 
on all inside edges for the selected cell or range of cells using the three preset 
configuration settings. 

Border Use the buttons to apply or remove borders on specific edges of the selected 
cell or range of cells. The graphics within each button help you view which 
borders you are applying or removing. 
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Microsoft 365 (Web) and Online 

To access additional border options, go to the Home tab > Font group > Border drop-down menu 
> More Border Styles > Border tab in the All formatting options pane.  

 

 

Format Cells 

 

You can fill cells or ranges of cells with background colors to make your worksheet more visually 
appealing. Colors and patterns can: 

• Highlight important areas such as totals rows 

• Differentiate headings from data 

• Draw attention to specific values 

To use the Fill Color command: 

• Select the cell or range you want modify, then on the Home tab > Font group > Fill Color 

Key points to remember: 

• By default, cells have No Fill 

• The Fill Color button will display the most recently used color until a new color is selected 

• Use the Fill Color drop-down arrow to display the color palette, which includes the No Fill option 
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To access all fill settings, use one of the following methods: 

• Select the cell or range > Home tab > Cells group > Format drop-down arrow > Format Cells... 
> Fill tab 

• Home tab > Font group > Font Settings dialog box launcher > Fill tab 

 

The Fill tab has four features: 

• Background color – Choose from a large variety of colors to fill the cell as background for the 
characters 

• Pattern Color – This is the color of the pattern when a Pattern Style is chosen. Nothing appears 
if only a Pattern Color is chosen with no Pattern Style 

• Pattern Style – A variety of lines or dot patterns from which to choose 

 
• Fill Effects – A variety of ways to provide shading between two colors in each cell 

 

Patterns and background colors are distinctly different features. You can use either or both of them 
at the same time. Fill effects cannot be used with patterns or background colors. 
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Microsoft 365 (Web) and Online 

Although Patterns and Fill Effects are not available in the online apps, cell backgrounds can be 
modified on the Home tab > Font group > Fill Color drop-down arrow. The online options include 
an Eyedropper tool, which is used to sample any color from an image or screen, ideal for matching 
existing hues precisely. 

 

 

Cell Styles  
Cell Styles in Excel are used to apply consistent formatting across a worksheet. A style is a preset 
group of formatting settings - such as font, size, color, borders, and fill. Similar to styles in Microsoft 
Word, when you apply a style to a cell, Excel automatically updates its appearance. If the style is 
modified later, Excel will update all cells using that style. This makes it straightforward to maintain 
a consistent appearance throughout the workbook with minimal effort. 

Excel provides a set of prebuilt styles (also called Quick Styles). These include headings, titles, totals, 
input cells, and other preset designs. 

To apply a cell style: 

Select the cell or range, then on the Home tab > Styles group > Cell Styles. From here, you can 
select from the style gallery and apply it to the selected cells. 

 
To view which style is applied to a cell: 

• Select the cell > Home tab > Styles group > Cell Styles. The applied style will be highlighted 
with a border 

• If no style has been applied, the Normal style will be highlighted 
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Note: You must check each cell individually to view its style. 

Styles make formatting consistent, but there are a few important restrictions to keep in mind:  

• Workbook-specific – Styles are saved within each workbook. They cannot be stored in a 
template file. To reuse custom styles, you must copy the original workbook, remove 
unnecessary data, and re-enter the new data 

• Global changes – If you modify a style, Excel updates all cells using that style in every worksheet 
of the workbook 

• Theme-based – Styles are linked to the current workbook theme. If the theme changes (or its 
formatting is updated), the style changes too 

 

Format Grouped Worksheets 

 
In Excel, you can format multiple worksheets at the same time by grouping them. By applying 
changes like fonts, borders, or new rows to the group, you ensure a consistent layout across your 
entire workbook in a single step. 

Formatting features that can be applied across grouped worksheets: 

• Font styles – Bold, italic, font type, and size changes 

• Borders and shading – Apply consistent cell borders or background fills 

• Alignment – Center text, wrap text, or adjust indentation 

• Number formats – Apply Currency, Percentage, Date or other formats 

To group worksheets, use one of the following methods: 

• Select the first sheet tab + SHIFT > select the last sheet tab 

• Select and hold CTRL > select non-adjacent sheet tabs 

Apply formatting as usual using the Home tab > Font, Alignment or Number groups. 

To ungroup worksheets: 

• Right-click a grouped sheet tab > select Ungroup Sheets 
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Conditional Formatting 
Conditional formatting is a powerful tool you can use to display the data in cells one way for some 
values, but another way for others, without the additional effort of manually changing the 
formatting each time you modify data or add new data to a worksheet.  

The Ribbon offers several choices for setting up conditional formats. 

Highlight Cell Rules Use this option to highlight cell values based on their relation to specific 
values you enter. 

Top/Bottom Rules Use this option to activate the conditional formatting on the top or 
bottom ranking cells in a range. 

Data Bars You can use conditional formatting to embed a bar chart into a selected 
range of cells based on the value in each cell. 

Color Scales Use this type of conditional formatting to show the relative value of each 
cell to each other cell using color gradients. 

Icon Sets You can use this type of conditional formatting to highlight values using 
icons. 

To apply conditional formatting: 

• Select the range that you want to apply formatting to, then on the Home tab > Styles group > 
Conditional formatting drop-down arrow 

 

Formatting options include only the font styles (regular, bold, italics, or bold and italics), font colors, 
number formats, borders, and background fill colors and patterns. You may not choose different 
font names or font sizes in a conditional format. 
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Remove Conditional Formatting  
You can remove conditional formatting when it is no longer needed. This can be done for specific 
cells or for the entire worksheet. 

To clear conditional formatting: 

• Home tab > Styles group > Conditional Formatting drop-down arrow > Clear Rules 

Options include: 

• Clear Rules from Selected Cells – Removes conditional formatting only from the highlighted 
range. Other cells in the original range keep their rules 

• Clear Rules from Entire Sheet – Removes all conditional formatting from every cell in the 
worksheet 

 

If you clear formatting only from selected cells, Excel will continue to apply the rule to the remaining 
cells. Example: If you are using a Top 10% rule, removing formatting from some cells may cause 
different values to enter the “Top 10%” category. Clearing the entire sheet ensures that no 
conditional formatting remains anywhere in the worksheet.  

 

Format Painter  
After formatting a cell or range, you may want to duplicate the formatting elsewhere in the 
worksheet. Excel’s Format Painter tool allows you to copy formatting from one area to another. 

 
Use the Format Painter: 

1. Select the cell or range of cells with the formatting you want to copy, then on the Home tab > 
Clipboard group > Format Painter (the pointer will resemble a paintbrush). 

2. Select the target cell to apply the formatting. The Format Painter turns off automatically after 
one use. 
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To apply the Format Painter to multiple target cells: 

1. Select the cell or range of cells with the formatting you want to copy, then on the Home tab > 
Clipboard group > Double-click the Format Painter button to keep the tool active 

2. Continue selecting additional target cells to apply the formatting. 

3. When finished, turn off the Format Painter by selecting the button again or using the ESC key. 

 

Clear Cell Contents and Formatting 
The Clear feature allows you to remove cell contents or specific components (such as formatting or 
comments) without deleting the actual cells. This means the structure of your worksheet remains 
intact. 

To access the Clear options: 

• Home tab > Editing group > Clear drop-down arrow 

After selecting a cell or range and then selecting the Clear arrow, you can choose from different 
options: 

 

Clear All Remove all data, cell formats, hyperlinks, and comments from 
the selected cell(s). 

Clear Format Remove only the formatting and hyperlinks from the selected 
cell(s) while the data and comments remain unchanged. The 
cell formatting reverts to the default settings. 

Clear Contents Remove only the data and hyperlinks from the selected cell(s). 
Because the cell formatting is unchanged, any new data 
entered the same cells afterward uses that formatting again.  

Clear Comments and Notes Remove only the comments part of the selected cell(s).  

Clear Hyperlinks Convert any hyperlinks in the selected cell(s) to text. When 
selected, the Clear Hyperlinks icon ( ) appears next to the cell, 

allowing you to clear only the hyperlink or the hyperlink and its 
formatting. The topic of hyperlinks will be covered in more detail 
in a later lesson. 

Remove Hyperlinks Remove both the hyperlink and hyperlink automatic formatting.  

In contrast to the Clear feature, the DELETE command removes the selected cells, rows, or columns 
entirely from the worksheet. The surrounding cells then shift to fill the empty space. 
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Lesson 2: Named Ranges 

Lesson Objectives 
In this lesson, you will use a variety of methods to format cells in a worksheet. Upon completion of 
this lesson, you should be able to: 

 Create Named Ranges 

 Go to Named Range 

 Use Named Ranges 

 Modify and Delete Named Ranges 
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Create Named Ranges  

 

As worksheets grow larger, it can become difficult to keep track of all the cells. To make navigation 
and formulas easier to understand, you can assign a meaningful name to a cell or range of cells. 

• A named range helps users quickly identify the purpose of the data 

• Named ranges appear in the Name Box, located to the left of the formula bar 

• The name is displayed only when the entire range is selected 

Using named ranges not only improves readability but also makes formulas straightforward to 
enter and understand. For example, a formula that references Sales_Q1 is much clearer than one 
referencing B2:B10. 

To define a range with a name, select the range and then use one of the following methods: 

• Home tab > Name Box > enter your desired text 

 

• Formulas tab > Defined Names group > Define Name > in the New Name dialog box > Name: 
enter your desired text > OK 

 

In addition to creating individual names, Excel allows you to create multiple named ranges at once 
by using the row or column headings already in your worksheet. This is useful when your data table 
has clear labels, such as months or names. 

To create multiple named ranges: 

• Select the range of cells, including the row and/or column headings you want to use as names, 
then on the Formulas tab > Defined Names group > Create from Selection 

In the Create Names from Selection dialog box, choose where the headings are located (Top row, 
Left column, Bottom row, Right column). Excel will then automatically assign names to each row or 
column of data using those headings. 
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Microsoft 365 (Web) and Online 

To define a range with a name, use one of the following methods: 

• Select the range and navigate to the Home tab > Name Box > enter the range name and select 
ENTER 

• Or go to the Formulas tab > Name Manager group > Name Manager  

 

▪ The Name Manager pane will open. If it is the first named range of the worksheet, select 
Define Name... 

 

▪ In the Name field, enter a reference name for the range 

▪ In the Refers To field, enter the cell range or select the cells in the worksheet 

▪ Select Save to create the named range 

 

The new range will now be visible in the Name Manager pane. To add another range, select the + 
New button in the Name Manager.  
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Go To Named Range  

 

Moving from cell to cell in a worksheet is very straightforward because the process is the same as 
with other Windows programs. You can select a cell that appears on the screen by selecting it. If 
you need to scroll to sections of the worksheet that are currently off the screen, use the scroll 
buttons.  

In Excel, you can use the method of jumping to a specific cell (if you know exactly what the cell 
address is) by using the Go To feature. 

With very large worksheets, the Go To feature helps you to navigate more precisely. To display the 
Go To dialog box, use one of the following methods:  

• Home tab > Editing group > Find & Select drop-down arrow > Go to... 

• Select CTRL+G 

 

Select Special... to navigate to precise features in the worksheet, such as Notes, Formulas, 
Conditional formats or Precedents to name a few. 

 
Alternatively, you can use the Name Box located to the left of the formula bar to select a named 
range of cells or to jump to a specific worksheet cell. 
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Microsoft 365 (Web) and Online 

The Go To dialog box in the online apps has limited functionality compared to the desktop version.  

To open the Go To dialog box: 

• Home tab > Editing group > Find & Select drop-down arrow > Go To 

 

 

Use Named Ranges 

 
Range names not only make spreadsheets straightforward to read but also help reduce errors. 
Once you define a name for a cell or a range of cells, you can use that name in formulas instead of 
cell references. 

For example: 

• Formula with cell references: =C7–C18 

• Formula with a range name: =Expenses 

If you mistype a cell reference (e.g., =C7–C81), Excel will not warn you - it will calculate using the 
incorrect cells. However, if you mistype a range name, Excel will not find a match and will display 
an error, helping prevent unnoticed mistakes. 

Insert a range name in a formula with one of the following methods: 

• Select a cell and begin entering a formula. Place the cursor where you want to insert the range 
name, then enter the first letter of the name and select it from the list that appears 

• Formulas tab > Defined Names group > Use in Formula drop-down arrow and select the 
desired range name 
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Range names are also helpful if the cell range changes later. For example: The range name 
Expenses refers to cells C10:C18. You extend the range to C10:C19. Because formulas use the range 
name Expenses, the update is automatic for every formula in the workbook. Without range names, 
you would need to manually update all formulas containing C10:C18, which increases the chance of 
errors. 

Microsoft 365 (Web) and Online 

To use a range name in the online apps, select a cell and begin entering a formula. Place the cursor 
where you want to insert the range name, then enter the first letter of the name and select it from 
the list that appears. 

 

 

Modify and Delete Named Ranges 

 
You can use the Name Manager to modify and delete range names or change the cell range 
references. 

 
To edit or delete a named range: 

• Formulas tab > Defined Names group > Name Manager > Choose Edit… or Delete 
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Be cautious when deleting named ranges. When you delete a named range, any formula that refers 
to this name no longer displays the correct value.  

Microsoft 365 (Web) and Online 

To open the Name Manager pane: 

• Formulas tab > Name Manager group > Name Manager > Choose to Edit (pencil icon) or select 
More Options (three dots …) to Select... or Delete the range 
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Lesson 3: Tables 

Lesson Objectives 
In this lesson, you will use various methods to create and format tables in a worksheet. Upon 
completion of this lesson, you should be able to understand the following: 

 Create a Table 

 Name a Table 

 Apply Table Styles 

 Table Style Options 

 Rows and Columns 

 Total Rows 

 Convert a Table to a Cell Range 
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Create a Table 
Many worksheets consist of a rectangular block of data in which the rows and columns of data have 
a common structure and format. Excel offers you the ability to define this block as a table. When 
you define a block of data as a table, you can use a variety of table tools for selecting summary 
formulas, formatting, sorting, and filtering.  

To create a table, the data must be contiguous. That is, there must not be any blank rows or columns 
in the range of cells. Also, the data must be arranged in row order, with an optional header at the 
top of each column and the data listed below. 

To convert a selected range of cells containing data to a table, use one of the following methods: 

• Home tab > Styles group > Format as Table drop-down arrow > choose a table style 

• Insert tab > Tables group > Table 

The Create Table dialog box appears. If the cells containing headers are included in the selection, 
be sure to select the My table has headers check box. Otherwise, default headers will be inserted 
at the top of the data. 

  

 

Name a Table 
When you create a table, Excel automatically assigns it a default name such as Table1, Table2, and 
so on. While these names work, it’s much more straightforward to manage your workbook if you 
give your tables meaningful names. 

To rename a table: 

• Select the table > Table Design tab > Properties group > Table Name: enter the new name 

 

Once your table has a name, you can use that name in formulas. For example: 

• =SUM(CallVolume) - Adds all the numeric values in the table named CallVolume 

• =SUM(CallVolume[Sales Inquiries]) - Adds only the numbers in the Sales Inquiries column of the 
CallVolume table 

This method of entering formulas is called a structured reference.   



Lesson: Tables  Unit 2: Formatting Worksheets 

80  3283-2 © CCI Learning Solutions Inc. 

 

Structured references make formulas straightforward to read and reduce the possibility of errors. If 
you reference the entire table, Excel will include every type of data - numbers, dates, times, and 
even text - because it treats them as numeric values. This can lead to incorrect results. 

 

Apply Table Styles 
By default, the workbook’s theme is applied to all tables in that workbook. A table style is a set of 
colors and formatting options that format the table appearance. For example: shading for rows, 
bold headers, or accent colors. You can change the style of an individual table at any time by 
choosing a different option from the Table Styles gallery on the Table Design tab. 

To change the style of a table: 

• Select the table > Table Design tab > Table Styles group > choose a style from the Table Styles 
gallery drop-down menu 

If you don’t want any style colors, you can remove them: 

• Select the table > Table Design tab > Table Styles group > Table Styles gallery drop-down 
menu > None (top-left option) 
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Table Style Options 
When you create a table, Excel automatically applies the current workbook theme and adds an 
AutoFilter icon (a drop-down arrow) next to each column heading. This icon lets you sort or filter 
the data in that column. Excel also adds the Table Design tab to the Ribbon, giving you more tools 
to manage your table. 

The Table Styles group provides pre-designed styles you can apply to change the appearance of 
your table, such as header colors, shading, or accents. You can customize your table by turning 
options on or off in the Table Style Options group. 

To access these options: 

• Select the table > Table Design tab > Table Style Options group 

 

The available options are: 

• Header Row - Shows or hides the header row (on by default) 

• Total Row - Adds a total row at the bottom of the table. When activated, Excel automatically 
moves any data below the table down by one row 

• First Column / Last Column - Boldfaces the first or last column (both off by default) 

• Banded Rows - Shades alternating rows with two colors to make wide tables straightforward 
to read (on by default) 

• Banded Columns - Shades alternating columns with two colors (off by default) 

• Filter Button - Shows or hides the AutoFilter icons in the header row 

 

Rows and Columns 
After a table is created, you can still add or remove rows and columns of data. Excel automatically 
expands or contracts the table to include these changes. 

 

Add columns and rows automatically: 

• New Column - Enter data in the first blank column to the right of the table. Excel will 
automatically extend the table to include it 
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• New Row - Enter data in the first blank row below the table. Excel will extend the table, unless 
the Total Row feature is activated 

To insert rows and columns in the middle of a table: 

• Home tab > Cells group > Insert drop-down arrow  

▪ Choose from the following options: 

o Insert Table Rows Above 

o Insert Table Rows Below 

o Insert Table Columns to the Left 

o Insert Table Columns to the Right 

To delete rows and columns in the middle of a table: 

• Home tab > Cells group > Delete drop-down arrow > choose to delete a row or column 
depending on which cell is active 

  

 

Total Rows 
The Total Row option in an Excel table lets you quickly calculate summaries, such as totals, 
averages, or counts. By default, Excel uses the SUBTOTAL function, which is useful because it can 
include or ignore hidden rows. You can also choose other functions such as AVERAGE, COUNT, MIN, 
or MAX. 

To add a Total Row: 

• Select any cell in the table > Table Design tab > Table Style Options group > check Total Row 
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Each column in the Total Row can display a different calculation. 

Select the drop-down arrow in the Total Row cell for the column > choose the function you want 
(for example, SUM, AVERAGE, MAX, etc.) 

  
The example above illustrates: 

• In cell B10, the SUM function can display the total revenue for 2021 

• In cell C10, the MAX function can display the highest revenue generated in 2020 

You can turn the Total Row off or back on at any time. Excel remembers the formulas you applied, 
so you don’t have to re-enter them. 

 

Convert a Table to a Cell Range 
If you no longer need your data in a table format, you can convert it back to a regular range of rows 
and columns. This removes the special table features but keeps your data and any formatting in 
place. 

Convert a table to a range: 

• Select any cell in the table > Table Design tab > Tools group > Convert to Range 

 

Excel will display a message box asking you to confirm. Select Yes to continue. 

 

As illustrated in the example below, the worksheet will appear the same, but column headers no 
longer display the AutoFilter icons (drop-down arrows). The Table Design tab is also removed from 
the Ribbon.   
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Lesson 4: Sort and Filter 

Lesson Objectives 
In this lesson, you will use various methods to sort and filter data in a worksheet. Upon completion 
of this lesson, you should be able to understand the following: 

 Multi-Level Sort 

 Custom Lists 

 Filter Data 
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Multi-Level Sort  
Sometimes sorting by only one column is not enough. For example, in a customer list, several 
people may share the same last name. In this case, you can sort by two columns - first by Last Name, 
then by First Name - to organize the list correctly. 

To sort by multiple columns, choose one of the following methods to open the Sort dialog box: 

• Home tab > Editing group > Sort & Filter drop-down arrow > Custom Sort 

• Data tab > Sort & Filter group > Sort 

In the Sort dialog box, you can: 

• Select the first column to sort by (e.g., Airline) 

• Add a second column (e.g., flight) 

• Continue adding levels if needed (e.g., Destination) 

• Choose the order for each column (A to Z, Z to A, Smallest to Largest, etc.) 

 

The settings in the Sort dialog box determine how the data is to be sorted: 

Add Level, Delete 
Level, Copy Level 

Add, delete or copy columns (or rows) in this dialog box to be used as 
sort keys.  

Move up/Move down Change the selected sort level higher or lower in the sorting sequence. 

Options Access a dialog box that allows you to sort top to bottom or left to right 
and choose whether to treat the data as case-sensitive. 

My data has headers Tells Excel to treat the first row (or column) of cells as labels or titles for 
the data below (or to the right). 

Column/Row Identifies the column or row to be used for sorting. The sequence of 
these columns or rows specifies the sorting level. 

Sort On Include Cell Values (cell data), Cell Color, Font Color, or Conditional 
Formatting Icon. These options identify what to use in the cells for 
sorting. 
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Order This option indicates whether to sort the data in ascending (A to Z, 
Smallest to Largest, Oldest to Newest) or descending (Z to A, Largest 
to Smallest, Newest to Oldest) order. 

Sort by This is the primary sort key: the first column or row Excel will use to 
sort the data. 

Then by These are optional columns or rows for sorting if multiple rows have 
the same primary sort key. You can select up to 64 columns or rows as 
sort levels. 

Note: You can sort data in any range of cells even if they are not constructed as a table.  

 

Custom Lists 

 
Built-in custom lists allow you to sort data by days of the week or months. Excel also has the option 
to create custom sorts. This is useful when you have data that doesn’t sort well alphabetically such 
as small, medium, large or first, second, third.  

To sort data by a custom list: 

1. Select the columns to sort > Data tab > Sort & Filter group > Sort. 

2. In the Sort dialog box > Sort by drop-down arrow > choose the column to sort. 

3. Order drop-down arrow > Custom List. 

4. Select the list you want to use, then select OK. 

 

To create your own custom list: 

1. In Custom lists: select NEW LIST. 

2. In List entries: enter the list data separated by a comma, then select OK 
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Filter Data  
Another way to locate information in a large worksheet is to use a filter. Filtering allows you to hide 
rows you don’t need and display only the rows that meet your criteria. The AutoFilter displays only 
the rows that match your selected conditions. All other rows remain hidden until you change the 
filter criteria or turn the filter off. 

You can filter data using the AutoFilter icons (drop-down arrows) that appear on the right side of 
each column heading: 

• If the data is formatted as a table, AutoFilter icons are turned on automatically 

• If the data is not a table, you can activate filters manually: 

▪ Home tab > Editing group > Sort & Filter drop-down arrow > Filter 

 

▪ Data tab > Sort & Filter group > Filter 

  

Once activated, select the AutoFilter icon on a column heading to: 

• Filter values that meet specific criteria (e.g., show only “Canada” from a Country column) 

• Sort the column in ascending or descending order 
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• Filter by color if the column contains formatted cells 

 

Excel provides selection criteria that are specific to columns containing text, numbers or dates, such 
as the following:  

Numbers – Evaluate numeric data in the selected column using any of the following: 

• A comparison operator such as equals, greater than, or less than 

• The top 10 values 

• All rows above or below the average of all values in the column 

• A custom filter that allows you to select more complex criteria  

 
Text – Evaluate text data in the selected column using any of the following: 

• A comparison operator such as equals, greater than, or less than 

• Begins or ends with a snippet of text 

• Contains or does not contain a snippet of text 

• A custom filter that allows you to select more complex criteria   
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Dates – Evaluate date-type data using a wide variety of criteria such as: 

• Before, After, Between 

• Tomorrow, Today, and Yesterday 

• Next Week, Next Month, Next Year 
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Unit 2 Key Terms 
Term Definition 

Alignment  Refers to the position or placement of data within the cell; you can align the cell 
contents horizontally or vertically.  

AutoFilter  Finds and displays the rows where the value in the selected column meets your 
specified criteria.  

AutoFilter Icon  An arrow that appears next to each column title and can be used to apply various 
options.  

Banding  Use different color shades for alternating rows.  

Borders  The line type or style that can be applied to one or more cells.  

Built-in Custom 
Lists  

Sort data by specific order such as weekdays or months.  

Cell Styles  A grouping of specific format settings for a cell.  

Clear  Use to remove the contents (or certain components that you choose) from the 
cell or a range of cells.  

Conditional 
Formatting  

A tool to use to display the data in cells one way for some values but another way 
for others.  

Convert a Table  Choose to return to a regular set of rows and columns without the table 
definition.  

Custom 
AutoFilter  

Allows you to specify exactly how you want to filter the data.  

Fill Color  A feature that enables you to apply a background color to the selected cell(s).  

Fill Patterns  A feature where you can apply a pattern style to the background of the selected 
cell(s).  

Filter  Hide rows of data you are not interested in viewing.  

Font  Refers to the typeface of the text characters, such as Times New Roman, Calibri, 
Century Block, Helvetica, etc.  

Format Cells 
Dialog Box  

A dialog box you can activate to select various formatting options for a selected 
cell(s). This dialog box contains various tabs to address different types of 
formatting.  

Format Painter  A tool that enables you to copy the cell formatting from one area on the 
worksheet to another.  

Formatting  Change the appearance of the data using various features to draw attention to 
parts of the worksheet, or to make the data presented clearer to understand.  

Go To Feature  A quicker method of jumping to a specific cell or object.  

Indented  Contents in a cell are positioned at least one character from the left edge of the 
cell to create an indented appearance.  

Merging Cells  A feature commonly used on text labels to identify a group of cells together.  
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Name Manager  A dialog box where you can modify and delete range names, or change the cell 
range references.  

Named Ranges  Add a meaningful name for a cell or range of cells for users to understand the 
purpose of the cells.  

Orientation  A button that allows you to change the direction of the characters in a cell in 
various ways.   

Quick Styles  A set of prebuilt styles provided in Excel to apply a common type of formatting 
for specific data, such as Headings or currency numbers.  

Shrink to Fit  An option that shrinks the font size to fit the cell.  

Structured 
Reference  

Reference individual columns within the table by adding the column title within 
square brackets.  

Table  A rectangular block of data in which the rows and columns of data have a 
common structure and format.  

Theme  A set of pre-defined formats that can be applied to a worksheet for a consistent 
formatted layout and color.  

Total Row  An option you can turn on or off for a table where you can select a built-in 
function such as sum or average.  

Wrap Text  Force the text content in a cell to stay within the left and right boundaries of the 
cell, increasing the height of that row to accommodate the full length of the 
text.   
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Unit 3: Formulas and Functions 
Unit Objectives 
In this unit, you will learn how to use different types of formulas, including functions for calculations, 
working with text, and dealing with dates and times. Upon successful completion of this unit, you 
should understand the following: 

 Formulas 

 Functions 

 Text Functions 
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Lesson 1: Formulas 
Lesson Objectives 
In this lesson, you will learn about formulas, what they are, how they work, and how to insert basic 
formulas and use built-in functions to perform calculations in a workbook. Upon completion of this 
lesson, you should be able to understand the following: 

 Simple Formulas 

 Edit a Formula 

 Identify Cell Reference 

 Cell Reference 

 Mixed Cell Reference 

 Ranges and Tables 

 Display Formulas  

 Copy or Move a Formula 
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Simple Formulas  
In Excel, every worksheet cell can use a formula. A formula is simply a calculation involving any 
combination of values, cell references, and/or built-in functions. To access a built-in function, you 
would select the Insert Function icon in the formula bar. Use the Insert Function dialog box to 
assist you in creating the correct formula. 

 

Suppose you have a worksheet with some formulas: 

 

The formulas used in this worksheet are described in the example below: 

Cell Formula/Value Description 

A1 10 A constant value – numeric in this case. Every workbook with formulas will 
usually have at least one constant value.  

B1 =A1 References the current value in cell A1. No changes or calculations are 
done to the value in cell A1, other than copy it over. If the value in cell A1 is 
changed, cell B1 will automatically display the new value. 

C1 =A1*8 References the value in cell A1 and multiplies it by eight. 

D1 =C1/5 References the value in cell C1 and divides it by five. Digits to the right of 
the decimal point will also be displayed if necessary. Note that if the value 
in cell A1 changes, then the value in cell C1 will change, which will cause 
the value in this cell to change in a cascading effect.  

E1 =SUM(A1:D1) References a built-in function called SUM (also known as AutoSum) to 
calculate the sum total of all cells in the range from A1 to D1. Note that if 
the value in cell A1 changes, then the values in cells B1, C1, and D1 will also 
change at the same time, which will cause the value in this cell to change 
as well.  

Let’s change the value in cell A1. All the formulas are automatically recalculated, and the worksheet 
will now appear: 
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The table illustrates a comparison of how these numbers were calculated using the previous value 
(10) and the new value (11) entered in cell A1: 

Cell Formula Old Value New Value 

A1   10  11 

B1 =A1 10 11 

C1 =A1*8 80 (=10 x 8) 88 (=11 x 8) 

D1 =C1/5 16 (=80 ÷ 5) 17.6 (=88 ÷ 5) 

E1 =SUM(A1:D1) 116 (=10 + 10 + 80 + 16) 127.6 (=11 + 11 + 88 + 17.6) 

This example demonstrates that by using formulas, you can have the computer do the calculations 
quickly. You changed the value in only one cell. Excel knows which sequence to perform all the 
calculations, ensuring that all the results are correct.  

Excel does not display the formula you enter into a cell in the worksheet, only the result of the 
formula.  

 

Edit a Formula 
When a formula is entered into a cell, it will also appear in the formula bar.  

 
To edit a formula, you will select the cell that contains the formula you want to edit.  Then choose 
one of the three methods:  

• Edit the formula directly in the Formula Bar by selecting in the formula bar to activate the 
formula 

• Double-click the cell that contains the formula and then you can edit the formula right in the 
selected cell 

• Select F2 on your keyboard and you can edit the formula right in the selected cell. 

 

Identify Cell Reference 
Efficiency in Excel often comes down to how cell addresses behave when they are moved or copied. 
Depending on the goal, Excel can either shift the data source automatically or lock onto a specific 
point. 

By default, Excel uses relative cell address. This means the formula acts as a set of directions 
relative to its current position (e.g., "add the three cells directly above this one"). When a relative 
formula is copied to a new column or row, Excel automatically adjusts the cell references to match 
the new location. 
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For example: 

• If a formula in Column A adds up three rows, copying that formula to Column B results in Excel 
automatically adding the three rows in Column B instead 

• This is perfect for budgets or schedules where the same math needs to be repeated across 
different months or categories 

 

There are instances where a formula needs to point to one specific cell, regardless of where the 
formula is copied. This is known as an absolute cell address. It creates a fixed reference point that 
never shifts. 

To transform a relative address into an absolute one, a dollar sign ($) is placed before the column 
letter and the row number.  

In the example below, cell F1 is referenced as part of a formula in cell C3. Excel will lock onto cell 
$F$1, regardless of where the formula is moved or copied to. This is an essential feature when 
referencing a single constant value, such as a tax rate, a goal, or a specific date, that applies to many 
different calculations. 

 

 

Cell Reference 
In Excel, you don't have to limit your math to single numbers. You can link individual cells or even 
large blocks of data to a single formula. A cell reference acts as a pointer to data located elsewhere.  
Once an equal sign (=) is active, a reference can be added by: 

• Entering the cell reference (or cell address) directly (like A1) 

• Selecting or dragging across a group of cells  

A cell range is a rectangular block of cells treated as a single group. To define a range, Excel uses a 
colon (:) to connect the top-left corner to the bottom-right corner. Ranges can be a single row, a 
single column, or a large "block" covering multiple rows and columns. 

Consider the following example of a range: <Starting Cell> : <Ending Cell> (or C11:E18) 

Ranges are designed to work within functions or arrays - for example =SUM(C11:E18). A range cannot 
be used with basic operators on its own. The formula =F9+C11:E18 will result in an error in Excel.  



Lesson: Formulas  Unit 3: Formulas and Functions 

98  3283-2 © CCI Learning Solutions Inc. 

  

The cell range can be one-dimensional with all cells in the same row or column, two-dimensional 
with multiple rows and columns, or three-dimensional, spanning more than one worksheet. Cell 
range addresses can also include entire rows or columns.  

Formula What it calculates 

 =SUM(B:B) Every value in column B. 

=SUM(B:C) Every value in both column B and column C. 

=SUM(3:3) Every value located in row 3. 

 

 

Mixed Cell Reference  
Cell addresses do not have to have both absolute column and row references. You can have mixed 
cell references. This allows one part of the cell address to move freely while the other part stays 
fixed. The column reference can be absolute and the row reference relative (for example, $E5). If a 
formula including this reference is copied to a new location, only the column reference ($E) is 
constant, and the row reference is adjusted for the new location. 

Conversely, if you copy a formula including a cell reference with an absolute row reference and a 
relative column reference (for example, E$5) to a new location, Excel will adjust only the column 
reference for the new location. This adds flexibility for creating cell formulas, which will become 
increasingly important as your worksheets become more complex. 

A general strategy is if you intend to copy the formula to other cells in the same row and keep the 
column reference locked, place the $ in front of the column letter. If you intend to copy the formula 
to other cells in the same column and keep the row reference locked, place the $ in front of the row 
number. 

Manually entering dollar signs can be slow and prone to errors. Excel provides a dedicated keyboard 
shortcut - the F4 key - to cycle through reference types instantly. 

How to use the shortcut: 
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• During entry - While you are entering a formula and have just selected a cell address (like A1), 
select F4 

• Editing later - If a formula is already finished, double-click the cell to edit it. Place your cursor 
inside the cell address you want to change and select F4 

Each time you select the F4 key, Excel rotates the "lock" (the dollar sign) through four different 
states. Understanding this cycle helps you reach the correct reference type with just a few taps. 

Number of 
selections 

Result Reference Type What is locked? 

1  $A$1 Absolute Both the column and the row. 

2 A$1 Mixed Only the row. 

3 $A1 Mixed Only the column. 

4 A1 Relative Removes the absolute reference. 
Nothing is locked (default). 

 

 

Ranges and Tables 

 

When you insert data into Excel, it starts as a 
range. A cell range is a group of selected cells 
in a rectangular block, for example, from the 
top-left to the bottom-right of your selection. 

Suppose you select cells from A4 to E15. This is 
called a range, and it would be entered as: 
A4:E15.  

At this stage the range has no table features, it’s 
just static data. When you convert a range to a 
table, Excel adds features such as calculated 
rows and columns, sorting and filtering, 
banded rows, etc.  

To convert a range into a table, select the range and use one of the following methods:  

• Insert tab > Table group > Table 

• CTRL + T 

Assume you convert the above range (A4:E15) into a table and name it “Tolano Adventures”. Now 
Excel recognizes this as a dynamic, named table with enhanced functionality.  

An Excel table is a structured, dynamic range of cells that is pre-formatted and given a unique 
name. It includes built-in features such as filtering, sorting, automatic expansion as new data is 
added, and support for structured references. Excel tables help organize and analyze data more 
efficiently by making formulas straightforward to read and data more manageable. 
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Structured references (or table references) are a 
flexible alternative to traditional cell addresses. 
They allow you to refer to specific parts of an Excel 
table, such as entire tables, columns, or individual 
rows, using table and column names instead of cell 
coordinates. Consider the example: the table is 
named TolanoAdventures. To reference the 
Complaints column in the table, enter it as:  
=SUM(TolanoAdventures[Complaints}) instead of 
using =SUM(E4:E15) 

Structured references adjust automatically when data grows and make formulas straightforward 
to understand and maintain. 

 

Display Formulas 

By default, Excel cells display the result of a calculation. However, when troubleshooting or 
reviewing a project, it is often necessary to view the actual formulas across the entire worksheet at 
once. Instead of selecting each individual cell to view its contents in the Formula Bar, you can toggle 
the entire worksheet to display the formulas using the Show Formulas tool. This replaces the 
calculated answers with the raw instructions used to create them. 

To toggle on the Show Formulas view:  

• Formulas tab > Formula Auditing group > Show Formulas 

• CTRL + ` (grave accent) 
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Copy or Move a Formula 
It is important to know the difference between copying a formula and moving a formula. 

• When you copy a formula, the relative reference will allow the formula to adjust for each new 
row and/or column. 

• When you move a formula, the relative reference within the cell will not change, regardless of 
whether it has a relative or absolute reference. 

You can copy formulas into additional cells by using the copy/paste tools or by dragging the Autofill 
handle. When you copy formulas, relative references will be put in place to ensure the formulas 
adjust for each row and column, unless you include absolute or mixed references before you copy 
the formula. 

Copy a formula using copy and paste: 

1. Select the cell with the formula that you want to copy then, the Home tab > Clipboard group > 
Copy or select CTRL+C. 

2. Select the cell you want to copy the formula and the formatting to, then on the Home tab > 
Clipboard group > Paste or select CTRL+V. 

Note: To paste ONLY the formula, in the Home tab > Clipboard group > Paste drop-down arrow > 
Paste Special > Formulas.  To paste ONLY the value, in the Home tab > Clipboard group > Paste 
drop-down arrow > Paste Special > Values.  

Use AutoFill to copy a formula: 

1. Select the cell with the formula that you want to copy into adjacent cells. 

2. Select and hold the fill handle that appears in the bottom-right corner of the cells  and 
drag the fill handle over the adjacent cells you want to copy the formula into.  

3. To change how you want to fill the selection, select the small AutoFill Options icon  and 
choose the relevant option. 

If you don’t notice the fill handle, it might be hidden. To display it, go to the File tab > Options > 
Advanced.  Under Editing Options, check the Enable fill handle and cell drag-and-drop box. 
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You can move formulas into a different cell by using cut and paste or by dragging the border of the 
cell into a new location (available in the desktop version only). When you move formulas, the cell 
references will not change, regardless of the type of cell reference used. 

Move a formula using cut and paste: 

1. Select the cell with the formula that you want to move, then on the Home tab > Clipboard 
group > Cut or select CTRL+X. 

2. Select the cell you want to move the formula and the formatting into, then on the Home tab, > 
Clipboard group > Paste or select CTRL+V. 

Move a formula by drag and drop (available in the desktop version only): 

• Select the cell with the formula that you want to move to a different location, then select and 
hold on the border of the cell and drag it to the cell you want to move the formula into 
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Lesson 2: Functions 
Lesson Objectives 
In this lesson, you will learn about functions. How can you use them to create a family budget or to 
track profit and loss for a small business? How can I make sure they are accurate? Upon completion 
of this lesson, you should be able to use and understand the following: 

 Insert Function 

 Random Numbers 

 Sequence 

 Unique 

 IF Function 
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Insert Function 
Excel has a very large number of functions available; memorizing the syntax of every function is an 
impossible task. To make it easier to use functions, Excel provides a special tool called Insert 

Function  left of the formula bar.  

To access the Insert Function dialog box, use one of the following methods: 

• Select Insert Function ( ) to the left of the Formula bar 

• Home tab > Editing group > AutoSum drop-down arrow > More Functions 

• Formulas tab > Function Library group > Insert Function 

You can also access a list of functions by entering  “=” (to indicate to Excel that you are entering a 
formula) and then entering the first few characters of the function that you want to enter. Excel 
displays a drop-down list of all functions that begin with these characters. 

 

The Insert Function dialog box displays all functions grouped by most recently used or by categories 
previously discussed. If you do not know the name of the function you want to use, but you do know 
what you want to accomplish, you can enter a brief description of what you want to do and the 
Insert Function feature will recommend a function for you (This feature can only be accessed in the 
desktop version.). 

 

After you select a function, Excel displays the Function Arguments dialog box to help you enter all 
the required function arguments. Helpful features of this dialog box include the following: 

• Each argument is listed and the required arguments are highlighted in bold. If the function 
you’re using allows a variable number of arguments, the dialog box displays additional 
argument boxes as necessary 
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• When the cursor is in one of the argument text boxes, the relevant help information displays in 
the lower part of the dialog box 

• If you select or enter data values or cell references into the argument boxes, Excel previews the 
data to the right of that argument box. In the following example screen, the data values being 
considered are {45;24;57;49;36} 

• If enough arguments have been entered, Excel also displays the results in the lower part of the 
dialog box. In this example screen, the calculated sum for the selected cell range is 211 

 

Many of the arguments in a function permit you to select a cell or range of cells containing the 
values to be used. For example, consider the following three functions: 

=SUM(45,24,57,49,36) 

=SUM(C1,C2,C3,C4,C5) 

=SUM(C1:C5) 

If cell C1 contains the value 45, C2 contains 24, and so on, all three of these functions will result in 
the displayed value of 211. 

You can enter a value or cell range into the appropriate boxes within the Function Arguments 
dialog box, or you can select a cell or cell range directly in the worksheet. In some situations, such 
as if you are using a device with a very small screen, the Function Arguments dialog box may block 

your view of the cell range. If you select the Collapse button ( ) located to the right of the 
argument text box, the Function Arguments dialog box shrinks temporarily. 

 

Once you have selected your cell range, select ENTER or select the Restore ( ) button located at 
the right side of the text box. The Function Arguments dialog box restores to its full size. 
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Function Name Description 

=AVERAGE Calculates the arithmetic mean average of the numbers in the specified range 
(sum total of the cell range, divided by the total of the number of cells containing 
a number). 

=MIN Finds and displays the lowest numeric value in the specified range. 

=MAX Finds and displays the largest numeric value in the specified range. 

 

Random Numbers 
The RAND function generates random decimal numbers between 0 and 1, making it a versatile tool 
for various data modelling and simulation tasks. It’s particularly useful for generating probabilities, 
percentages, or random fractions for statistical analysis. For example, you can use it to simulate 
random probabilities, create weighting factors for data models, or produce test values for formulas. 
Because it generates continuous random decimals, it’s useful for situations where you need more 
precise or detailed randomness. 

Function: =RAND() 

If you would like to randomly select a random number between specific numbers, you could include 
those numbers in the function.  

Function: =RAND()*upper limit 

Function: =RAND() * (upper limit – lower limit) + lower limit 

Function  Description  Possible Result 

=RAND() A random number greater than or equal to 0 and 
less than 1. 

0.982912 

=RAND()*100 A random number greater than or equal to 0 and 
less than 100. 

32.91643 

=RAND() * (10-1)+1 A random number greater than or equal to 1 and 
less than 10. 

9.090773 

 

The RANDBETWEEN function is used to generate random numbers between two specified values. 
It’s useful for simulations, test data creation, and random sampling. For instance, you can use it to 
simulate dice rolls in gaming scenarios, assign random employee IDs for mock databases, or create 
random test scores for analysis. Its ability to generate dynamic random numbers between specified 
limits is particularly useful for data modeling, statistical sampling, and testing formulas or functions.  

Function: =RANDBETWEEN(lower limit, upper limit) 
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Function   Description  Possible Result 

=RANDBETWEEN(1, 
100) 

This will generate a random number between 1 
and 100. 

11 

=RANDBETWEEN(10, 
50) 

This will generate a random number between 10 
and 50. 

49 

 
The key difference between RAND and RANDBETWEEN is that RAND generates random decimal 
numbers between 0 and 1, while RANDBETWEEN generates whole numbers within a specified 
range. 

Feature RAND RANDBETWEEN 

Purpose Generates a random decimal 
number between) and 1. 

Generates a random whole number 
between two specified values. 

Input Parameters No parameters required. Requires two arguments: bottom 
(lower limit) and top (upper limit). 

Output Produces decimal numbers like 
.4532 or .9847. 

Produces integers like 12, 78, or 100. 

Use Case Useful for generating probabilities, 
percentages, or random fractions. 

Useful for generating random 
whole numbers within a defined 
range, such as test scores or IDs. 

 
Both the RAND and RANDBETWEEN functions are dynamic, meaning the random numbers they 
generate will update each time the worksheet recalculates, such as when you press F9 or make 
changes to the sheet. If you want to keep the generated numbers static for either function, you can 
copy the cells containing the formulas and use Home tab > Clipboard group > Paste Special > 
Values to replace the formulas with their current output. This ensures the values remain fixed and 
do not change with further recalculations. 

Note: F9 is the “Calculate Now” key in Excel. When you select it, Excel forces the worksheet to 
recalculate all the formulas immediately. 

 

Sequence 
The SEQUENCE function generates an array of sequential numbers, offering flexibility for various 
data organization and modeling tasks. It’s particularly useful for creating ordered datasets, dynamic 
ranges, and patterns automatically, eliminating the need for manual entry. For instance, you can 
use it to create numbered lists, generate unique IDs, or structure grids for tables. Its ability to 
produce sequences with customizable rows, columns, starting values, and increments makes it 
ideal for applications like scheduling, financial modeling, or inventory tracking.  

Function: =SEQUENCE(rows, columns, start, step) 

• rows: The number of rows for the sequence 

• columns: (optional) The number of columns for the sequence. Default is 1 
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• start: (optional) The starting number of the sequence. Default is 1 

• step: (optional) The increment for the sequence. Default is 1 

Function  Description  Result 

=SEQUENCE(5,1)  Generates a vertical list of five sequential 
numbers starting from 1. This is useful for 
numbering rows in a dataset automatically.  

1 2 3 4 5  

=SEQUENCE(3,4,10,5)  Generates a 3-row by 4-column array of 
numbers, starting at 10 and increasing by 5. This 
could be useful for structured numbering in 
tables or scheduling tasks.  

10 15 20 25 30 35 40 
45  

=SEQUENCE(2,3,100,-
10)  

Generates a 2-row by 3-column array of 
numbers, starting at 100 and decreasing by 10. 
This can be useful for countdowns, reverse 
ordering, or financial projections.  

100 90 80   
70 60 50  

 

Unique 
The UNIQUE function is designed to extract unique values from a range of data, eliminating 
duplicates. This function is particularly useful for data analysis, reporting, and cleaning datasets by 
identifying distinct entries. Whether working with a list of customer names, product IDs, or survey 
responses, the UNIQUE function ensures streamlined and organized data. 

Function: =UNIQUE(array, [by_col], [exactly_once]) 

• array: The range or array from which to return unique values 

• by_col (optional): A logical value indicating whether to compare values by columns (TRUE) or by 
rows (FALSE, default) 

• exactly_once (optional): A logical value indicating whether to return all unique values (FALSE, 
default) or only those that appear exactly once (TRUE) 

 

Scenario Function  Result 

You have a list of names in 
column A (A1:A10), and some 
are repeated. 

=UNIQUE(A1:A10) A vertical list of unique names 
extracted from column A. 

 

A dataset where each row 
represents a product entry, 
and you need to identify 
unique rows. 

=UNIQUE(A1:D10, FALSE) A filtered table where each row 
is unique. 

 

You want to find values that 
appear only once in a dataset. 

=UNIQUE(A1:A10, FALSE, 
TRUE) 

A list of values that appear 
exactly once in column A. 
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IF Function 
In Excel, the ability to perform different calculations based on changing values is one of the most 
powerful and useful features of spreadsheets. The primary function used for this is the IF function. 
This function tests for a condition and performs one of two different calculations based on the result 
of the test. The result should always evaluate to either TRUE or FALSE. In other words, either the 
condition being tested is TRUE or it is FALSE. This automatic evaluation provides “on the fly” 
conditional worksheet calculations. 

Function: =IF(logical test,value if true,value if false) 

• Logical Test – Specify what the IF statement will evaluate. The result should always be binary; 
it should always result in either True or False 

• Value if True – If the Logical Test is found to be true, then the result of the IF function will be 
whatever is in this section of the formula 

• Value if False – If the Logical Test is found to be false, then the result of the IF function will be 
whatever is in this section of the formula 

The Logical Test section of the function often uses comparison operators that will help you obtain 
the desired result. Qualifiers are punctuation marks used to identify or define different types of data. 
For example, text used in a formula requires double quotation marks (") as qualifiers.  
Some of the comparison operators you can use are: 

Logical Operators Definition 

= Equal to 

> Greater than 

< Less than 

>= Greater than or equal to 

<= Less than or equal to 

<> Not equal to 

The Value if True/False sections can contain a text string, values or even other functions. In fact, you 
can nest or embed up to 64 IF functions within one IF function. An example of a nested IF function 
would appear as follows: 

=IF(A1=10, “text A”,IF(A1=20, “text B”, “text C”)) 

In this example, Excel will display the following values when the conditions are met: 

 If A1 contains  Then this will display 

 10  text A 

 20  text B 

 Any other value  text C 
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Lesson 3: Text Functions 
Lesson Objectives 
In this lesson, you will learn about text functions. The objective of the text functions in Excel is to 
convert numbers into text strings which will change how they appear in your spreadsheet. Upon 
completion of this lesson, you should be able to use and understand the following: 

 Right, Left, Mid 

 Upper, Lower, Proper 

 Len 

 Trim 

 Combine Text 
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Right, Left, Mid 
Excel offers text functions to extract specific parts of a text string, making it more convenient to 
work with structured data such as IDs, codes, and descriptions. The RIGHT, LEFT, and MID functions 
are particularly useful for isolating and analyzing substrings within a larger text string. 

RIGHT Function:  

• Purpose: Extracts a specified number of characters from the end (right) of a text string. 

• Syntax: =RIGHT(text, num_chars) 

▪ text: The text or cell reference containing the text to extract from. 

▪ num_chars (optional): The number of characters to extract. Default is 1. 

 

LEFT Function:  

• Purpose: Extracts a specified number of characters from the beginning (left) of a text string. 

• Syntax: =LEFT(text, num_chars) 

▪ text: The text or cell reference containing the text to extract from. 

▪ num_chars (optional): The number of characters to extract. Default is 1. 

 

MID Function:  

• Purpose: Extracts a substring from the middle of a text string, starting at a specified position. 

• Syntax: =MID(text, start_num, num_chars) 

▪ text: The text or cell reference containing the text to extract from. 

▪ start_num: The position of the first character to extract. 
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▪ num_chars: The number of characters to extract. 

 

Function Description Example Result 

=RIGHT(A1, 3) Extracts the last three characters from the text 
in cell A1. 

If A1 contains 
"Product123" 

123 

=LEFT(B1, 5) Extracts the first five characters from the text in 
cell B1. 

If B1 contains 
"Order45678" 

Order 

=MID(C1, 4, 3) Extracts three characters starting from the 
fourth position in the text in cell C1. 

If C1 contains 
"A1B2C3D4" 

2C3 

 

Upper, Lower, Proper 
Excel provides several text functions to help standardize the case of text data. The UPPER, LOWER, 
and PROPER functions allow you to manipulate text, making it more consistent and easier to work 
with. These functions are essential for cleaning up data imported from external sources or for 
formatting data for reporting and presentation. 

UPPER Function:  

• Purpose: Converts all text to uppercase. 

• Syntax: =UPPER(text) 

▪ text: The text or cell reference to convert to uppercase. 

LOWER Function:  

• Purpose: Converts all text to lowercase. 

• Syntax: =LOWER(text) 

▪ text: The text or cell reference to convert to lowercase. 

PROPER Function: 

• Purpose: Capitalizes the first letter of each word in a text string. 

• Syntax: =PROPER(text) 

▪ text: The text or cell reference to convert to proper case. 
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Function Description Example Result 

=UPPER(A1) Converts all text in cell A1 to uppercase. If A1 contains 
"hello world" 

HELLO WORLD 

=LOWER(B1) Converts all text in cell B1 to lowercase. If B1 contains 
"HELLO WORLD" 

hello world 

=PROPER(C1) Capitalizes the first letter of each word 
in the text in cell C1. 

If C1 contains 
"hello world" 

Hello World 

 

Len  
The LEN function measures the length of text strings. It counts the total number of characters in a 
cell, including spaces, numbers, and special characters. This function is useful for tasks like data 
validation, cleaning text data, or ensuring consistent formatting. 

LEN Function: 
• Purpose: Counts the number of characters in a text string, including spaces, numbers, and 

special characters. 

• Syntax: =LEN(text) 

▪ text: The text or cell reference to measure. 

Function Description Example Result 

=LEN(A1) Counts characters in the text in cell 
A1. 

If A1 contains "Hello World" 11 

=LEN("12345") Counts characters in the given text 
string. 

Counts the string “12345” 5 

=LEN("Hello123") Counts letters, numbers, and spaces. Counts the string “Hello123” 8 

 

Trim 
The TRIM function is a powerful tool for cleaning up messy text by removing unnecessary spaces. It 
ensures that only single spaces remain between words and eliminates any leading or trailing 
spaces. This is especially helpful when working with data imported from external sources, where 
extra spaces can cause inconsistencies or errors in analysis. 

TRIM Function: 
• Purpose: Removes all extra spaces from a text string, leaving only single spaces between words. 

• Syntax: =TRIM(text) 

▪ text: The text or cell reference to clean.  
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Function Description Example Result 

=TRIM(A1) Removes extra spaces in 
the text in cell A1. 

If A1 contains "Data 
Science" 

Data Science 

=TRIM(" Excel 2023 ") Removes leading, 
trailing, and extra 
spaces. 

Removes the space 
before “ Excel 2023 ” 

Excel 2023 

 

Combine Text 
The TEXTJOIN and CONCAT combine multiple text strings into one. These functions simplify tasks 
like merging names, formatting data, or creating custom labels. While they serve similar purposes, 
they differ in how they handle delimiters and blank cells. 

TEXTJOIN Function: 
• Purpose: Combines multiple text strings into one, separated by a specified delimiter, while 

optionally ignoring blank cells. 

• Syntax: =TEXTJOIN(delimiter, ignore_empty, text1, [text2], ...) 

▪ delimiter: The character(s) to separate each text item. 

▪ ignore_empty: TRUE to ignore blank cells; FALSE to include them. 

▪ text1, [text2], ...: The text strings or ranges to join. 

 

CONCAT Function: 
• Purpose: Combines multiple text strings into one without a delimiter. 

• Syntax: =CONCAT(text1, [text2], ...) 

▪ text1, [text2], ...: The text strings or ranges to combine. 
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Function Description Example Result 

=TEXTJOIN(", ", 
TRUE, A1:A5) 

Joins values in A1:A5 with 
a comma as the 
separator. 

If A1:A5 contains "John", 
"Mary", "Alan" 

John, Mary, 
Alan 

=TEXTJOIN(" - ", 
FALSE, A1:A5) 

Joins values in A1:A5, 
including blanks, with a 
dash. 

If A1:A5 contains "Data", "", 
"Science" 

Data - - Science 

=CONCAT(A1, " ", 
B1) 

Combines values in A1 
and B1 with a space in 
between. 

If A1 contains "John" and 
B1 contains "Doe" 

John Doe 

=CONCAT(A1:A5) Combines all values in 
A1:A5 without separators. 

If A1:A5 contains "Excel", 
"2023" 

Excel2023 
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Unit 3 Key Terms 
Term Definition 

Cell Range   A rectangular block of cells. You refer to a cell range by listing the 
addresses of two cells at opposite corners of the range, separated by a 
colon (:).    

Cell Reference   The column and row coordinates which comprise a cell address. For 
example, the cell reference A1 indicates a cell at the intersection of 
column A and row 1.   

Excel Table   A structured and pre-formatted dynamic range of cells that has its own 
name.   

Function   A feature designed by Microsoft that enables you to quickly perform a 
calculation or formula using a specialized function.   

Insert Function   The feature Excel provides to help you select the desired function to 
perform calculations.   

Mixed Cell 
Reference   

A cell address where either the column or row reference is absolute, and 
the other reference is relative.   

Structured 
Reference or Table 
Reference   

A special way for referencing tables and their parts that uses a 
combination of table and column names instead of cell addresses.   
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Unit 4: Inserting Elements 

Unit Objectives 
In this unit, you will develop proficiency in working with advanced data techniques, utilizing 
comments to enhance collaboration and documentation, creating user-friendly forms for data 
entry and manipulation, and incorporating graphics to enhance visual representation and 
communication of data. Upon successful completion of this unit, you should understand the 
following: 

 Data 

 Comments and Notes 

 Graphics 
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Lesson 1: Data 
Lesson Objectives 
In this lesson, you will learn about Excel spreadsheet data. Data is information that is stored in Excel. 
Data stored in Excel is stored in cells within the worksheet that can be used in calculations, 
displayed in graphs, or sorted and filtered to find specific information. Upon completion of this 
lesson, you should be able to understand the following: 

 Find and Replace Data 

 Import Data from External Text Files 

 Import Data from External CSV Files 

 Import Data from Online Sources 

 Export Excel Data as CSV 

 Insert Hyperlinks 

 Modify and Delete Hyperlinks 
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Find and Replace Data 
The purpose of Excel spreadsheets is to organize a variety of data based on changes of inputs. By 
keeping the data organized you can effectively analyze the variation in outputs. This allows for ease 
in interpreting the data and it allows for quick sharing with others. 

Sometimes you will need to locate specific information in Excel and it can be accomplished by using 
the Find feature. The find and replace feature will allow you to find specific information and then 
replace it with updated content by using a few entries. By default, the Find and Replace feature will 
locate a partial match, but you can make it search for an exact match by selecting the option “match 
entire cell contents” amongst other available options to refine the search. 

You can search a worksheet for every occurrence of a value (text label or number), function name, 
or cell reference by using the Find feature. By default, the Find tool will search for the value in the 
Find what text box in every cell in the current worksheet. The search value can be as long or short 
as you need. Any cell that contains this value, even if it is only part of a longer value, will be selected. 

To activate the Find feature, use one of the following methods:  

 
• Home tab > Editing group > Find & Select drop-down arrow > Find... 

• Select CTRL+F 

• Select the Options button in the Find and Replace dialog box to display all the options 
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Within Search only within the current worksheet or the entire workbook. 

Search Indicate which direction to search: 

By Rows: Search from left to right across each row in the 
worksheet/workbook starting from the top row. 

By Columns: Search down each column starting from the left-most 
column. 

Look in Specify whether to view only the value (the result of a function rather than 
the formula or function text), the underlying formula, or any comment in 
each cell. The Formulas option is generally more flexible even if the cell 
contains just a value.  

Match case Specify whether to match the upper and lower case of alphabetic 
characters in the cell.  

Match entire cell 
contents 

Specify whether the cell must contain only the Find what value, or the cell 
may contain other text characters as well. This setting only applies when 
you are searching for text data.  

You can also replace the search item with a new value, on an individual basis by using Replace, or 
for all cells at one time that contain the search item by using Replace All. The Replace function 
simplifies and speeds up the task of replacing one word or value with another. This automated 
process virtually eliminates any typing errors you would make if you had to do it manually. 

To activate the Replace feature, use one of the following methods: 

• Home tab > Editing group > Find & Select drop-down arrow > Replace > Replace tab 

• Select CTRL+H 

• If the Find dialog box is already open, select the Replace tab 

 

You may want to use Replace to check and verify that each replacement should be made. An 
alternative is to use the Find tab before using the replace function to search through the worksheet 
and verify that your search value and options have been set correctly. Once you are certain that 
your search value and options are correct, you can proceed with using Replace All. If you replace a 
cell value by mistake, you can use the Undo command.  

 



Unit 4: Inserting Elements  Lesson: Data 

3283-2 © CCI Learning Solutions Inc.  121 

Import Data from External Text Files 

 

Most businesses use various specialized computer applications for their operations.  The challenge 
has always been to move data from one application to another without having to manually re-enter 
the data. Almost all these applications can export data into files, and the text data file format is the 
most used.  

Excel uses the Office Open XML format to store its own workbook data. However, many other 
applications do not support this format. Fortunately, Excel has built-in capabilities for importing 
and exporting data conveniently.  

In Excel, on the Data tab, the commands in the Get & Transform group comprise a powerful set of 
tools that make it possible to connect to data from various sources, "clean up" or transform the data 
into the form you need and import it into Excel. 

On the Data tab > Get & Transform Data group > select one of the options to import external data:  

 
• From Text/CSV – Imports data from a file containing numeric and alphabetic data in text format, 

in which the values are separated from each other by a tab, space, comma, or some other 
character 

• From Web – Imports data that is displayed in specific locations of a Web page 

• From Table/Range – Imports data from a selected Excel table or named range 

• From Picture – Imports a picture from a file or from the Clipboard 

• Recent Sources – Imports data from a recently-opened source file 

• Existing Connections – Imports data using an existing data connection that was previously 
created for this workbook, this computer, or your network.  

• The Get Data drop-down menu displays further options for importing data: 

▪ From File – Imports data from a selected Workbook, Text/CSV, XML, or JSON file. You can 
also navigate to a folder or SharePoint location to specify the file you want to import 

▪ From Database – Imports data from a selected database file. You can select from among 
SQL Server, Microsoft Access, Analysis Services, SQL Server Analysis Services, Oracle, IBM 
DB2, MySQL, PostgreSQL, Sybase, Teradata, and SAP HANA database types 

▪ From Azure – Imports data from a file stored in Microsoft Azure. Azure is a cloud-
computing service created by Microsoft in which developers can build, test, install, and 
manage applications and services through Microsoft data centers. You can select files 
from SQL Database, SQL Data Warehouse, HDInsight, Blob Storage, Table Storage, and 
Data Lake Store services 
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▪ From Fabric & Power Platform - Imports data directly from sources such as Power BI 
datasets, Dataverse, and Fabric warehouses 

▪ From Online Services – Imports data from files stored in various online services such as 
SharePoint, Microsoft Exchange, Dynamics 365, Facebook, Salesforce Objects, and 
Salesforce Reports 

▪ From Other Sources – Imports data from files that come from various sources, some of 
which you can access directly using the options in the Get & Transform Data group. You 
can select data from sources such as a Table/Range, the Web, Microsoft Query, 
SharePoint List, OData Feed, Hadoop File, Active Directory, Microsoft Exchange, ODBC, 
OLEDB, and Blank Query 

 

To import a Text/CSV file: 

• Data tab > Get & Transform Data group > From Text/CSV to open the Import Data dialog box > 
Browse and select the file > Import 

 

• The contents of the file will display in a preview window illustrating the overall structure of the 
data. Select Load or Transform Data to import it into the workbook 
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The table below describes the options in the preview window. 

Field Description 

File Origin Select an option to specify the character set used to create the data in the text 
file. In most cases, you can accept the default setting. 

Delimiter Select an option to specify the character used to separate each field of text in 
the text file. Excel attempts to detect each instance of the delimiter in the text 
file to determine the value that should appear in each column in the worksheet. 

Any printable character can be used as a delimiter. You can select from among 
the Colon, Comma, Equals sign, Semicolon, Space, Tab, Custom, and Fixed 
Width delimiters. Select Custom if you need to specify a delimiter that is not 
part of the default list, such as the quote or double-quote character. Select 
Fixed Width if the values are vertically aligned in columns (possibly with no 
gaps between the columns), and blank spaces are used where necessary to 
align the data. 

Data Type 
Detection 

Select an option to specify the number of rows in the text file that Excel uses to 
interpret the type of data contained in the text file. 

 (Preview) Select this button to preview the imported data based on options you select in 
the File Origin, Delimiter, and Data Type Detection drop-down lists. You should 
always preview the data to ensure it will display correctly in Excel. 

Load Select this button to load the imported data.  

You can select the arrow on the right side of the Load button and select the 
Load To command to specify how to view the imported data in your workbook, 
such as whether you want to place the data in the existing worksheet or in a 
new worksheet, and which worksheet cell to use as the starting point for the 
imported data. Selecting the Load command in the drop-down menu is the 
same as selecting the Load button, which will import the data as a table into a 
new worksheet starting in cell A1. 

Transform 
Data 

(Edit) 

Select this button to display the Query Editor, in which you can determine how 
the data will appear in the worksheet. For example, you can transpose the 
columns and rows, filter the data, sort the data, and so on. Depending on your 
version of Excel, this button may appear as "Edit". 



Lesson: Data  Unit 4: Inserting Elements 

124  3283-2 © CCI Learning Solutions Inc. 

When you have successfully imported the data, the Queries & Connections task pane opens. Within 
this task pane you can observe how many rows of data were imported.  

 

Microsoft 365 (Web) and Online 

Import data: 

• On the Data tab > Get & Transform Data group > select one of the options to import external 
data: 

▪ From Table/Range  

▪ From Picture  

▪ Data from Power BI 

 

• Select the Get Data drop-down arrow > Get Data > in the Power Query dialog box, select New 
and choose from multiple options 
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Import Data from External CSV Files 

 

A CSV file is where the data is separated by commas, and it doesn’t contain any specialized 
formatting. Sometimes you will need to import CSV data into an Excel file to transform the data or 
to analyze it.  

A CSV (Comma Separated Values) file contains data in text form, just like a text file with the 
filename extension of .TXT. But because CSV files must follow a set of rules in how the data is laid 
out inside the file, Excel is able to open CSV files directly. It almost treats CSV files like Excel 
workbooks.  

The example illustrates how Windows displays this type of file in File Explorer.  

 

Notice that the icon to the left of the Global Swimsuits file name is similar to the icons of Excel 
workbooks, but it is not the same. Also, the file type is Microsoft Excel Comma Separated Values 
File.  

In the example below, the file is opened in Notepad: 

  

A CSV file is a text file with commas used as a delimiter to separate the values between columns. 
The numbers have commas inside, so the double-quote character (") is used as the text qualifier 
around each number. 

When you open a CSV file in Excel, Excel displays the values in columnar format using the comma 
delimiter to determine which values appear in which columns. Excel also displays a notification 
below the Ribbon indicating that Excel features might be lost if you save the workbook in the CSV 
file format instead of saving it as an Excel workbook. 
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To import a CSV file into a workbook: 

1. Data tab > Get & Transform Data group > From Text/CSV. 

2. Browse your computer, select the file you want to import and > Import.  

Microsoft 365 (Web) and Online 

To import a CSV file into a workbook: 

1. Data tab > Get & Transform Data group > Get Data drop-down menu > Get Data... > New > 
Text/CSV. 

• Link to file – Browse OneDrive for the desired file > Next 

• Upload file - Browse your computer, select the file you want to import > Open > Next  

 

2. Modify or transform your data in the Power Query dialog box before loading it into the file 
(options may be limited in the online app version). 

 

 

Import Data from Online Sources 

 

The ability to import data from online sources into Excel is an essential skill for organizing, analyzing, 
and sharing information efficiently. Excel offers tools that allow users to connect to various data 
sources, such as web pages, and bring external data directly into their workbooks. This process 
streamlines data integration and ensures accuracy in analysis. 

Web pages often contain structured data tables that can be imported directly into Excel using its 
Web connector feature.  

Import data from a web page: 

1. Data tab > Get & Transform Data group > From Web. 

2. Enter the URL of the web page containing the data you wish to import > OK to initiate the 
connection.  

• Ensure the URL leads to a page with well-structured data tables for better results 
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3. If it is the first time you are accessing content from the web, in the Access Web content window, 
select which user profile to access the website with. Choose from Anonymous, Windows, Basic, 
Web API or Organizational account. Input your credentials and select Connect.  

4.  In the Navigator pane, review the list of tables detected on the web page under Display Options. 
Select a table and preview its data in the Table View tab or Web View tab. 

 

5. On the Load drop-down menu, choose Load to... open the Import data dialog box. Choose 
which format and location to import the table to. 
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6. Or select Transform Data to clean and shape the data with the Power Query Editor before 
importing it into the workbook. 

• Home tab – Manage loading, refreshing, and query properties; choose, remove, or reorder 
columns and rows; merge or append queries; group or replace values, create a new query or 
manage connections and credentials 

• Transform tab – Modify, transpose or extract data values and data types; split or group 
columns; and reshape table structures 

• Add Column tab – Create new calculated columns based on transformations or formulas 

• View tab – Control panes and formula bar visibility, and enable column profiling and quality 
checks 
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Export Excel Data as CSV  

 

Excel provides an easy-to-use method of exporting data to other file formats, including the CSV 
format.  

To save a workbook as a .csv file: 

• File tab > Save As > Save as type drop-down menu > choose CSV UTF-8 (Comma delimited) 
(*.csv) > Save 

 
Note that CSV files contain only text data. This means that when saving a workbook in the CSV 
format, Excel will discard anything that is not pure data. For instance, the result of a formula 
illustrated in the cell would be exported, but not the formula itself. Also, charts and other graphics 
would be deleted. Therefore, your CSV workbook should not use Excel features such as formulas, 
cell formatting, charts, and multiple worksheets.  

If you try to save a workbook that uses these features as a CSV file, Excel will display a notification 
below the Ribbon to remind you that some features may be lost. 

Microsoft 365 (Web) and Online 

To export a workbook as a .csv file: 

• File tab > Export > Download as CSV UTF-8 or Download as a CSV 
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CSV UTF-8 (Comma delimited) - Also a plain text file with values separated by commas. Uses UTF-
8 encoding, which is a universal standard. Supports all characters, such as accented letters, non-
Latin scripts (Chinese, Hindi, Arabic, Cyrillic, etc.), and emojis. 

CSV (Comma Separated Values) - A plain text file where values are separated by commas. Works 
fine for basic English letters and numbers., but it can break when you have special characters (é, ñ, 
ü, Chinese, Arabic, emojis, etc.) → they may show as ? or weird symbols. 

 

Insert Hyperlinks 
A hyperlink is a clickable element in an electronic document that you can use to jump to or open 
another document. Hyperlinks were introduced with the internet to allow users to navigate from 
one web page to another whether the next web page was on the same website or another.  

Over time, hyperlinks have evolved to link to any type of document in any location, not just on the 
internet. A hyperlink in an Excel workbook can be used to: 

• Launch web pages from the Internet or the internal organizational intranet 

• Open a workbook or document located on a computer (including your own) within your home 
or corporate network, or an online storage service such as OneDrive, SharePoint, or Dropbox 

• Jump to another cell or named range in the same workbook 

• Create a new workbook 

• Launch the default email program (for example, Outlook), and create an email with a specific 
set of recipients and, optionally, a subject line 

To insert a hyperlink, use one of the following methods: 

• Insert tab > Links group > Link  

• Right-click on a cell > Link > Insert Link... 

• Select CTRL+K 

 
The Insert Hyperlink dialog box allows you to insert one of four types of hyperlinks: 

• Existing File or Web Page – Used to link to workbooks, files or documents stored on a local or 
networked hard drive, or websites on the intranet or the Internet. 

• Place in This Document – Used to link to a cell or named range of cells in the current workbook 
either in the current worksheet or another worksheet. 

• Create New Document – Used to create a new workbook using the name that you specify in 
the Name of new document text box and located in the folder specified under Full path. 

• E-mail Address – Used to launch the email program (for example, Outlook) installed on the local 
computer and create a new email message using the email address and subject line specified 
in this dialog box.  A mailto URL is a special type of URL used by email systems. 
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To quickly access recently used items in the dialog box: 

• Current Folder – Search for other files in the folder currently in use 

• Browsed Pages – Link to recently browsed pages. Before creating a hyperlink, you would likely  
have recently viewed a website. Instead of having to copy and paste the website information, 
possibly missing part of it, the information is already conveniently accessed under this option  

• Recent Files – Files needed for a hyperlink would have likely been recently viewed 

 

Modify and Delete Hyperlinks 
If you move or rename a referenced document or range, you must change the hyperlink. You may 
also want to change the text displayed in the worksheet for the hyperlink or add a custom 
ScreenTip. 

 
To modify a hyperlink in the worksheet, use one of the following methods: 

• Right-click the hyperlink and then select Edit Hyperlink 

• Move the cell pointer to the cell containing the link > Insert tab > Links group > Link to open the 
Edit Hyperlink dialog box. Make the necessary changes and select OK 

Note: When you use the arrow keys on the keyboard to move the cell pointer from a nearby cell 
into a cell containing a hyperlink, the link is not activated. You can also select and hold CTRL while 
selecting the cell containing the hyperlink; or select and hold the left mouse button on the cell for 
a few seconds until the mouse pointer changes from a hand to a white cross, then release the 
mouse button and select F2 to go into edit mode. 

When you no longer need the hyperlink, you can remove the reference. The text displayed for the 
hyperlink remains in the cell. 
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To delete a hyperlink in the worksheet, use one of the following methods: 

• Right-click the link and then select Remove Hyperlink 

• Move the cell pointer to the cell containing the link > Insert tab > Links group > Link > Remove 
Link 
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Lesson 2: Comments and Notes 
Lesson Objectives 
In this lesson, you will learn about Excel comments and notes. Comments are utilized to add a note 
or to explain a function. Comments are a great way to collaborate and share thoughts. Excel allows 
you to use a great deal of flexibility while editing, deleting and showing/hiding comments within 
worksheets. Upon completion of this lesson, you should be able to understand the following: 

 Create Comments 

 Move Among Comments 

 Reply to Comments 

 Resolve and Delete Comments 

 Notes 
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Create Comments  
Comments are like “sticky” notes on a hard-copy document. You typically use them so that several 
users who are sharing a workbook can mark-up the spreadsheet with their various comments. Excel 
automatically adds the current user’s name at the top of the comment text box. The final reviewer 
can then act on each comment and follow up with the author, if necessary. 

You can use comments for many reasons. For example, to explain data or formulas, or to add 
reminders and notes. You can insert comments directly into the cells they reference and display 
them only when you want to view them. You can reply to comments or delete comments that are 
no longer needed. 

 
To insert a comment into a worksheet, select the cell to which you want to add a comment: 

• Review tab > Comments group > New Comment. A comment box will open 

  

Notice that the comment box displays your name and the active cell (C7) in the title bar. Enter text 
in the Start a conversation (or @mention or comment) field and select the Post button in the 
bottom left corner of the comment box to create your comment.  

Excel displays a purple marker in the top right corner of the commented cell to remind you that 
you have inserted a comment there. Otherwise, the comment would remain hidden until you 
position the mouse pointer over that cell. 

To display comment(s) continuously: 

• Review tab > Comments group > Show Comments to open the Comments task pane. Close 
the Comments task pane or select Show Comments again to hide the comments 
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Move Among Comments 
When the Comments task pane is open, you can move from 
one comment to the next. When the Comments task pane 
is closed, you can move from comment to comment by 
selecting the Review tab > Comments group > Previous 
Comment and Next Comment button.  

 

Reply to Comments 
To reply to a comment, select the commented cell in the worksheet (or open the Comments task 
pane and select the comment). Enter your comment in the Reply field that appears below the 
original comment, and then select the Post button. 

Notice the Edit and Delete options that appear in the lower 
right portion of the reply. Once you’ve selected the Post 
button to complete the comment, you can select the Edit 
option to change your reply or select the Delete option to 
delete it. 

By replying to comments in this manner, you are creating a 
“conversation thread,” which makes it straightforward to 
follow the flow of comments. 

 

Resolve and Delete Comments 
If a comment thread has been completed, then you can mark it as Resolved by selecting the ellipsis 
in the upper left corner and choosing Resolve. This means that the comment is still viewable, but 
no further additions can be added to the thread unless it is reopened. 

To remove a comment or an entire comment thread, select the comment you want to delete then 
use one of the following methods: 

 

• Review tab > Comments group > Delete 

• You can also remove comments or individual 
“reply” comments in a comment thread by 
selecting the ellipses and then selecting the 
Delete option 
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Notes  
Notes are intended for making annotations or reminders about data. They are not threaded like 
Comments and do not have a Reply field. They are primarily used for adding context or explanations 
to specific cells without the need for a discussion thread. A cell which includes a note will have a 
visible red triangle in the corner of the cell. 

 
Add a note with one of the following methods: 

• Right-click on the cell where you want to add a note > New Note > enter the text > move the 
cursor outside the note box to save it 

• Select the cell you want to add a note to > Review tab > Notes group > Notes > New Note 

 

To view, modify or delete a note: 

• Hover over the red triangle and select in the note to edit it 

•  Review tab > Notes group > Notes drop-down arrow > select a command for your purpose 

Notes can be converted into comments using the Review tab > Notes group > Notes drop-down 
arrow > Convert to Comments. 

Choosing between comments and notes: 

• Use Comments when you need to have a discussion or seek feedback from others within the 
worksheet 

• Use Notes for personal annotations or to provide additional information about the data that 
doesn't require a response 

Comparing Comments and Notes: 

Feature Comments Notes 

Background White background Yellow background 

Reply Capability Allows replies in a threaded 
conversation 

No reply capability 

Keyboard 
Commands 

Ctrl+Enter posts the comment ESC exits the note; Ctrl+Enter adds 
a new line 
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Display All comments appear in a pane 
alongside the data 

Notes appear scattered across cells 
and are not consolidated into a 
pane 

Text and Image 
Formatting 

Does not support formatting or 
images 

Supports rich text formatting and 
images 

Resizing Cannot resize comments Notes can be resized 

Name 
Customization 

Cannot remove or change the author 
name 

Allows removing or editing the 
author name 
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Lesson 3: Graphics 
Lesson Objectives 
In this lesson, you will learn about graphics in Excel. Upon completion of this lesson, you should be 
able to understand the following: 

 Insert Illustrations 

 Insert Symbols and Special Characters 

 Insert Image 

 Insert SmartArt 

 Selection Pane 

 Layer Objects  
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Insert Illustrations 
Images can visually enhance data and are useful for illustrating examples and reinforcing concepts. 
Inserting an image in a worksheet is similar to inserting images in Word documents. When you 
insert an illustration in Excel, you can move it to any location and resize it as needed.  

 

To insert a picture: 

• Insert tab > Illustrations group > Pictures drop-down arrow 
> choose between Place in Cell or Place over Cells > select a 
location to browse for images 

 

This Device Navigates to the location where the picture file is stored on the computing 
device or a connected network. 

 

Stock Images Opens a window that displays a variety of stock or common types of 
images that can be inserted into the workbook. 

 

Online Pictures Opens a window to display various pictures that can obtained using the 
Creative Commons License from Microsoft’s website. You can choose to 
insert a picture from one of the categories displayed in the window, or 
enter search criteria. 
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• When the picture has been placed in the desired location, go to the Picture Format tab to 
modify the style, size and formatting  

 

• The picture can be placed in or over cells at any point by selecting the icon next to the image 

 

Instead of choosing to insert a picture, you could choose to insert shapes, icons, 3D Models, SmartArt 
or a Screenshot. 

 

Insert Symbols and Special Characters 

 

When you need a special character in a document, Word provides a quick method to find and  insert 
the character. For example, if you need to insert a copyright © symbol or another currency symbol, 
Word provides a feature that contains many symbols that can be inserted in the worksheet. 

To insert a special character, on the Insert tab > Symbols group > Symbol. 

 

Select Symbols to display the Symbols tab of the Symbol dialog box. 
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A grid of symbols then appears based on the font that is active. You can select the drop-down arrow 
from the Font field to choose another font such as Wingdings that contains different sets of 
symbols.  

To add a symbol into the document, either scroll through the grid or use the recently used symbols 
list to find the symbol you want. Select the character and then Insert. You can also double-click the 
character to insert it. You can then search for other symbols or close this dialog box to return to the 
worksheet. 

For special characters commonly used with text characters, select the Special Characters tab to 
display a list. 

 

As with inserting symbols, select the special character you want and then Insert. Notice the 
shortcut keys. You can enter these special key combinations from the keyboard to automatically 
insert special characters into the document without using the Symbol dialog box.  

 

Insert Image 
The IMAGE function inserts images into cells. The images become a part of the Excel document, 
which means you are able to move and resize cells, sort and even filter based on the images. Use 
this function to visually enhance data tables. 

Syntax: =IMAGE(source, [alt_text], [sizing], [height], [width]) 

Example: =IMAGE("https://images.freeimages.com/clg/images/41/411718/cartoon-penguin-clip-
art_f.jpg","Penguin") 
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The IMAGE function takes the following arguments: 

Field Description 

source Required: The URL path, using an "https" protocol, of the image file. Supported 
file formats include BMP, JPG/JPEG, GIF, TIFF, PNG, ICO, and also WEBP (WEBP 
is unsupported on Web and Android). 

alt_text Optional: Alternative text that describes the image for accessibility.  

sizing Optional: Specifies the image dimensions. There are several acceptable values: 

0     Fit the image in the cell and maintain its aspect ratio. 

1      Fill the cell with the image and ignore its aspect ratio. 

2     Maintain the original image size, which may exceed the cell boundary. 

3     Customize the image size by using the height and width arguments. 

height Optional: The custom height of the image in pixels. 

width Optional: The custom width of the image in pixels.  

 

 

Insert SmartArt 

 

SmartArt allows you to create and customize diagrams to convey information with graphics 
instead of just text. Depending on how you want to portray the information, you can use the 
SmartArt feature to create a diagram such as an organization chart or to illustrate a list of 
procedures. A variety of types and styles of diagrams are available. You can also create diagrams 
manually using individual shapes.  

 Insert a SmartArt object: 

• Insert tab > Illustrations group > SmartArt to open the Choose a SmartArt Graphic dialog box 

 

Select a category from the panel at the left if you want a specific type of diagram. View the table for 
a detailed description of each category. Otherwise, you can scroll through All graphics under List 
in the middle pane to select one of the SmartArt Graphic layouts from the gallery.  
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You will notice that some categories overlap or provide features with multiple components, so 
make sure to explore each option to notice which is right for your needs. On the very right side of 
the Graphic Dialog box, you will observe a preview of the selected SmartArt Graphic, its name, and 
a suggestion of how to use that specific graphic. Select OK to insert it into the document. 

Category Suggested Use Options Example 

 Use to illustrate non-
sequential, sequential, 
grouped lists or blocks of 
information. Depending on 
the SmartArt List Graphic 
chosen, you can organize large 
amounts of data effectively, 
into categories,subcategories 
and more.  

 

 

 Use to illustrate a progression 
or sequential steps in a task, 
process, or workflow. Can be 
used to illustrate a series of 
events or a timeline 
information. Some of these 
processes display related or 
contrasting concepts. 

 

 

 Use to represent a continuing 
sequence of stages, tasks, or 
events in a circular flow. Also 
use the SmartArt Cycle 
Graphic to illustrate the 
relationship to a central idea in 
a cycle or cyclic progression.  
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Category Suggested Use Options Example 

 Use this graph to illustrate the 
hierarchical relationships 
which can progress from top 
to bottom, side to side or 
grouped hierarchically. You 
may also use this Hierarchy 
when needed to report 
relationships in an 
organization or when making 
decision trees.  

 

 

 
Use to compare or illustrate 
relationships between two or 
more ideas, illustrate the 
relationship to or from a 
central idea or illustrate 
contrasting or similar ideas. 
You may also use this to 
illustrate grouped or related 
information.  

 

 

 Use to illustrate the dynamic 
relationship of components to 
a whole in quadrants. There 
may be an emphasis on how 
these pieces work together to 
form the whole.  

 

 

 Use to illustrate the 
proportional, hierarchical 
and/or interconnected 
relationships with the largest 
component on the top and 
narrowing down or vice versa.  
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Category Suggested Use Options Example 

 Use to illustrate or organize a 
group of pictures. You could 
use this option to highlight 
important parts in a picture, 
connect pictures together or 
add captions and text to 
pictures.  

 
 

 For additional options. 

 

 

 

Selection Pane 

 

When you have multiple objects or graphics in your document, the Selection Pane is a convenient 
way to navigate between each object without having to scroll through your entire document to 
find them.  

To display the Selection Pane: 

• Home tab > Editing group > Find & Select > Selection Pane... The pane lists any objects that 
exist in the current worksheet on that current page. This is true even if objects have been 
grouped 

With the Selection pane open, you can move to an object within a group by selecting it in the list. If 
it isn’t the one you want to change, you can select another object to have Excel select it on the 
screen for you. To help identify which object is being selected, you can double-click the name of the 
object and enter text to make it more descriptive. This can also be done with the Group names. 
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Layer Objects 
You can arrange or layer objects to appear as if they are layered over top each other. You can add 
effects to the shapes to create a shadow or background type of effect. The two most common 
options to layer graphics objects are Bring Forward and Send Backward, both in the Arrange group. 
Make sure your object is a floating graphic before trying to layer objects.  

 

To bring an object forward, select the object and then on the Shape Format tab > Arrange group > 
Bring Forward drop-down arrow. 

  

Bring Forward Bring the selected object forward by one layer. 

Bring to Front Bring the selected object directly to the front of all objects. 

 
Below is an example of bringing the yellow star to the front, so it is not being blocked by other 
shapes. The star is first selected, then Bring to Front is selected.  

 

To send an object backward, select the object and then on the Shape Format tab > Arrange group 
> Send Backward drop-down arrow. 
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Send Backward Send the selected object backward by one layer. 

Send to Back Send the selected object directly to the back of all objects. 

Below is an example of sending the scroll shape to the back, so it is not blocking the arrow shape. 
The scroll is first selected, then Send to Back is selected.  

  

Note: Other objects such as pictures can be layered by using their corresponding Format tab. Select 
the object you want to layer and select the corresponding tab to modify the arrangement (using 
the Arrange group). 

Objects will automatically float over the top of cells. If those cells have content already in them, they 
will be covered. If you want the content visible, you will need to move your object to another 
location. If you want text on top of the object, you will need to insert a text box. 
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Unit 4 Key Terms 
Term Definition 

Comma Separated 
Value (CSV)   

A comma-separated value (CSV) file allows data to be saved in a format 
that can be used with almost any spreadsheet program.   

Comments A way to add a note or explanation so that other users of the workbook 
can collaborate.  

Export   
When you export data, it is the removal and conversion of raw data from 
their existing format into a new pre-selected format that is required by 
the new application.   

Hyperlink   
A hyperlink is a shortcut to another location in the current workbook, 
opens a stored document, or opens a page on the internet.   

Import   
When you import, you bring in information from an outside source into 
Excel.  

Layer Objects   Arrange objects to create a layer effect.   

SmartArt   
Create and modify specific types of diagrams such as organization charts, 
a matrix, or list processes.   

Special Characters   

Characters that do not fall under numeric or alphabetic characters. They 
include symbols like punctuation marks and characters that have a 
special functionality within Excel, such as the full colon (:) and double 
quotes (").   

Symbols   
Signs, characters, and alt codes that represent important information or 
enhance the representation of the data.  
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Unit 5: Advanced Excel 
Features 
Unit Objectives 
In this unit, you will create and effectively use various chart types, apply different chart elements 
and generate sparklines to visualize data in Excel. Upon successful completion of this unit, you 
should understand the following: 

 Charts 

 Chart Element Types 

 Sparklines
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Lesson 1: Charts 
Lesson Objectives 
In this lesson, you will learn about Excel charts. Charts are graphical representations of data that 
can be used to help communicate information effectively by visually displaying comparisons and 
trends. Upon completion of this lesson, you should be able to understand the following: 

 Create Basic Chart 

 Change Chart Types 

 Move and Resize Charts 

 Modify Chart Design 

 Chart Layouts 

 Add Alternative Text  

 Create Chart Sheets 

 Print Charts 
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Create Basic Chart 

 

The chart function in Excel allows users to create a visual representation of their spreadsheet data. 
Although the process of creating the charts is somewhat automated, it allows the user to customize 
their chart as much or as little as desired.  

A chart is a pictorial representation of the data you enter into a worksheet. Often, a chart can be a 
more descriptive way of representing your data. As a result, those viewing the information provided 
by your spreadsheets may find it more straightforward to examine and understand a chart rather 
than many rows and columns of numbers. A pictorial representation of the data will often help 
identify trends or patterns in the data. 

The example displays a sample chart and a few commonly included chart elements. 

 
The chart’s horizontal axis (also known as the X axis) is located at the bottom of the chart and the 
vertical axis (also known as the Y axis) is located at the left or right side of the chart. Labels can be 
applied to either or both axes. Excel will automatically include a legend with the chart to explain 
the meaning of each line in a line chart or column in a column chart.  

Although you can remove the legend, it may be helpful to others to retain it if your chart has more 
than one data series. A data series is a row or column of numbers that are plotted on a chart. In the 
example the vertical axis displays the number, the horizontal axis displays the city, and the legend 
displays which color represents which month. 

The charting feature is an extremely professional presentation tool and can incorporate fonts, 
patterns, symbols, graphics, and 3-D (three-dimensional) effects. 
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To insert a chart: 

• Select the cell range, then in the Charts group > Insert tab > Recommended Charts tab to open 
the Insert Chart dialog box. A set of charts that are commonly used for the data you have 
selected is displayed 

• If this set of charts does not meet your needs, the full set of chart types and layouts are available 
in the All Charts tab. 

 

You can select the type of chart you want on the left side of the dialog box and select from among 
the different forms of the chart across the top of the dialog box. Available variations of the currently 
selected form appear in the preview area. 

Alternatively, chart types can be selected directly from the Insert tab > Charts group on the Ribbon. 

 
Once the chart appears in the worksheet, the Chart Design and Format tab appear on the Ribbon.  

Microsoft 365 (Web) and Online 

Selecting the Recommended Charts button opens the Recommended Charts pane which displays 
a preview of the chart. Scroll down to view further suggestions and select a preview chart to insert 
it into the worksheet. 
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Change Chart Types 

 

You can change the type of chart you have selected if the chart does not display the worksheet 
information in the way you would like. 

The type of chart to use will depend on what you are trying to display. Line charts are better for 
displaying trends, column charts are better for displaying volume, and pie charts are better for 
displaying portions of a total. 

Excel provides a variety of chart types and several subtypes within each major type. This section 
discusses the most commonly used chart types.  

Column – Use to compare values over time or across categories. This is a vertical presentation of a 
bar chart. 

 
Line – Use to compare continuous trends for a series of data.  

 
Pie – Use to compare the relative size of each portion that together make up the combined total. 

 

Bar – Use to compare values over time or categories. This is a horizontal presentation of a column 
chart.  
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Note: Advanced chart types, including Area, XY, Map, Stock, Surface, Radar, Treemap, Sunburst, 
Histogram, Box & Whisker, Waterfall, Funnel, and Combo are discussed in the Excel Expert course. 

Most of these chart types have both two-dimensional and three-dimensional choices. Three-
dimensional charts can be more interesting but complicated to understand because they tend to 
appear more complex. 

To change the chart type, select on the chart and use one of the following methods to open the 
Change Chart Type dialog box: 

• Chart Design tab > Type group > Change Chart Type 

 

• Right-click in any blank area of the chart > Change Chart Type... 
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Move and Resize Charts  
You can move charts to any location on a worksheet. Typically, you place a chart next to its source 
data so that users can view both at the same time. To move a chart around on a worksheet, use the 
mouse to drag it to its new location. While moving a chart, take care when placing the mouse 
pointer to ensure that you are not moving a single component within the chart by mistake. To move 
an entire chart, you must select on a blank area of the chart where no chart components are located.  

You can also make charts larger or smaller or change their shape. To resize a chart, select and drag 
any of the resizing handles located around the border of the chart. Every chart has eight of these 
handles, four in the corners and four at mid-points between the corners. The mid-point handles are 
used to change either the width or the height of the chart. The corner handles can be used to make 
the chart larger or smaller in two directions at the same time by changing the width and height at 
the same time. Whenever you change the size or shape of a chart, the internal components will 
generally resize proportionately. 

 

 

Modify Chart Design  

 

You can modify and refine your chart using the Chart Design tab. Once the chart has been created, 
it can be altered at any time. The clearest method of altering the chart is to apply a predefined 
layout in the Chart Styles group or use the Quick Layout in the Chart Layout group. There are a 
variety of predefined layouts and styles that can be selected. Also, you can choose to customize a 
layout or style manually by modifying individual chart elements.  
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Microsoft 365 (Web) and Online 

Selecting a chart in the online apps opens the Chart tab. To access the chart formatting options, 
select the Format button in the Format group to launch the Chart pane. 

 

 

Chart Layouts 

 

There are several options to change a chart layout.  

Note: To utilize any of the following processes, you must have an existing chart.  

To select a predefined chart layout: 

1. Select the existing chart, then on the Chart Design tab > Chart Layouts group > Quick Layout 
drop-down arrow. 

 

2. Hover over the available options to observe how it alters the chart elements then select the 
desired option. 

To select a predefined chart style: 

1. Select the chart, then on the Chart Design tab > Chart Styles group > More button to view all 
the available options. 
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2. Hover over the options to view how it alters the visual style of the chart, then select the desired 
option. 

 

Note: The Chart styles will use the colors of the current document theme. To change the colors to a 
different document theme, select the Change Colors option in the Chart Styles group.  

To change the layout of chart elements manually: 

1. Select the chart or select the chart element that you want to change, then on the Chart Design 
tab > Chart Layouts group > Add Chart Element drop-down arrow. 

 

2. Hover over the options to view how the options modify the chart. 

Microsoft 365 (Web) and Online 

Although the online apps do not have Chart Layout or Quick Styles features, it is possible to add, 
remove or modify individual chart elements using the drop-down menus on the Chart tab > Labels 
group or Axes group.  

  
Alternatively, select the arrow next to an element type in the Chart pane > Format tab to display 
modification options. 
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Add Alternative Text  

 

Alternative text (alt text) is descriptive text 
added to graphic objects (such as images, 
charts, shapes, and so on), which can be read 
by screen readers or other text-to-speech tools 
to help those who are visually impaired 
understand the purpose or meaning of the 
object. 

By providing alt text for the graphic objects in 
your workbooks, you help ensure your 
workbooks are globally accessible. 

Add alt text to a chart: 

• Right-click the chart > View Alt Text   

• Format tab > Accessibility group > Alt Text 

In the Alt Text pane, enter a brief description of the chart (or its purpose) in the text box. 
Alternatively, select the Mark as decorative check box to specify that the object is not informative 
in nature 

Note: The Mark as decorative check box is not available in the online apps, although Alt Text 
descriptions may be automatically generated by the app. Always ensure the description is accurate 
before closing the dialog box. 

 

Create Chart Sheets 

 

By default, Excel places a chart in the same worksheet where the source data is located. You can 
move this chart to its own chart sheet, back to its original worksheet, or to a different worksheet.  

When you move a chart to its own chart sheet, the chart will automatically resize itself to fill the 
entire sheet.  

To move a chart to its own sheet: 

• Right-click on a blank area inside the chart > Move Chart... to open the Move Chart dialog box >  
New sheet. Name the sheet as you would any new sheet (or leave the default name) > OK 

• Chart Design tab > Location group > Move Chart > New sheet. Name the sheet as you would 
any new sheet (or leave the default name) > OK  
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Microsoft 365 (Web) and Online 

To move a chart to its own sheet: 

1. Select the + New Sheet icon on the Status Bar to create a new sheet > navigate back to the 
sheet where the chart is located. 

2. Right-click the chart > Move Chart... to open the Move Chart dialog box > select the sheet to 
move the chart to > OK. 

 

 

Print Charts 

 

You can print charts as part of a worksheet or on their own as individual chart sheet(s). Depending 
on the circumstances, each method has its own set of advantages.  

 

When you print a chart as part of a worksheet, you are printing a 
worksheet. In other words, any data or other charts that are on the 
worksheet will also be printed at the same time.  

Therefore, you can change the appearance of the printout by rearranging 
the worksheet: the chart can be moved around with the data above, 
below, or next to it. You can also change the size of the chart and the 
formatting of the data.  

If you select only the chart for printing, whether it is on a worksheet or in 
its own chart sheet, only that chart will be printed. Any data or other 
charts that may be on the same worksheet will not be included in the 
printout. The chart will automatically resize itself to the size of the page. 
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The color charts that Excel creates are interesting to view on the screen but may not translate well  
if printed with color ink. The chart colors will convert to various shades of gray which are difficult to 
distinguish from each other. 

To ensure that you get the best results on paper: 

• Chart Design tab > Chart Styles group > Change Colors drop-down arrow. Choose a 
Monochromatic (single-color) option to select a color palette that is more favorable to black and 
white printers 

As an alternative to selecting a monochromatic color palette, you can manually select a different fill 
pattern of your choosing for each series. These fill patterns allow readers to quickly identify the 
series within each group.  

To add fill patterns: 

1. Double-click the column or bar you would like to fill, and the Format Data Series pane will 
appear.  

2. Select the Fill & Line tab > Fill group > Pattern fill, and then select a pattern. This option works 
with other chart features such as pie slices and areas. 
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Lesson 2: Chart Element Types 
Lesson Objectives 
In this lesson, you will learn about Excel chart elements. Chart elements are used to add, modify, 
or format chart components.  Upon completion of this lesson, you should be able to understand 
the following:  

 Chart Elements 

 New Data Series 

 Switch Source Data 
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Chart Elements 
Chart elements in Excel are items that make a complete chart. Some of the most used chart 
elements include chart titles, legends, gridlines, axis titles, data labels, and trendlines. Once your 
chart has been created, you can add or remove one or more chart elements according to your 
preferences. The Chart Elements menu appears when you select a chart. 

 

Chart elements are used to add, modify, or format chart components such as the chart title, data 
labels, legend, and horizontal or vertical axis. Although the Ribbon option is labeled as Add Chart 
Element, it can also be used to remove the element from the chart. The chart elements include: 

Element Description 

Axes  Choose to have one of the axes as the primary one with a label while leaving 
the label off the other axis.   

Axis Titles Label what the group on an axis represents. For example, numbers may appear 
on the Y axis, but to make it clearer, you could label what those numbers 
represent, such as US dollars or population.  

Chart Title  A chart title is useful to know what the chart represents.  

Data Labels Data labels give more details to the chart by providing the exact data. For 
example, if a bar on a column chart stops somewhere between 60 and 70, a 
data label can tell you that the number for this bar is exactly 64. This can provide 
much more detailed information on the chart, but caution is needed to avoid 
overwhelming the chart with so many details that it is hard to read.  

Data Table Similar to data labels, data tables provide more detailed information. If this 
detail is needed in the chart, but data labels are difficult to read, data tables are 
a good option to clearly display the details of the data in a table under the chart 
portion of the chart.  

Error Bars Used only in area, bar, column, line, and X Y charts, error bars display potential 
errors or an amount of uncertainty in statistical or scientific data.  

Gridlines  Choose among different types of gridlines behind the chart. This can make it 
easier to approximate exactly where the information lines up with the axes.  

Legend  Often there are more than just two categories of data. Two categories can be 
displayed on the axes while a third category can be represented with different 
colors. A legend can clarify what the colors represent.  
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Lines  Used in a line chart, a line starts at the highest point of the line on the chart and 
goes down lining up with each point along the horizontal axis.  

Trendline  Trendlines can overlay a chart displaying a trend to help predict future data.  

Up/Down Bars  Used on a line chart, bars appear at each point along the horizontal axis 
between the two lines. For example, if the lines represent projected sales versus 
actual sales, this is helpful to emphasize where the lines may be far apart versus 
close together. One option can display a difference in the bars when one line 
falls below the other versus above it. 

Quick Layout Used to select from one of several predefined chart layouts for the current chart 
type. 

Change Colors Used to select from one of several predefined color sets for the data points, lines, 
or bars. 

Chart Styles Used to select from one of several predefined chart visual styles.  

Switch 
Row/Column 

Used to exchange the data rows and columns as the data series for the chart. 
This is useful for providing a different focus for the data, such as grouping the 
data by month of sales versus location of sales. It emphasizes one aspect of the 
data over another. 

Select Data  Used to select a different cell range for the chart. This is useful when you are 
adding data. For example, if your chart displays sales per month, and you finish 
a new month, you can add this data without deleting and creating a new chart. 
Just add the sales for the most recent month to the existing chart. 

Change Chart 
Type  

Used to change the chart to a different chart type. 

Move Chart  Used to move the chart between a worksheet and a dedicated chart sheet. 
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New Data Series 

 
New data series or categories can be added to a worksheet at any time but the chart may not be 
automatically updated. You can add this new data to the chart to keep it current using any of the 
following methods:  Copy the new data into the Clipboard > select the chart > Home tab > Clipboard 

group > Paste Special drop-down arrow > Paste Special... In the Paste 
Special dialog box, specify how you want the new data to be added and 
select OK to paste the data into the chart 

When the chart is selected, the data that coincides with the chart is also 
selected. When you point the mouse over a corner of these selected cells, 
a diagonal arrow appears. Then you can drag the boundary of the data 
range selection box on the worksheet to include the new data. The added 
data then appears in the chart. This is normally the quickest method but 

can be used only when the chart and the data are on the same worksheet 

 

Switch Source Data 

 
Switch Source Data allows you to change the cell range (data source) that a chart is based on, so 
the chart updates to reflect the new values. 

To switch rows or columns: 

• Select the chart > Chart Design tab > Data group > Select Data to display the Select Data 
Source dialog box > Switch Row/Column button 
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Lesson 3: Sparklines 
Lesson Objectives 
In this lesson, you will learn about Excel sparklines. Sparklines are scaled-down versions of a chart 
that fit into a single cell. Sparklines will provide a visual description of the data. Place the sparkline 
next to its data for the greatest impact.  Upon completion of this lesson, you should be able to 
understand the following: 

 Insert Sparklines 

 Customize Sparklines 
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Insert Sparklines 

 

Sparklines in Excel are miniature charts inside a worksheet cell. These tiny charts are without axes 
or coordinates. Sparklines highlight variations in data and are an excellent way to represent data 
without having to create large charts. 

Similar to a regular chart, the sparkline displays a visual representation of each value in a horizontal 
or vertical range of cells. Because Excel displays the entire chart in a single cell, only the data points 
are illustrated without any additional components such as a legend, titles, or axis. 

 

 

To insert a sparkline, on the Insert tab > Sparklines group > choose 
the type of sparkline you want to insert. 

In the Create Sparklines dialog box, delete any cell references that 
appear in the Data Range text box, then select the data for which you 
want to create the sparklines. The selected data range appears in the 
Data Range text box. In the Location Range text box, delete any 
existing cell references and either enter or select the range where you 
want the sparklines to display. 

Select OK to insert the sparklines. 

There are three types of sparklines: 

   

Line – Use this chart type to 
represent the values. The 
relative height of each point 
indicates the size of each value. 

Column – Use this chart type 
also to represent the values. The 
relative height of each column 
indicates the size of each value. 

Win/Loss – Use this chart 
type to indicate whether 
each value is positive (greater 
than zero) or negative (less 
than zero). Every bar is the 
same shape and size. 
However, positive values 
appear as higher bars and 
negative values appear as 
lower bars.  
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Sparkline charts have additional capabilities that you will not find in regular charts. The following 
are two examples of these capabilities. You can display data in a regular way with a sparkline chart 
at the same time in the same cells. You can activate markers in a sparkline chart such as high, low, 
first, last, and negative points. Without gridlines and axis markers, these markers help identify 
important points on the chart.

  

 

Customize Sparklines 

 

The Sparkline formatting tab includes a range of different settings and options to modify and 
customize sparkline charts. 

• Sparkline group – Edit or change the data range and location or modify hidden cells 

• Type group – Switch between Line, Column, or Win/Loss sparkline styles 

• Show group – Highlight specific points such as High, Low, First, Last, or Negative values, and 
toggle markers 

• Style group – Apply predefined color themes and visual styles and customize line/column and 
marker colors 

• Group group – Group or ungroup sparklines, clear them from cells and control axis scaling, 
direction, and display options 
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Unit 5 Key Terms 
Term Definition 

Chart   A chart is a pictorial representation of the data you enter in a worksheet. 
Often, a chart can be a more descriptive way of representing your data.   

Legend   Excel will automatically include a legend with the chart to explain the 
meaning of each line in a line chart or column in a column chart.    

Series   A data series is a row or column of numbers that are plotted in a chart.   

X Axis   The chart’s horizontal axis is located at the bottom of the chart.   

Y Axis   The chart’s vertical axis is located on the left or right side of the chart.    
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Appendix A: Course Book Mapping 
Skills required for the Microsoft Excel Associate certification exam.: 

Objective Domain Unit Lesson 

1 Manage Worksheets and Workbooks 

 1.1 Import data into workbooks   

 1.1.1 Import data from text files 4 1 

1.1.2 Import data from online sources 4 1 

1.2 Navigate within workbooks   

 1.2.1 Search for data within a workbook 4 1 

1.2.2 Navigate to named cells, ranges, or workbook elements 2 2 

1.2.3 Insert and remove hyperlinks 4 1 

1.3 Format worksheets and workbooks   

 1.3.1 Modify page setup 1 3 

1.3.2 Adjust row height and column width 1 2 

1.3.3 Customize headers and footers 1 3 

1.4 Customize options and views   

 1.4.1 Manage  the Quick Access toolbar 1 1 

1.4.2 Display and modify worksheets in different views 1 3 

1.4.3 Freeze worksheet rows and columns 1 3 

1.4.4 Change window views 1 3 

1.4.5 Modify built-in workbook properties 1 1 

1.4.6 Display formulas 3 1 

1.5 Prepare workbooks for collaboration and distribution   

 1.5.1 Set a print area 1 3 

1.5.2 Save and export workbooks in alternative file formats 4 1 

1.5.3 Configure print settings 1 3 

1.5.4 Inspect workbooks and correct issues 1 1 

1.5.5 Manage comments and notes 4 2 

2 Manage Data Cells and Ranges 

 2.1 Manipulate data in worksheets   

 2.1.1 Paste data by using special paste options 1 2 

2.1.2 Fill cells by using AutoFill 1 2 

2.1.3 Insert and delete multiple columns or rows 1 2 

2.1.4 Insert and delete cells 1 2 

2.1.5 Generate numeric data by using RANDBETWEEN() and 
SEQUENCE() 

3 2 

2.2 Format cells and ranges   

 2.2.1 Merge and unmerge cells 2 1 

  2.2.2 Modify cell alignment, orientation, and indentation 2 1 
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Objective Domain Unit Lesson 

2.2.3 Format cells by using Format Painter  2 1 

2.2.4 Wrap text within cells 2 1 

2.2.5 Apply number formats 2 1 

2.2.6 Apply cell formats from the Format Cells dialog box 2 1 

2.2.7 Apply cell styles 2 1 

2.2.8 Clear cell formatting 2 1 

2.2.9 Format multiple worksheets by grouping 2 1 

2.3 Define and reference named ranges   

 2.3.1 Define a named range  2 2 

2.3.2 Referene a named range 2 3 

2.4 Summarize data visually   

 2.4.1 Insert Sparklines  5 3 

2.4.2 Apply built-in conditional formatting 2 1 

2.4.3 Remove conditional formatting 2 1 

3 Manage Tables and Table Data 

 3.1 Create and format tables    

 3.1.1 Create Excel tables from cell ranges  2 3 

3.1.2 Apply table styles  2 3 

3.1.3 Convert tables to cell ranges  2 3 

3.2 Modify tables    

 3.2.1 Add or remove table rows and columns  2 3 

3.2.2 Configure table style options  2 3 

3.2.3 Insert and configure total rows  2 3 

3.3 Filter and sort table data    

 3.3.1 Filter records  2 4 

3.3.2 Sort data by multiple columns  2 4 

4 Perform Operations by using Formulas and Functions 

 4.1 Insert references    

 4.1.1 Insert relative, absolute, and mixed references  3 1 

4.1.2 Use structured references in formulas 3 1 

4.2 Calculate and transform data    

 4.2.1 Perform calculations by using the AVERAGE(), MAX(), MIN(), 
and SUM() functions  

3 2 

4.2.2 Count cells by using the COUNT(), COUNTA(), and 
COUNTBLANK() functions 

3 1 

4.2.3 Perform conditional operations by using the IF() function  3 2 

4.2.4 Sort data by using the SORT() function  3 2 

4.2.5 Get unique values by using the UNIQUE() function 3 2 

 4.3 Format and modify text    
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Objective Domain Unit Lesson 

 4.3.1 Format text by using RIGHT(), LEFT(), and MID() functions 3 3 

4.3.2 Format text by using UPPER(), LOWER(), and LEN() functions  3 3 

4.3.3 Format text by using the CONCAT() and TEXTJOIN() functions  3 3 

4.3.4 Get unique values by using the UNIQUE() function 3 2 

5 Manage Charts 

 5.1 Create charts    

 5.1.1 Create charts  5 1 

5.1.2 Create chart sheets  5 1 

5.2 Modify charts    

 5.2.1 Add data series to charts 5 2 

5.2.2 Switch between rows and columns in source data  5 2 

5.2.3 Add and modify chart elements  5 2 

5.3 Format charts    

 5.3.1 Apply chart layouts  5 1 

5.3.2 Apply chart styles  5 1 

5.3.3 Add alternative text to charts for accessibility 5 1 
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Appendix B: Key Terms 
Accessibility Checker    
A tool used to find issues that might make it 
difficult for users with disabilities to access the 
content in the workbook.  
Active Cell     
The cell where you are entering data.  
Alignment    
Refers to the position or placement of data 
within the cell; you can align the cell contents 
horizontally or vertically.  
Auto Fill    
Use to copy data or continue sequential 
patterns in entered data.  
AutoFilter    
Finds and displays the rows where the value in 
the selected column meets your specified 
criteria.  
AutoFilter Icon    
An arrow that appears next to each column title 
and can be used to apply various options.  
AutoFit    
Change a row’s height or column’s width to fit 
the contents.  
Banding   
Use different color shades for alternating rows.  
Borders    
The line type or style that can be applied to one 
or more cells.  
Built-in Custom Lists    
Sort data by specific order such as weekdays or 
months.  
Cell Range    
A rectangular block of cells. You refer to a cell 
range by listing the addresses of two cells at 
opposite corners of the range, separated by a 
colon (:). 
Cell Reference    
The column and row coordinates which 
comprise a cell address. For example, the cell 
reference A1 indicates a cell at the intersection 
of column A and row 1. 
Cell Styles    
A grouping of specific format settings for a cell.  
Chart    
A chart is a pictorial representation of the data 
you enter in a worksheet. Often, a chart can be a 
more descriptive way of representing your data.  
Clear    
Use to remove the contents (or certain 
components that you choose) from the cell or a 
range of cells.  
Column Headings    
Sequential letters at the top of each column 
enable you to identify columns.  
 
 

Comma Separated Value (CSV)   
A comma-separated value (CSV) file allows data 
to be saved in a format that can be used with 
almost any spreadsheet program.   
Comments    
A way to add a note or explanation so that other 
users of the workbook can collaborate.  
Conditional Formatting   
A tool to use to display the data in cells one way 
for some values but another way for others.  
Contextual Tab     
Tabs that appear only when they are applicable.  
Convert a Table    
Choose to return to a regular set of rows and 
columns without the table definition.  
Custom AutoFilter   
Allows you to specify exactly how you want to 
filter the data.  
Custom Views    
Allows you to save your current page layout 
settings with a name so that you can re-activate 
them later.  
Document Inspector    
A tool used to find hidden or private information 
in a workbook and report it to you in a report.  
Excel Table    
A structured and pre-formatted dynamic range 
of cells that has its own name.   
Export    
When you export data, it is the removal and 
conversion of raw data from their existing 
format into a new pre-selected format that is 
required by the new application.   
Extension    
The last four characters in the file name that 
indicate the type of Excel file it is.  
File Tab    
Select the File tab to open the Backstage view.   
Fill Color    
A feature that enables you to apply a 
background color to the selected cell(s).  
Fill Patterns    
A feature where you can apply a pattern style to 
the background of the selected cell(s).  
Filter    
Hide rows of data you are not interested in 
viewing.  
Font    
Refers to the typeface of the text characters, 
such as Times New Roman, Calibri, Century 
Block, Helvetica, etc.  
Footers    
Footers appear at the bottom of every printed 
page.   
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Format Cells Dialog Box    
A dialog box you can activate to select various 
formatting options for a selected cell(s). This 
dialog box contains various tabs to address 
different types of formatting.  
Format Painter    
A tool that enables you to copy the cell 
formatting from one area on the worksheet to 
another.  
Formatting    
Change the appearance of the data using 
various features to draw attention to parts of the 
worksheet, or to make the data presented 
clearer to understand.  
Formula Bar    
Displays the contents of the active cell and can 
be used to add or edit data.  
Formulas    
Formulas are composed of values, cell 
references, arithmetic operators, and special 
functions for calculating and displaying results.  
Freeze Panes    
Locks in place the rows above and the columns 
to the left of a selected cell.  
Function    
A feature designed by Microsoft that enables 
you to quickly perform a calculation or formula 
using a specialized function.   
Gallery    
Type of menu in the ribbon that displays 
multiple formatting options.  
Go To Feature   
A quicker method of jumping to a specific cell or 
object.  
Headers    
Appear at the top of every printed page.  
Hyperlink    
A hyperlink is a shortcut to another location in 
the current workbook, opens a stored 
document, or opens a page on the internet.   
Import    
When you import, you bring in information from 
an outside source into Excel.  
Indented    
Contents in a cell are positioned at least one 
character from the left edge of the cell to create 
an indented appearance. 
Insert Function    
Opens a dialog box to help you choose and 
insert a built-in function.  
Insert Function    
The feature Excel provides to help you select the 
desired function to perform calculations. 
Layer Objects    
Arrange objects to create a layer effect. 
Legend    
Excel will automatically include a legend with 
the chart to explain the meaning of each line in 
a line chart or column in a column chart.

Merging Cells    
A feature commonly used on text labels to 
identify a group of cells together.  
Metadata    
Information about a file that’s stored within the 
file.  
Minimize, Maximize/Restore Down, Close    
Located in the upper right-hand corner of the 
window, these buttons enable you to minimize 
the application window to a button on the 
taskbar, maximize the program to full screen, 
restore the window to its original size, or close 
the application window.   
Mixed Cell Reference    
A cell address where either the column or row 
reference is absolute, and the other reference is 
relative.   
More Button    
Button that opens a gallery.  
Name Box    
Displays the cell address of the active cell.  
Name Manager    
A dialog box where you can modify and delete 
range names, or change the cell range 
references.  
Named Ranges    
Add a meaningful name for a cell or range of 
cells for users to understand the purpose of the 
cells.  
Normal View    
The default view used for entering data and 
working with data.  
Numeric    
Numbers, date, or time values, aligns to the right 
by default.  
Orientation    
A button that allows you to change the direction 
of the characters in a cell in various ways.   
Page Break Preview View    
Used to manage and control vertical and 
horizontal page breaks. 
Page Layout    
A tab on the Ribbon where you find controls and 
settings for printing.  
Page Layout View    
Use to add header and footer information, 
change margins and layout, and adjust how the 
printed document will appear.  
Paste Special    
Paste options to control components of what is 
pasted.  
Print Titles    
Specifies rows or columns (or both) to print on 
every page of the printed output.  
Properties    
Metadata in Excel, some that’s generated 
automatically by Excel (such as the date and 
time the file was created and last modified, who 
created it, and the size of the file), and some you 
add.  
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Quick Access Toolbar (QAT)    
Located above the Ribbon, the QAT provides 
quick and customizable access to frequently 
used commands.  
Quick Styles    
A set of prebuilt styles provided in Excel to apply 
a common type of formatting for specific data, 
such as Headings or currency numbers.  
Ribbon    
A collection of tabs (such as File, Home, and 
Insert) that provides quick access to commands 
used to complete a task. Each Ribbon tab relates 
to a type of activity.  
Ribbon Display Options    
Button to control what displays on the ribbon: 
Auto-hide, Tabs, Tabs, or Tabs and Commands.  
Ribbon Group    
Each Ribbon tab contains groups of related 
commands to edit, format, or enhance items in 
your documents. Some groups include a dialog 
box launcher button at the bottom right which 
opens a dialog box or pane with more 
commands and options.  
Ribbon Tab    
Commands are arranged in tabs that appear on 
the Ribbon, and each tab's commands relate to 
a specific type of activity.  
Row Headings    
Sequential numbers on the left side of each row 
enable you to identify rows.  
Scroll Bars    
Scrolls the spreadsheet to view content that is 
offscreen and not visible.  
Series    
A data series is a row or column of numbers that 
are plotted in a chart.   
Sheet Tab    
The rectangular box at the bottom of a 
worksheet by which the worksheet is accessed 
and identified.  
Shrink to Fit    
An option that shrinks the font size to fit the cell.  
SmartArt    
Create and modify specific types of diagrams 
such as organization charts, a matrix, or list 
processes.   
Special Characters    
Characters that do not fall under numeric or 
alphabetic characters. They include symbols like 
punctuation marks and characters that have a 
special functionality within Excel, such as the full 
colon (:) and double quotes (").   
Split    
Splits the worksheet into two or four panes 
based on the cell pointer position.  
Status Bar    
Displays the current cell mode, auto 
calculations, the View buttons, and the Zoom 
slider. 

Structured Reference    
Reference individual columns within the table 
by adding the column title within square 
brackets.  
Structured Reference or Table Reference    
A special way for referencing tables and their 
parts that uses a combination of table and 
column names instead of cell addresses.   
Symbols    
Signs, characters, and alt codes that represent 
important information or enhance the 
representation of the data.  
Table    
A rectangular block of data in which the rows 
and columns of data have a common structure 
and format.  
Template    
A type of workbook that typically contains data, 
formulas, and formatting, and makes a copy of 
itself for you to use.  
Text    
Alphabetic and numeric characters and most 
printable symbols, aligns to the left by default.  
Theme    
A set of pre-defined formats that can be applied 
to a worksheet for a consistent formatted layout 
and color.  
Title Bar    
Located at the top of the screen, the title bar 
indicates the contents of the window.   
Total Row    
An option you can turn on or off for a table where 
you can select a built-in function such as sum or 
average.  
View Buttons    
Change the on-screen views for the worksheet: 
Normal, Page Layout, and Page Break Preview.  
Wrap Text    
Force the text content in a cell to stay within the 
left and right boundaries of the cell, increasing 
the height of that row to accommodate the full 
length of the text.   
X Axis    
The chart’s horizontal axis is located at the 
bottom of the chart.   
Y Axis    
The chart’s vertical axis is located on the left or 
right side of the chart. 
Zoom Slider    
Drag the slider button to choose a particular 
zoom percentage or use the buttons at either 
side of the slider.  
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Appendix C: Index
A 

Accessibility Checker, 9 
Accounting format, 51 
Advanced Paste Special, 20 
Alt Text, 158 
Application Window, 3 
Auto Fill, 21 
Autofill, 21 

B 
Borders, 62 

C 
Cell Reference, 97 
Cells 
Identify Cell Reference. See 
Cell Reference 
Insert and Delete, 26 
Orientation, 57 
Styles, 65 
Wrap Text, 58 
Chart Sheets, 158 
Charts 
Chart Types, 153 
Data Source, 164 
Elements, 162 
Insert a Basic Chart, 151 
Layouts, 156 
Modify Design, 155 
Move and Resize, 155 
Print, 159 
Check for Issues, 9 
Check for... 
Compatability, 10 
Columns 
Format Width, 27 
Hide, 27 
Insert and Delete, 22 
Comments 
Reply to..., 135 
Resolve and Delete, 135 
Conditional Formatting 
Remove, 68 
Convert a table to a range, 
83 
Currency format, 51 
Customize 
Quick Access Toolbar, 7 
Ribbon, 5 

D 
Data 
Find and Replace Data, 119 
Ranges and Tables, 99 
Date format, 52 

Decimals, 54 
Defined Names, 72 
Document Inspector, 9 

F 
Fill Color, 63 
Filtering, 88 
Font formatting, 60 
Footers, 40 
Format 
Borders, 62 
Cells, 63 
Clear Cell Contents and 
Formatting, 69 
Data, 49 
Dates, 52 
Decimals, 54 
Font, 60 
Times, 53 
Format Painter, 68 
Formulas 
Copy or Move, 101 
Edit a Formula, 96 
Insert a Formula, 95 
Relative Cell Address, 97 
Freeze Panes, 35 
Functions 
CONCAT(), 114 
IF(), 109 
IMAGE(), 141 
Insert Function Tool, 104 
LEFT(), 111 
LEN(), 113 
LOWER(), 112 
MID(), 111 
PROPER(), 112 
RAND(), 106 
RANDBETWEEN(), 106 
RIGHT(), 111 
SEQUENCE(), 107 
TEXTJOIN(), 114 
TRIM(), 113 
UNIQUE(), 108 
UPPER(), 112 

G 
Go To feature, 74 
Graphics 
Arrange and Layer Objects, 
146 
IMAGE() Function, 141 
Insert Images, 139 
SmartArt, 142 
Group worksheets, 66 

H 
Headers, 40 
Hyperlinks 
Insert, 130 

I 
Import Data 
from External CSV Files, 125 
Indent, 56 
Insert Function, 104 

L 
Layer Objects, 146 

M 
Merge cells, 60 
Merge Cells, 59 
Mixed Cell Reference, 98 

N 
Named range, 72 
Named Ranges 
Modify and Delete, 76 
Notes, 136 

O 
Orientation, 57 

P 
Page Layout, 37 
Page Setup, 38 
Paste Special, 18 
Print Options, 43 

Q 
Quick Access Toolbar, 7 

R 
Random Numbers, 106 
Ribbon, 5 
Rows 
Format Height, 28 
Hide, 29 
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S 
Save, 12 
Selection Pane, 145 
SmartArt, 142 
Sort Data 
Multi-Level, 86 
Split View, 33 
Startup Window, 3 
 

T 
Table, 79 
Convert to Cell Range, 83 
Create a..., 79 
Properties, 79 
Style Gallery, 80 
Style Options, 81 
Total Rows, 82 
Table Design, 81 
Table style, 80 
Time format, 53 
Total Rows, 82 

W 
Window View Options, 31 
Workbook 
Create New, 11 
Properties, 8 
Views, 34 
Worksheet 
Delete, 14 
Move or Copy, 15 
Rename, 14 
Worksheet Window, 4 
Wrap Text, 58

 
 

 


