
Fo
r E

va
lua

tio
n O

nly

 

6281-1 v1.00 © CCI Learning Solutions Inc.  51 

 
 

Microsoft®
 

Excel 2013  
 
 

Lesson 2: Organizing Data 

Lesson Objectives 
In this lesson, you will look at various methods of organizing data to improve your ability to analyze it. On 
successful completion of this lesson, you will be able to: 

 create, modify, and delete range names

 use Go To to jump to a cell or named range 

 convert a range of data to a table 

 modify a table by adding and deleting rows and 
columns of data 

 apply and remove formatting on a table 

 sort data

 use filtering on data 

 remove duplicate rows of data 

 outline and group data using automatic 
subtotals 

 outline and group data by manually inserting 
subtotals 

Working with Named Ranges  
Creating Named Ranges  

When developing spreadsheets, you will find that they quickly become very large and it becomes difficult 
to keep track of all the cells. One feature in most spreadsheet programs is the ability to create a meaningful 
name for a cell or range of cells. For example, it is much easier to understand the formula =Total_Revenues–
Total_Expenses than a cryptic formula such as = C7–C18. With meaningful names, it becomes easier for 
users to understand the purpose of these cells.  

To define a range with a name, select the range and then use one of the following methods: 

 On the Formulas tab, in the Defined Names group, click Define Name, or 

 click in the Name Box and type the name, or 

 right-click the selected range and then click Define Name. 

Once you define a name for a cell or a range of cells, you can use that name when creating formulas. Excel 
also provides tools to convert formulas by replacing the cell references with their new range names. 
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You can also quickly jump to a named range by using Go To or by selecting the named range from the 
Name Box list to the left of the Formula bar. 

In addition to making spreadsheets easier to read by using meaningful names, range names can reduce the 
number of errors made. For example, the formula =C7–C18 can easily be entered incorrectly. However, if 
you incorrectly enter any range name in a formula such as =Total_Revenues–Total_Expenses, Excel will not 
be able to match that range name to any cell and will display an error message.  

Range names also reduce errors if you change the cells included in the range. For example, suppose you 
change the cell range for the range name Expenses from C10:C18 to C10:C19. By changing the cell range 
once, then every formula in the workbook that uses the Expenses range name will be automatically 
updated. If you did not use a range name, then you must ensure that the cell range C10:C18 is changed 
wherever it is used in the workbook. You will likely miss one or more of them. 

Range names can be from 1 to 255 characters in length. They may contain alphabetic or numeric characters 
(alphanumeric), underscores (_), backslashes (\), periods (.) and question marks (?). You cannot use spaces 
in range names. The first character must be alphanumeric, an underscore, or a backslash. 

 

Learn the Skill 
This exercise demonstrates how to create range names and set up formulas using those range 
names. 

1 Open the Income Statement workbook and save as Income Statement ‐ Student. 

 Now create a range name to use in sales calculations. 

2 Select cells C5:C6. 

3 On the Formulas tab, in the Defined Names group, click Define Name. 

 The New Name dialog box displays with the cell range entered. 

4 In the Name field, type: Revenues and click OK. 

 From now on, whenever you select these two cells, the range name Revenues displays in the Name 
Box, which appears to the left of the Formula Bar.  

  
5 Select each of the cells in the cell range C5:C6 and observe what displays in the Name Box.  

6 Select the cell range C5:C6 and observe what displays in the Name Box.  

 This demonstrates that the range name only appears when the entire range is selected.  

7 Select cells C10:C17. On the Formulas tab, in the Defined Names group, click Define Name. 

8 In the Name field, type: Expenses and click OK. 

 You can also create a range name by selecting the desired cell(s) and clicking in the Name Box on the 
Formula bar. You can then type the desired name and press . 

 Now enter summary formulas using this range name.  
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9 Select cell C7. 

Note: Range names are not case sensitive – you can enter any mixture of upper and lower case characters. 

10 Type: =SUM(Revenues) and press . 

 Notice that as you type the first one or two characters of the range name, a quick tip box appears, 
showing you this name and other functions with similar names. You can double-click the range name 
in the quick tip box to select it and continue with entering the rest of the formula. 

  
11 Select cell C18, type: =SUM(ex to enter the first part of the formula. 

12 Double-click on the Expenses name in the quick tip box to select it, continue with typing: ) and press 
. 

 As another reminder, Excel permits you to omit entering the last parenthesis for this function. However, 
Excel does not permit this for every function, and it is poor practice.  

13 Select cells B7:C7. 

14 On the Formulas tab, in the Defined Names group, click Create from Selection. 

  
15 Verify that the Left column check box is the only one turned on and click OK.   

16 Select cell C7. 

 Note that the range name in the Name Box is Total_Revenues. 

Hint: Excel does not permit blank spaces in range names. You can use the underscore character as one 
alternative between the words in a multi-word range name. 

 Create a range name for the Total Expenses cell, but this time, using the Name Manager.  

17 Select cell C18.  

18 On the Formulas tab, in the Defined Names group, click Name Manager. 

 The Name Manager dialog box is now displayed.  

19 In the Name Manager dialog box, click New to create a new range name. 

20 Verify that the Name is Total_Expenses and that the Refers to field contains the formula 
=Sheet1!$C$18, then click OK. 

 If the New Name dialog box is blocking access to the worksheet behind it, you can minimize it 
temporarily by clicking the Collapse button to the right of the Refers to field. You can then select a 
range of cells from the worksheet. 
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The Name Manager dialog box now has this new range name added, similar to the following example: 

  
21 Click Close to close the Name Manager dialog box. 

Enter the formula to calculate the Net Income, using the range names.  

22 Select cell C20, and type: =  

23 On the Formulas tab, in the Defined Names group, click Use in Formula. 

  
24 Click Total_Revenues, then press  to indicate that you are going to perform a subtraction. 

25 On the Formulas tab, in the Defined Names group, click Use in Formula. Click Total_Expenses and 
press . 

  
26 Save the workbook.  

Modifying and Deleting Named Ranges 
You can use the Name Manager to modify and delete range names or change the cell range references. 

Be cautious when deleting named ranges. When you delete a named range, any formula that refers to this 
name no longer displays the correct value. Deleting a range name may also cause a domino effect with 
other formulas that indirectly refer to this formula. 

 

Learn the Skill 
This exercise demonstrates how to the Name Manager to update and delete range names. 

1 Ensure the Income Statement – Student workbook is open. 
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 A common situation is adding more rows to a named range. As long as you add the rows inside the 
range, Excel automatically includes the new data as part of the range. If you add the new data outside 
of the range, you will need to expand the range to include the new row(s). 

3 Click the gray header for row 18 to highlight the entire row. Right-click in the highlighted row and click 
Insert in the menu. 

4 Select cell B18, type: Travel and press . 

5 In cell C18 type: 1400 and press . 

 Note that none of the figures in the report changed because the new entry sits outside of the named 
range Expenses. Now expand the named range to include the new entry.  

 When you first created the range name, you could have included additional blank cells for future 
growth. Then, as you add new entries to the list, Excel automatically recalculates the total expenses 
formula. 

6 On the Formulas tab, in the Defined Names group, click Name Manager. 

7 In the Name Manager dialog box, click the Expenses row to select it. 

8 In the Refers to text field, change the range to =Sheet1!$C$10:$C$18 as the range. 

9 Click Update (the checkmark) to the left of the field to update the changes, and click Close. 

 The worksheet should now show the correct calculations for each of the functions: 

  
Try deleting a named range and see how it affects the worksheet. 

10 On the Formulas tab, in the Defined Names group, click Name Manager. 

11 Click the Revenues row and then click Delete. 

 Excel displays a message box asking you to confirm the deletion of this range name.  

12 Click OK for the confirmation message box and then click Close to close the Name Manager dialog 
box. 

 As shown in the following example, when you remove a named range, Excel displays an error indicator 
regarding any formulas that depend on that name. Note also that the change has affected the formula 
in cell C21 as well, even though it does not use the range name Revenues directly.   
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13 In the Quick Access Toolbar, click Undo.  

14 Save the workbook.  

Go To a Cell or Named Range  
Moving from cell to cell in a worksheet is a very simple because the process is the same as with other 
Windows programs. You can select a cell that appears on the screen simply by clicking on it. If you need to 
scroll to sections of the worksheet that are currently off the screen, you can use the scroll buttons.  

With Excel, you can use a quicker method of jumping to a specific cell 
(as long as you know exactly what the cell address is) by using the Go 
To feature. With very large worksheets, the Go To feature helps you to 
navigate around them more easily. 

To display the Go To dialog box, use one of the following methods: 

 Press , or 

 Press + . 

Alternatively, you can also use the Name Box located to the left of the 
Formula Bar to select a named range of cells or to jump to a specific 
worksheet cell.  

  

Learn the Skill 
This exercise demonstrates how to jump to a cell or named range using the Go To dialog box 
and the Name Box. 

1 Ensure the Income Statement – Student workbook is open. 

2 Click on cell A3 to jump to that cell using the mouse. 

 Now select a cell range using the Go To dialog box.  

3 Press . 

4 In the Go To dialog box, click Expenses and click OK. 

 Use the Name Box to jump to another named range. 
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5 Click the drop-down button in the Name Box, and click Revenues. 

  
 The cell range C5 to C6 is now selected. Use the Go To dialog box to jump to another cell in the 

worksheet. 

6 Press + , type: H14 in the Reference text box (be sure that the H14 is the only address in that 
text box) and click OK. 

 Use the Name Box to jump to a different cell. 

7 Click in the Name Box, type: F3 and press . 

8 Save and close the workbook. 

Using Tables 
Creating a Table 

Many worksheets consist of a rectangular block of data in which the rows of data have a common structure 
and format. Excel offers you the ability to define this block as a table. As a table, you can use a variety of 
tools such as selecting summary formulas, formatting, sorting, and filtering. These same features are 
available even without using tables but you had to insert these features manually by selecting the range of 
cells that apply. However, by defining a range of cells as a table, you indicate to Excel that this group 
belongs together as a single unit. These same tools are then easier to apply because Excel now knows 
which cells to include.  

A table is not the same as a named range of data but you can define a range name for a table if you wish. 

To create a table, the data must be contiguous. That is, there must not be any blank rows or columns in the 
range of cells. Also, the data must be arranged in row order, with a header at the top of each column and 
the data listed below. 

To convert a range of cells containing data to a table, use one of the following methods: 

 On the Insert tab, in the Tables group, click Table, or 

 on the Home tab, in the Styles group, click Format as Table, 
then click a table style, or 

 after selecting the cell range, click the Quick Analysis icon, 
then click the Tables category and click Table, or 

 press + . 

 
Once you create the table, Excel activates an AutoFilter icon next to each column title and applies the 
current active theme. The Table Tools Design tab is also added to the Ribbon: 

 
One of the table features is the ability to insert an automatic Total Row at the bottom of the table. 
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Learn the Skill 
This exercise demonstrates how to create a table, assign a name of your choice to the table, and 
add a total row at the bottom. 

1 Open the Monthly Call Volume workbook and save as Monthly Call Volume – Student. 

For the purpose of this exercise, we will delete the bottom row and add it back in later. 

2 Click the row 16 header and then, on the Home tab, in the Cells group, click Delete. 

Now convert the data to a table. 

Hint: When creating a table, leave at least one empty row and column on all sides of the table to separate 
it from any other data on the worksheet. 

3 Click on any cell in the range A4:E15. 

4 On the Insert tab, in the Tables group, click Table. 

   
5 Confirm that My table has headers is turned on and then click OK. 

The data is now converted into a table. Change the table name to something that is more meaningful to 
you.  

6 Under Table Tools, on the Design tab, in the Properties group, click in the Table Name field and 
replace the default name to: CallVolume (with no spaces between the words). 

Turn on the automatic Total row. 

Note: When you activate the Total row, Excel automatically moves any data below the table down by one 
row. 

7 Under Table Tools, on the Design tab, in the Table Style Options group, click Total Row to turn it on. 

 Enter some common statistical formulas using the data in the table. 

8 Select cell B16, click the drop-down arrow that appears next to it, and click Average. 

9 Repeat step 8 for the Count, Max, and Min options for cell B16. 

10 Repeat step 9 for the Sum option for cell B16. 

11 Select each of the cells C16:D16 and select the Sum calculation. 

Note: You cannot copy the contents of a column total to other cells in a table. 

If you also want to display row totals (in a new column to the right of the table), you will have to insert 
them manually. Tables do not have the ability to create row totals automatically. Row totals show the 
sum total for each row of data.  

12 Click on cell F4 and enter: Total. 

 Insert the SUM formula for the first row. 

13 With cell F5 as the active cell, on the Home tab, in the Editing group, click AutoSum and press . 
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 Even though you only entered the row total for the first row, Excel has automatically inserted them for 
the rest of the rows, except the Total row. This demonstrates one of the advantages of identifying this 
range of cells as a table.  

14 Click on cell F5. 

 You can see that the formula used for this sum total is specifically used for tables. 

  

 Now insert the Total Row calculation for this new column. 

15 Select cell F16, click its drop-down arrow, and select Sum. 

  

16 Save the workbook. 

Modifying Table Data 
After the table is created, you can add or delete rows and columns of data.  

To add a new column of data at the far right of a table, simply enter this data into the first blank column. 
Excel will automatically extend the table to include this new column. Similarly, Excel will extend the table to 
include a new row of data that you enter directly below a table, as long as the Total Row feature is not 
activated. If the Total Row is activated, you must use one of the following methods: 

 Manually insert a new blank data row by clicking on the bottom right cell containing data (immediately 
above the Total Row), and then clicking the  key.  
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 Manually insert a new blank data row by clicking any cell in the bottom 
data row, then on the Home tab, in the Cells group, click the arrow next 
to Insert, and click Insert Table Row Below. 

 Add the new row of data below the Total Row, and then manually extend 
the table to include the new row.  

The Insert button in the Home tab can be used to insert a new row or column 
anywhere in the table, not just as the last row of data. Be aware that the Insert 
drop-down menu may show different Insert Table options, including various 
combinations of Insert Table Rows Above, Rows Below, Columns to the Left 
and Columns to the Right, depending on which cell in the table is currently 
selected as the active cell.  

Similarly, on the Home tab, in the Cells group, you can use the 
Delete button to delete rows or columns of data from the table. 

If you no longer wish to keep the data in a table, you can 
convert it back to a regular set of rows and columns of data 
without the table definition. Under Table Tools, on the Design 
tab, in the Tools group, using the Convert to Range tool to 
convert the data. 

 

 

Learn the Skill 
This exercise demonstrates how to insert rows and columns of data into different parts of a 
table, and convert the table back to a range of cells. 

1 Make sure the Monthly Call Volume - Student workbook is selected. 

Now add a new row at the bottom of the table. 

2 Select cell F15 and press . 

 Notice that Excel automatically shifts the Total row down by one row and that the formula in cell F15 is 
copied down to this new row. 

3 In cell A16, type: December 2013 as the new value and press . 

4 Enter the following values into the remaining cells of the row: 
B16 8969 
C16 7375 
D16 7 
E16 1 

 Notice also that the statistical formulas in row 17 (these were all Sum but you may have selected 
Average or other formulas instead) automatically updated even though the new data were added at 
the bottom of the list. 

Now add a new column between the Complaints and Total columns. 

5 Select cell F8, then on the Home tab, in the Cells group, click the arrow next to Insert, and click Insert 
Table Columns to the Left. 

6  Click cell F4 and type: Other. 
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7 Enter the following values into the remaining cells of the column: 
F5 500 
F6 300 
F7 250 
F8 450 
F9 400 
F10 220 

F11 200
F12 480 
F13 100 
F14 200 
F15 150 
F16 300 

8 Select cell E17, click the drop-down arrow that appears next to it, and click Sum. 

 By adding a column to the table, you must ensure that the Total column at the far right includes this 
new column. 

9  Click on cell F5, and note the formula in the Formula Bar. 

10  Press , delete the table cell reference [Complaints], and replace it with: [Other]. 

 If no longer needed, a column (or row) can be easily removed from a table. 

11  Click on any cell in the range D4 to D17, then on the Home tab, in the Cells group, click the arrow next 
to Delete, and click Delete Table Columns. 

  
Add another row of data to the table using a different method. 

12 Enter the following values: 
A18 January 2014 
B18 7000 
C18 4000 
D18 20 
E18 200 

13 Ensure that cell F17 is not the active cell, then position the cursor at the bottom right corner of cell F17 
so that the cursor changes to a double-headed arrow . 

14 Click and drag the resize handle down to row 18. 

Hint: If the Total Row is not activated for this table, the new row would have been automatically added to 
the table. 

Because you had added the new data below the Total Row, Excel did not know if you intended to keep 
that data separate from the table. Therefore, you had to manually expand the table to include the 
January row.  

Convert the table back to a regular range of cells.  
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15  Ensure that the active cell is anywhere within the table, then under Table Tools, on the Design tab, in 
the Tools group, click Convert to Range. 

  
16 Click Yes. 

 The worksheet does not appear any different, except that the Table Tools Design tab no longer 
appears and the column titles no longer display the filter buttons.  

17 Click the drop-down button on the right side of the Name Box to display the list of any range names in 
the worksheet. 

 This indicates that the Convert to Range tool simply converts the data to a set of rows and columns 
with data. If you want to create range names, you must add them manually.  

18 Click on any cell in the worksheet to close the Name Box list. 

 Revert the data back to a table.  

19 In the Quick Access Toolbar, click Undo.  

20 Save the workbook. 

Formatting Table Data 
By default, the theme selected for the workbook is applied to all tables in that workbook. You can override 
it for specific tables by selecting a different table style under Table Tools, on the Design tab, in the Table 
Styles group: 

The table style colors option can also be removed, and re-applied later if needed again. If none of these 
predefined table styles are suitable, you can also create a customized one.  

The Table Tools Design tab also allows you to 
activate or de-activate other table formatting options 
including: 

 Highlighting the first or last column – or both – 
with the bold font option. By default, both 
options are turned off. 

 “Banding” rows by using different color shades 
for alternating rows. This feature often improves 
the readability of tables that are very wide 
because data in the same row have the same 
color shade. By default, the Banded Rows option 
is turned on, but Banded Columns is turned off. 
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Learn the Skill 
This exercise demonstrates how to change and remove the table style, and use different table 
band formatting options. 

1 Make sure the Monthly Call Volume - Student workbook is selected. 

 Preview some of the different table styles that are available. 

2 Click any cell in the table. 

3  Under Table Tools, on the Design tab, in the Table Styles group, click the More button to display all of 
the table styles. 

4 Point the cursor to different table styles and observe the live preview effect on the table. 

5 Click on any cell in the worksheet to close the table styles menu and keep the current table style 
unchanged. 

 Highlight the left-most and right-most columns so that they stand out. 

6  Under Table Tools, on the Design tab, in the Table Style Options group, click the First Column and 
Last Column check boxes to turn them on. 

 Activate the Banded Columns option to see how it affects the table. 

7  Under Table Tools, on the Design tab, in the Table Style Options group, click the Banded Columns 
check box to turn it on. 

8  Under Table Tools, on the Design tab, in the Table Style Options group, click the Banded Columns 
check box to turn it off. 

 The table styles can also be removed from the table. 

9  Under Table Tools, on the Design tab, in the Table Styles group, click the More button, then click 
Clear. 

  
 Notice that the bolding in the first and last columns, and the Total row in the table are also removed, 

even though the check boxes in the Table Style Options group are still activated. 

10 In the Quick Access Toolbar, click Undo. 

11 Save the workbook. 
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Sorting Data  
Worksheets with a large amount of data are often difficult to understand. Excel provides a sorting tool that 
enables you to change the sequence of the data based on the values in selected columns. After sorting, the 
data becomes more readable. You can sort and re-sort the data as many times as required, using different 
columns each time. You can sort the data by columns or rows, but the most common method is sorting by 
columns (with column headers and the data extending downwards). 

Sorting by Single-Level Data  
The Ribbon offers the quickest method of sorting your data but you are limited to sorting by one column. 
The Ribbon has two ready-to-use buttons for this: 

 on the Home tab, in the Editing group, 
click Sort & Filter and then click Sort A 
to Z to sort in ascending sequence or 
Sort Z to A to sort in descending 
sequence, or 

       

 on the Data tab, in the Sort & Filter 
group, click Sort A to Z or Sort Z to A. 

    
Depending on what type of data you are sorting, the Ribbon menu will display a different command 
description. If the data is text, the Ribbon menu will display Sort A to Z and Sort Z to A. If the data 
contains numbers or times, the Ribbon menu will display Sort Smallest to Largest and Sort Largest to 
Smallest. If the data contains dates, the Ribbon menu will display Sort Oldest to Newest and Sort Newest 
to Oldest. 

Sorting by Multi-Level Data  
In many cases, you will need to sort by more than one column to handle situations with multiple rows with 
the same value. For example, you may have a customer list with several people having the same last name. 
In this situation, you will want to sort the list using two columns – one containing the customer’s last name 
and the other containing their first name. 

The example below shows a range of data sorted using three different columns as sort keys. The primary 
sort key is airline name in ascending order, as indicated by the green marker: A at the top, down to Z at the 
bottom. The destination name is the secondary sort key, as designated by the first Then by selection: for 
rows with the same airline. These rows are sorted by destination name as indicated by the red box. The 
third level sort key in this example is the departure time: for rows where the same airline is flying to the 
same destination on the same day. These rows are sorted by the departure time as designated in the 
second Then by selection. This group is identified by the blue box. 
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The settings in the Sort dialog box determine how the data is to be sorted: 

Add Level, 
Delete Level, 
Copy Level 

These buttons allow you to add, delete or copy columns (or rows) in this dialog box to 
be used as sort keys. Note that the topmost sort key is the highest (primary) sorting 
level, followed by the remaining levels in descending order.  

Move up / 
Move down 

These buttons allow you to change the selected sort level higher or lower in the sorting 
sequence.  

Options This button displays a dialog box that allows you to sort by columns or rows, and 
choose whether to treat the data as case-sensitive or not. If you turn the case-sensitive 
option on, then upper case letters are treated as different characters than lower case 
characters. For example, the letter “A” is not the same as the letter “a”. 

My data has 
headers 

This option tells Excel to treat the first row (or column) of cells as labels or titles for the 
data below (or to the right). Use this option to prevent sorting the header data together 
with the other data—they will remain in their place as headers. If the range of cells 
being sorted does not contain column or rows headers, then turn off this setting.  

Column/Row This identifies the column or row to be used for sorting. The sequence of these columns 
or rows specifies the sorting level. By default, the data is sorted by column with the 
headers in the top row. 

Sort On The sort options include Values (cell data), Cell Color, Font Color, or Cell Icon. These 
options identify what to use in the cells for sorting. In most cases you will want to sort 
using the cell values, which is the default. 

Order This option indicates whether to sort the data in ascending (A to Z, Smallest to Largest, 
Oldest to Newest) or descending (Z to A, Largest to Smallest, Newest to Oldest) order. 

Sort by This is the primary sort key: the first column or row Excel will use to sort the data.  

Then by These are optional columns or rows for sorting if multiple rows have the same primary 
sort key. You can select up to 64 columns or rows as sort levels.  
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Learn the Skill 
This exercise demonstrates how to sort a table of data using one column as a sort key. You will 
then sort the data again using multiple columns. 

1 Make sure the Monthly Call Volume - Student workbook is selected. 

 First, sort the data using one of the columns.  

2 Click the AutoFilter icon for Sales Inquiries, then click Sort Largest to Smallest.  

  
 Now select a second column for sorting.  

3 Click the AutoFilter icon for Complaints , then click Sort Smallest to Largest. 

 You can see that all of the rows have been re-sorted using only the Complaints column. Both steps 2 
and 3 used single-level sorting. 

  
Now sort the data using two different columns at the same time. 

4 Ensure that the active cell is anywhere inside the table, then on the Home tab, in the Editing group, 
click Sort & Filter and then click Custom Sort. 

 Excel displays the Sort dialog box.  

Hint: You can also open the Sort dialog box from the Data tab. 

5 Click the arrow next to the Sort by field and click Other. 

 The Other column is the primary sort key. Use the Sales Inquiries column as the secondary sort key.  

6 Click Add Level to add another sort key. 

7 Click the arrow for Then by and then click Sales Inquiries. 

8 Click the arrow for Order and then click Largest to Smallest, then click OK. 
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 Notice the direction of the arrows in the AutoFilter icon for the Sales Inquiries and Other headers. 

 To put the data back to its original sequence, you will need to change the sort order.  

9 Click the AutoFilter icon for Month, then click Sort Oldest to Newest.  

10 Save the workbook. 

Filtering Information 
Worksheets are often used to store large amounts of data. Finding information in large worksheets is often 
difficult because of the sheer volume. Sorting the rows is one way of making it easier to find information. 
However, you still have to look through many of the rows in the worksheet to find what you are looking for. 
Another way to locate information quickly is to use a filter to hide the rows you are not interested in 
viewing. Filtering does not change the content of your worksheet or the sequence of the rows (like the way 
sorting does), only what you see of your worksheet. 

The quickest and easiest way to filter data in Excel is to use the AutoFilter  icons on the right side of each of 
the column titles. If the data is formatted as a table, the AutoFilter icons will be activated by default. If the 
data is not formatted as a table, you can activate them for any range of data. 

In its simplest form, the AutoFilter finds and displays the rows where the value in the selected column 
meets the criteria that you specify. All other rows are hidden from view until you change the filter criteria or 
you turn the AutoFilter off.  
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The AutoFilter also has the flexibility to help you build more complex queries which you can use to narrow 
the results and hide rows that you do not want. For example, you can select criteria that examine two or 
more columns, or that are equal to one of two or more values. In addition, Excel provides powerful 
selection criteria that are specific to columns containing text, numbers or dates, such as the following:  

Numbers Evaluate numeric data in the selected column using any of the 
following: 

 A comparison operator such as equals, greater than, and less 
than. 

 The top 10 values. Despite the name displayed in the menu, the 
filter criteria can also be configured differently to select the top 
or bottom-most rows. You can also select any number of rows, 
not just 10. And finally, you can select the number of rows or 
percentage of rows. For example, 10% of 20 rows will result in 
only two rows being displayed. 

 All rows above or below the average of all values in the column. 

 A custom filter that allows you to select more complex criteria.  

 

Dates Evaluate date-type data using a wide variety of criteria that are 
specific for dates, as shown in the filter menu list: 

 
Text 
 

Evaluate text data in the selected column using any of the 
following: 

 A comparison operator such as equals, greater than, and less 
than. 

 Begins or ends with a snippet of text. 

 Contains or does not contain a snippet of text. 

 A custom filter that allows you to select more complex criteria.  
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Learn the Skill 
This exercise demonstrates how to use AutoFilters on a table of data. 

1 Make sure the Monthly Call Volume - Student workbook is selected. 

2 Click the AutoFilter icon for the Month header. 

Activate the AutoFilter and select all rows for specified months.  

3 Click the + for 2013 to open that tree and see all data rows in the table for this year value. 

 The AutoFilter menu displays a list of every unique value in this column. You set the filter by turning 
the check box on or off for the value(s) you want.  

  
4 Scroll up and click the Select All check box to turn it off, then click the March and June check boxes to 

turn them on. Click OK. 

 The table now shows only those two rows. Notice the row numbers of the records that remain 
displayed from the database. Excel hides the rows that do not meet the criteria and displays only 
records that have a matching value in the filtered field. Excel also changes the AutoFilter icon to 
indicate that it is using a field to limit the records displayed. 

  
 The conditions you select are called filter criteria. You can also set up criteria for text, time, and numeric 

values.  

5 Click the AutoFilter icon for the Month header again. 

6 Point to Date Filters then click Between in the menu. 
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7 Click the Date Picker buttons next to each of the two blank entry fields and select the date range July 1, 
2013 to November 30, 2013 so that the dialog box appears as follows: 

  
8 Click OK. 

9 Click the AutoFilter icon for the Other header. 

10 Click the Select All check box to turn it off, then click the 200 check box to turn it on. Click OK. 

 The results should look similar to the following: 

  
 Now turn off the filter on the Other column. 

11 Click the AutoFilter icon for the Other header, then click Clear Filter From “Other”. 

 The table has reverted back to displaying all of the months from July to November. Turn off the filter 
on the Month column as well.  

12 Click the AutoFilter icon for the Month header, then click Clear Filter From “Month”. 

 The full table is displayed again.  

13 Save and close the workbook.  
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Removing Duplicate Rows  
Excel has the ability to find and remove duplicate data rows from a cell range. This is often a useful feature 
for worksheets with a lot of data especially when the data came from multiple sources or the data entry 
system does not have an ability to prevent duplicates from occurring. 

 
You can select all columns or only selected columns to be used for comparing the data. For example, you 
can scan a data table containing customer numbers, name, and addresses to find any rows where the same 
customer is listed two or more times. Alternatively, you can select just the last name and first name 
columns to find and remove duplicate rows.  

On the other hand, Excel will only look for identical data when comparing rows. For example, Excel will 
consider two rows as different if the address in one row contains “1234 Miller Road” and the other row 
contains “1234 Miller Rd.”. Every blank space, comma, number, and other character in each cell is used to 
find exact matches.  

 

Learn the Skill 
This exercise demonstrates how to use the remove duplicates feature. 

1 Open the Customer List workbook and save as Customer List – Student. 

 Do you think this list has any duplicate data in it? 

2 Scan through the data on your own to see if all rows are unique. 

 Now use the Remove Duplicates command in Excel. 

3 Select any cell in the table. 

4 On the Data tab, in the Data Tools group, click Remove Duplicates. 

5 Click OK. 

 A message box is displayed with the message: “No duplicate values found.” 

 That should be enough to confirm that there are no duplicate rows in the data. Or maybe we did not 
use the command correctly. 

6 Click OK to close the message box. 

7 On the Data tab, in the Data Tools group, click Remove Duplicates. 

 This time only use the columns that really matter. Turn off the check box for all other columns.  

8 Click the Customer # check box to turn it off and click OK. 
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 A message box is displayed with the message: “3 duplicate values found and removed; 25 unique 

values remain.” 

9 Click OK to close the message box. 

  
 By comparing the results from the original table, customers 16, 26 and 27 were found to be duplicates. 

10 Save and close the workbook. 

Outlining  
Using Automatic Subtotals 

Many worksheets become very large due to the sheer amount of information needed for analysis. 
Inevitably, summary totals are added for each major group of data as well as grand totals. The end result 
can be a worksheet that is difficult to see from one end to another. 

To help organize the data, Excel provides an automatic outlining tool that enables you to insert subtotals 
whenever the selected field changes in value. You can make a very big worksheet easier to understand by 
setting it up so that you see only the subtotals for each group of data. An important step is organizing the 
data so that the subtotals are displayed for the data groups you want. 
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With the Outline feature turned on, you can quickly open up all or selected groups of data and collapse 
them again. Before creating the subtotals, you must sort the data by column to group these related rows 
together. Otherwise, the results will not make much sense. 

You can also create multiple subtotals for a single column or several layers of columns. For example, you 
can calculate the sum, average, and variance subtotals for as many numeric columns as you require. You 
must add each different type of subtotal as a separate row to identify the type of subtotal. 

You can create a more complex type of multiple subtotals by nesting them. For example, suppose you have 
a sales report listing every sales transaction for a year. As long as you have a separate column for the 
month value, you can create subtotals based on the month. You can then create another layer of subtotals 
based on the date of each sale which is in a different column. Assuming that you will have multiple sales 
each day, you can nest your subtotals by day of each month and by month of the year. The outline feature 
then allows you to quickly open or collapse your worksheet at the year, month, or day level. 

The key difference in creating multiple subtotals is how you use Replace current subtotals. When creating 
the first (or only) subtotal for a worksheet, ensure this check box is turned on. When creating subsequent 
subtotals, ensure this check box is turned off. 

 

Learn the Skill 
This exercise demonstrates how to create automatic subtotals for one and two numeric 
columns. 

1 Open the Sales workbook, and save it as Sales Subtotal – Student. 

2 Scroll down the worksheet to see how many rows of data are present. 

Create an automatic subtotal based on the Payment Type but first sort the worksheet by this column. 

3 Select any cell in column E. 

4 On the Data tab, in the Sort & Filter group, click Sort A to Z. 

Now create the subtotals on the Amount Paid column. 

5 On the Data tab, in the Outline group, click Subtotal. 

6 Click the drop-down button for At each change in and select Payment Type. 

7 In the Use function list box, click the drop-down and select Sum. 

8 In the Add subtotal to list, click the Amount Paid check box to turn it on, and turn off all other check 
boxes in this list. 

9 If necessary, click Replace current subtotals and Summary below data to turn them on, and clear 
Page break between groups if necessary. 
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10 Click OK. Then scroll down the worksheet to see how the data now appears. 

 Notice that the worksheet now has three outline levels at the left side. Each of these numbers 
corresponds to a different level of detail: clicking  compresses the data rows so that only the grand 
total is displayed. Clicking  also compresses the data rows but displays the subtotal rows and grand 
total. Clicking  shows all data rows for that level as well as the subtotals and the grand total. 

Now practice with the outline features. 

11 Click  at the top of the outline section and then scroll up to the top of the worksheet. 

  

 The  and  buttons work the same way as in File Explorer: clicking the  opens the level and shows 
the data in the next level. Clicking the  collapses the details. 

Note: You can only use the outline buttons with the mouse. 

12 Click  to display all rows again. 

13 Scroll up and click the  to the left of the Mastercard Total and then scroll up the worksheet for a few 
more rows. 

14 Click  at the top of the outline section and then scroll up to the top of the worksheet. 

  
Note: When you remove some subtotals, you remove all subtotal functions. You cannot remove some 
subtotals and keep the rest. 

15 Click  to display all rows again. 

Now remove all of the subtotals from the worksheet. 

16 Click on any cell in the data area to ensure that it is selected, then on the Data tab, in the Outline 
group, click Subtotal. 

17 Click the Remove All button to clear the subtotals. 



Fo
r E

va
lua

tio
n O

nly

Organizing Data Lesson 2 
 

 

6281-1 v1.00 © CCI Learning Solutions Inc.  75 

You can also calculate two different types of subtotals for the same (or different) column(s) in the 
worksheet at the same time. 

18 On the Data tab, in the Outline group, click Subtotal. 

19 In the Subtotal dialog box, configure the following settings and click OK: 

At each change in Payment Type 
Use function Sum 
Add subtotal to Amount Paid 
Replace current subtotals On 
Summary below data On 

20 On the Data tab, in the Outline group, click Subtotal again. 

21 In the Subtotal dialog box, configure the following settings and click OK: 

At each change in Payment Type 
Use function Count 
Add subtotal to Amount Paid 
Replace current subtotals Off 
Summary below data On 

 Note that when you are adding another subtotal to an existing one, you have to clear Replace current 
subtotals. 

22 Scroll down the data and see how it now appears. 

23 Save the workbook. 

Manually Grouping and Ungrouping Data 
Creating an outline of an Excel worksheet using automatic subtotals is a very useful feature but only if the 
data are structured consistently, as demonstrated in the previous topic. However, not all worksheets have 
data designed in such a way that there is a clear break from one group of rows or columns to the next 
group. 

On some worksheets, you need to insert summary functions manually where they are required. To create 
an outline of a worksheet using this manual grouping method, you must adhere to the following 
guidelines: 

 The worksheet must already contain summation formulas including SUM, SUBTOTAL, or simple 
addition (+) operators in the rows and/or columns where they need to be. 

 The summary formulas must all flow in the same direction. For example, all =SUM formulas must add 
together cells above or to its left in a single worksheet. If one or more add together other cells to the 
right or below as well, Excel cannot create an outline. 

 The summary formulas can flow in any direction. Although Excel assumes the direction of the summary 
formulas is above or to the left, you can override these assumptions by changing the settings. On the 
Data tab, in the Outline group, click the Dialog box launcher to display the Settings dialog box. 
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By default, Excel assumes that summation formulas flow to the right and/or below the group data. 
Uncheck the boxes if the data flow in one of the opposite directions. 

 You can have only one outline for each worksheet. 

If you are unable to meet any one of these conditions, Excel may not complete the task and you will have 
to create the outline manually. 

As indicated, the automatic outlining tool can be applied to rows and/or columns of data.  

 
Excel could not create an automatic outline for this worksheet because there are no repeating values to 
insert the subtotals. Instead, you have to manually insert the subtotals by row after every 3 months (or 
Quarter), and by column within each product group.  

 

Learn the Skill 
This exercise demonstrates how to insert manual subtotals, and then create an outline 
afterwards. 

1 Open the Sales workbook again and save as Sales Grouping – Student. 

Begin by creating a group for the month of January. 

2 Scroll down and select row 180. On the Home tab, in the Cells group, click Insert. 

3 Enter the following: 

Cell Value or Formula 
A180 Subtotal ‐ January 
D180 =SUBTOTAL(9,D2:D179) 

4 Make a note of the first row of the February sale and write it here: __________ 

5 Select rows 2 to 179. You can select this group of rows by starting at the bottom with row 179 and 
select the rest of the rows in an upward direction, or scroll to the top of the worksheet, start with row 2, 
and select downwards. 

Note: Do not include the row containing the subtotal formula. 

6 On the Data tab, in the Outline group, click Group. 

 The group outline bar is now displayed for the January rows. 
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Repeat these steps for the month of February. 

7 Scroll down and select row 332. Then, on the Home tab, in the Cells group, click Insert. 

8 Enter the following: 

Cell Value or Formula 
A332 Subtotal ‐ February 
D332 =SUBTOTAL(9,D181:D331) 

 How did you know the range for this SUBTOTAL would start at 181? Because 181 came from the 
number you wrote down in step 4. 

9 Select rows 181 to 331 and then, on the Data tab, in the Outline group, click Group. 

10 Click  at the left of the headers for rows 332 and 180 to collapse both groups created so far. 

You still have another 10 months’ worth of data to group, and the process is beginning to appear tedious 
and error prone because the SUBTOTAL function must reference the correct cell range. For the remaining 
10 months, you can use the same steps but in a different sequence to help streamline the process. 

11 Scroll down and insert a new blank row at row 493. You can also use the keyboard shortcut  +  
to insert a blank row. 

12 Select rows 333 to 492 and then, on the Data tab, in the Outline group, click Group.  

 When selecting the rows to be grouped together, be sure to not include the blank row in the group. 

13 Check that the  appears at the blank row, similar to the example below:  

  
 If you have accidentally left out one or more rows of data, select these missing rows as shown in the 

following screen example. Then, on the Data tab, in the Outline group, click Group. Excel automatically 
adds these cells to the group. 

  

14 Click  at the left of the row header to collapse this group. Alternatively, click  (to the left of the 
column label row). 

15 Enter the headings for each of these two new groups: 

Cell Value or Formula 
A493 Subtotal ‐ March 
D493 =SUBTOTAL(9,D333:D492) 

How did you know the range for this SUBTOTAL? You have collapsed all of the groups created so far, 
so just look at the row numbers at the left side of the worksheet. The range for March starts at row 333 
because that is the next row after the February subtotal. It ends at row 492 because that is the last row 
just above the March subtotal. 
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Now switch to a different workbook in which the grouping and subtotals have already been entered for the 
months of May to December. 

16 Save and close the workbook. 

17 Open the Sales Grouping 2 workbook and save as: Sales Grouping 2 – Student. 

18 Enter the following: 

Cell Value or Formula 
A2015 Grand Total 
D2015 =SUBTOTAL(9,D2:D2014) 

Set Excel to automatically create the outline for the worksheet. 

19 Select a cell inside the data range, such as C180. 

20 On the Data tab, in the Outline group, click the arrow for Group, and then click Auto Outline. 

Hint: Alternatively, on the Data tab, in the Outline group, click the Dialog box launcher to display the 
Settings dialog box. 

 A message box appears with the question, “Modify existing outline?” This message is displayed 
because you had already created groups in this worksheet. You could have inserted the SUBTOTAL 
formulas into the worksheet without the grouping. The automatic outlining tool would then have 
created all of the monthly groups for you. However, for this exercise, you used the monthly groupings 
to help you enter the correct ranges for each SUBTOTAL. 

 Your data with the manually inserted groupings and subtotals is now converted to an outlined group. 

21 Click OK. 

 Collapse and expand the worksheet using the outline buttons to confirm that it is working properly as 
an outlined group. 

22 Click the  ,  ,  , and  buttons to view different outline levels of the data. 

 The worksheet should look something like the following when the  button is clicked. 

  
Note: When you use the automatic outlining feature, you will not be able to undo it using the Undo 
button on the Quick Access Toolbar. 
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23 Save the workbook. 

24 On the Data tab, in the Outline group, click the arrow for Ungroup, and click Clear Outline. 

 All of the groupings have now been removed. The workbook has already been saved with the 
groupings so discard this version with the groupings removed. 

25 Close the workbook and discard the changes. 

Lesson Summary
In this lesson, you learned various ways of organizing data to improve your ability to analyze it. You should 
now be able to: 

 create, modify, and delete range names 

 use Go To to jump to a cell or named range 

 convert a range of data to a table 

 modify a table by adding and deleting rows and 
columns of data 

 apply and remove formatting on a table, and 
remove a sparkline chart 

 sort data 

 use filtering on data 

 remove duplicate rows of data 

 outline and group data using automatic subtotals 

 outline and group data by manually inserting 
subtotals 

Review Questions 
1. Give examples of why you might want to name cell ranges instead of using the cell references. 

2. What restrictions are in place regarding range names? 

3. What can you use the Name Manager for? 

4. To create a table, the following conditions must be met (select all that apply):  

a) The data in the range of cells must be contiguous. 

b) All of the data must be of the same type, such as text, numbers, or dates but not a mixture. 

c) The data can be arranged in row or column order. 

d) Any range names must be removed first before creating the table.  

e) There must be a header at the top of each column and the data listed below. 

5. Banding a table means to (select all that apply):  

a) Discard the contents of a table. 

b) Apply a light and dark shade of a color to alternating rows of a table. 

c) Apply a “band-aid” fix to the table data. 

d) Apply a light and dark shade of a color to alternating columns of a table.  

e) Create a musical performing group to headline the latest chart hits. 

6. What is the difference between sorting and filtering? 

7. Why do you need to tell Excel whether you have headers in the data? 

8. Provide an example of when you might set up multiple levels for sorting. 

9. Which of the following comparison operators can be used for filtering text, numbers, and dates (select 
all that apply):  
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a) Above average f) Begins with 

b) Greater than g) Next month 

c) Top 10 h) Contains 

d) Equals i) Does not equal 

e) Between j) Greater than or equal to 

10. The Remove Duplicates feature will reliably delete all rows that contain duplicate data even though the 
data may have minor variations such as extra blanks, commas, or different spellings.  

a. True b. False 

11. The automatic outline feature allows you to (select all that apply):  

a) Insert a sum subtotal for one or more columns of data. 

b) Automatically sort your data.  

c) Insert one or more subtotals – for example, sum, average, and variance – for the same column of 
data with each subtotal being in a separate subtotal row. 

d) Nest your data with multiple subtotal levels. 

e) Set the filter criteria using a wide variety of different comparison operators.  




