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Lesson Objectives

The objectives of this lesson are to use advanced Excel features in creating charts and conditional formatting
rules, and to check for errors in formulas. Upon completion of this lesson, you should be able to:
format a simple chart



add a secondary vertical axis



use dynamic and animated charts



create and apply chart templates



create and modify a chart trendline



trace formula errors



use basic conditional formatting



use the evaluate formula feature to debug a formula



manage conditional formatting rules



check the worksheet manually for formula errors
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create custom conditional formatting rules using
formulas and functions



use the Error Checking Tool to mark possible
incorrect formulas
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Advanced Chart Elements
Objective 4.1

Formatting a Simple Chart
The Excel charting feature is an extremely powerful tool that displays your data in a visual manner. The Chart
Tools group of tabs includes a wide variety of options you can use to customize the appearance of your chart.

y

Because there are so many combinations to choose from, you may want to start with one of the selections
under the Chart Layouts group in the Chart Tools/Design tab. Each of these options commonly uses a

nl

pre-selected mix of titles, legend, and other chart formatting settings.

Learn the Skill

O

This exercise is a refresher on how to create a chart, move and resize it, and perform some
common customizations.

Open the Sales by Type and Year workbook and save as Sales by Type and Year – (your name).
Create a chart using the data in this worksheet.

2

n

1

Click any cell in the range A5:J14, then on the Insert tab, in the Charts group, click Insert Column Chart.
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Click Clustered Column in the 2-D Column section.

Move the chart so that it is below the data and make it bigger. Also add a chart title.
3

Click and drag the chart to a new location on the worksheet with the upper left corner in cell A17.

4

Click and drag the bottom right corner handle down to cell L40.

Switch the data so that the years are displayed on the horizontal X-axis.
5

Under Chart Tools, on the Design tab, in the Data group, click Switch Row/Column.

6

Select the Chart Title label, and change the label to: Sales by Type and Year.

va

The chart includes the Total row because it was directly below the rest of the data. It is skewing the chart
by creating the very tall columns. Remove this row so that the other data columns are easier to see.
7

In the Select Data Source dialog box, scroll down to the bottom of the Legend Entries (Series) list. Click

rE

8

On the Design tab, in the Data group, click Select Data.

Fo

the Total entry and click Remove.
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9

Click OK to close the dialog box.
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The screen should look similar to the following example:

10 Save the workbook and leave it open for the next exercise.

Add a Secondary Vertical Axis

The Y-axis is always displayed on the left side of the chart. You can also add an optional secondary Y-axis on
the right side. The primary reason for having two axes is that the chart may have two types of data, each
needing its own scale. An example is a chart that shows data containing prices and sales volume. The sales

va

volume may use the primary axis on the left with the scale reaching up to 1,000,000 units. The price data may
use the secondary axis on the right with the scale reaching up to $10.00. If you displayed the price data using
the primary axis, each data point will be very low compared to sales data and therefore not appear to be

rE

meaningful.

In many cases, you may want to configure the chart using two different chart types at the same time. This is
known as a combo chart, in which some of the data series use one chart type (for example clustered column)
while the rest of the data series use a different chart type (such as a line). You can also select more than two

Fo

chart types but the chart will look too complex. You can then combine the combo chart with dual axes so
that one chart type uses the primary axis, and the other chart type matches to the secondary axis.
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To change these chart type and secondary axis options, click Change Chart Type on the Design tab, in the
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Type group:

An alternative method of shifting a data series to the secondary axis is to right-click on one of the data points
(or bar), and click Format Data Series from the shortcut menu. To switch to the other axis, select the
Secondary Axis option from the Series Options in the Formatting Data Series pane. Note that you must select

Fo
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one of the data series – four resize handles will appear around each of the data bars in the series.
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Learn the Skill
The Marketing Department manager for Tolano Adventures has been reviewing her sales data for
the past several years, looking for a pattern. In this exercise, you will modify a chart as a combo
chart and use a secondary Y-axis.
1

Ensure the Sales by Type and Year – (your name) workbook is open.
Add a new row of data to the chart.
Click in a blank area of the chart to select it.

3

On the Design tab, in the Data group, click Select Data.

4

In the Select Data Source dialog box, click Add.

5

In the Edit Series dialog box, click in the Series name text box, then click cell A16.

6

Delete the current contents of the Series values text box, then select cells B16 to J16, then click OK.

7

In the Select Data Source dialog box, click OK.
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2

This new row of data represents an expense, unlike the other data series which represent income. It
would therefore make better sense to display it as a different chart type with its own Y-axis.
8

On the Design tab, in the Type group, click Change Chart Type.

9

In the Change Chart Type dialog box, click the Combo chart type on the left.

va

By changing to the combo chart type, Excel changes the second half of the data series to the line type.
You will need to manually change them all back to clustered column except the last one.
10 Scroll down the Choose the chart type and axis for your data series list box, and change the Chart Type

rE

for every series except Advertising and Promotions (the bottom one) from Line to Clustered Column.

Fo

11 Click the Secondary Axis check box for the Advertising and Promotions series, and click OK.
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The screen should look similar to the following example:
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Notice that if you had left the new data row as another column bar, its significance would not have been
obvious. By changing the data series to a line, you can now see a very distinct pattern – the Advertising
and Promotions amount rises and falls in direct proportion to the sales of the various travel types. This
significance has been enhanced especially with the use of the secondary Y-axis using its own scale. The
Marketing Department manager will be able to use this chart to convince senior management to increase
her spending budget, because it clearly shows how an increase in spending on advertising and
promotions coincides with sales volume.
12 Save the workbook.

va

Dynamic Charts

Up to this point, your experience with Excel charts has been with using static data. The chart simply displays
all of the data within a defined range of cells. But once the chart has been created, any changes to the data

rE

will also cause the chart to be updated automatically.
Furthermore, if your data is set up as a table, you can leverage the AutoFilter capability to easily update any
charts attached to it. With tables, new data is automatically added to the range. With AutoFilter, data can be

temporarily hidden. When you link the chart to tables or AutoFiltered data lists, the chart will also change

Fo

dynamically.

1

Learn the Skill
This exercise demonstrates how to update a chart dynamically while making changes to the table
containing the data.

Ensure the Sales by Type and Year – (your name) workbook is open.
Delete two rows from the range so that the Advertising and Promotions row is next to the rest of the
data.
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2

Click on the row headers on both rows 14 and 15 to select both, then on the Home tab, in the Cells
group, click Delete.
Convert the range into a table.
Click on any cell in the range A5:J13.

4

On the Insert tab, in the Tables group, click Table.

5

In the Create Table dialog box, accept the default settings and click OK.

6

In cell A4, enter: Travel Type to replace the default column heading inserted by the table.
Extend the table by adding more columns.

7

Enter the following values into the designated cells:
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3

K4

2014

L4

2015

M4

2016

For these additional columns, we will create a forecast using an estimated rate of growth.
8

In cell O14, enter: 10%.

9

In cell K14, enter: =J14*(1+$O$14).

10 Select the cell range K5:K14, then drag the AutoFill handle in the bottom right corner of cell K14, and

va

drag it across to column M.

11 Scroll down the worksheet so that row 14 and the chart are fully visible on the screen.
Notice that the chart is already updated with the additional columns of data. Now observe the effects

rE

on the chart when you change the growth rate.

12 Select cell O14, change the value to: 15%.

13 Change the value in cell O14 to 20%, and then again to 5%.

Fo

The chart will also automatically adjust when you apply filter conditions on the table.

14 Click the AutoFilter button for cell A4 (Travel Type). Click the (Select All) check box to turn it off, then
click on each of the following three travel types to turn on their check boxes again:
Cruises
American Vacation Packages
Sun Seeker Vacation Packages
15 Click OK to update the table and the chart.

3254-1 v1.00 © CCI Learning Solutions Inc.

59

Lesson 2

Advanced Charts, Conditional Formatting, and Checking Formulas

lu
at
io

n

O

nl

y

The screen should look similar to the following example:

Filtered out. Add that data series back in.

16 Click the AutoFilter button for cell A4 and click the Advertising and Promotions check box to turn it
back on, then click OK.

17 Click the AutoFilter button for cell A4 and click the Select All check box to turn it back on, then click
OK.

18 Save the workbook.

The secondary axis still appears, but the scale is meaningless because the related data series has been

va

Animated Charts

As described above, charts will automatically update themselves when changes are made to the source data.
Prior to Excel 2013, the chart will update instantaneously, even on the slowest computer. Charts are now

rE

animated, which means that chart elements will move in visible increments to their new positions.

Learn the Skill

Fo

This exercise demonstrates how to animate a chart when making changes to the table containing

1

the data. You will also use a slicer to filter data on a non-pivot table.

Ensure the Sales by Type and Year – (your name) workbook is open. Select the Sheet2 worksheet.

Create a chart using only the total values for each year.

2

Select cells A4:J4, hold down the

key and select cells A14:J14. Release the

3

On the Insert tab, in the Charts group, click Insert Column Chart, then click Clustered Column in the

key.

2-D Column section.
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4

Move the chart to the blank area below the data, with the top left corner of the chart in cell A16. Make
the chart bigger by dragging the bottom right corner of the chart down to cell G33.
Change one of the numbers in the data, and observe the change to the chart.

5

Select cell E7, and enter: 900,000.
Notice how the 2008 bar slides up to its new position. In earlier versions it would jump up in one quick
move.
Click the Undo and Redo buttons in the Quick Access Toolbar to watch this action again.

y

6

nl

Now add a slicer to the table so that the entire data series moves at the same time.
On the Insert tab, in the Filters group, click Slicer.

8

In the Insert Slicers dialog box, click the Travel Type check box to turn it on and click OK.

9

Move the Travel Type slicer to the empty area to the right of the chart.
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10 Click on different buttons of your choice in the Travel Type slicer.

Notice that the scale on the Y-axis also changes to accommodate the new range of values in the chart.
11 Save the workbook.

rE

Custom Chart Templates
Once you have created a chart with specific formatting in it, you may want to apply the same formatting to
other charts, whether you have an existing chart or you are creating a new one. For example, you (or your

Fo

organization) may want the same color scheme or layout for all charts to maintain a consistent look. This can
be accomplished by saving an existing chart as a template.
To save a chart as a chart template, do the following:
1.

Click in a blank area of the chart to select the chart. Any of the blank areas in the four corners of the

chart would work best, to ensure the overall chart is selected.
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In the shortcut menu, click Save as Template. The Save Chart Template dialog box will appear.

3.

Enter a name for the chart template and click Save.

O

2.

Once created, the user-created chart templates appear in the Insert Chart dialog box in the Templates
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category.
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When you create a chart template, you are saving the chart design, not the data. For example, the
following screen demonstrates a new chart created using the example user-defined chart template
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shown above:

In this chart, the data came from the current worksheet. The formatting of the data bars, plot area, and
chart area were all encoded into the chart template and applied to the new chart, saving you a lot of
time and effort by not having to apply them again.

Learn the Skill

va

This exercise demonstrates how to save a chart as a template and how to use that template to
create new charts.

1

Ensure the Sales by Type and Year – (your name) workbook is open. Select the Sheet1 worksheet tab. Also

rE

ensure that all changes made to this workbook up to this point have been saved.
Customize this chart a little more, and then save it as a template.

Click on a blank area of the chart to select it.

3

Under Chart Tools, on the Design tab, in the Chart Styles group, click Style 5.

Fo

2

4

Right-click in a blank area of the chart and click Format Chart Area in the shortcut menu.

5

In the Format Chart Area pane, click the Fill & Line icon, then open the Fill options menu.

6

Click Gradient fill, select a Color of your choice, and change the Angle to 45°.

7

Close the Format Chart Area pane.

8

Right-click on a blank area of the chart, and in the shortcut menu, click Save as Template.

9

In the File name text box, replace the default name with: Sales and Advertising Combo and click Save.
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Notice that this chart template is saved to your private templates folder; that is, only you have access to
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this template from this location.

10 Close the Sales by Type and Year – (your name) workbook and discard the changes made since the last
save.

Now open another workbook where you want to use this chart template.
11 Open the Advertising and Promotions Expense workbook and save it as Advertising and Promotions
Expense – (your name).

Select the data that you want to use in the chart.

va

12 Select any cell in the range A5:E12.

The only place where you can access your user-defined chart templates is from the Insert Chart dialog
box.

rE

13 On the Insert tab, in the Charts group, click the dialog box launcher.

14 Click the All Charts tab, then click the Templates category at the left side of the Insert Charts dialog
box.

Fo

15 Click the Sales and Advertising Combo icon in the My Templates section to select it, and click OK.
The chart is now displayed in the current worksheet, using the same formatting as the original chart. For
the purpose of this exercise, you will move it to its own chart sheet.

16 Under Chart Tools, on the Design tab, in the Location group, click Move Chart.

17 Click New sheet and click OK.
Chart formatting that is not carried over in the chart template are the chart title (other than a default
label), the data series selection, and the chart type for individual data series in a combo chart (such as
the original chart used to create this template).
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18 Select the chart title and replace the default text with: Advertising Expenses.
19 On the Design tab, in the Data group, click Switch Row/Column.
20 Click one of the bars in the Total data series (the tallest bars).
21 Under Chart Tools, on the Design tab, in the type group, click Change Chart Type.

22 In the Change Chart Type dialog box, scroll down to the bottom of the Choose the chart type and axis
for your data series list box, change the Total data series to Line, and click the Secondary Axis check

y

box. Click OK.
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The completed chart should now look similar to the following example:

va

23 Click the Sheet1 worksheet tab again.

24 On the Insert tab, in the Charts group, click the dialog box launcher.
25 Click the All Charts tab, and click the Templates category. Click the Manage Templates button.

rE

An Explorer window now displays the folder where the template is located. From here you can copy or

Fo

move it to another location, or delete it.
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26 Close the Explorer window and click Cancel in the Insert Chart dialog box.
27 Save and close the Advertising and Promotions Expenses – (your name) workbook.

Chart Trendline
A common method of analyzing data is to create charts or graphs using the data in a worksheet. But charts
will only display the data in a visual format; you must still interpret this visual information and try to find a
pattern in it. Adding a trendline to a chart will not only help you analyze existing data, but also to predict

y

future values.

nl

A trendline is used to find a pattern or trend in the mass of data points that appear on a chart. Excel uses

advanced mathematical techniques (such as regression analysis) to determine a best-fit line using the data
available.

•

O

Before deciding to insert a trendline, you should:

Include as many data points as possible in your chart. For example, creating a trendline using only two
or three points will be very misleading. Trends are usually more accurate with 10 data points as a bare

•

n

minimum; having at least 100 data points is preferred.

Do not automatically accept the trendline as presented. The human brain can sometimes see a different
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pattern that the computer will not be able to identify.

Trendlines can easily be added to an existing chart when the chart is selected. Excel offers a choice of six
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types of trendlines based on different statistical calculation methods.
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Exponential

Create a trendline by using an exponential equation. This option is not available when
your data includes negative or zero values.

Linear

Create a very simple trendline by using the linear equation y = mx + b.

Logarithmic

Create a simple trendline by using the logarithmic equation y = clnx + b.

Polynomial

Create a trendline by using the polynomial equation. A maximum order number must
also be specified.

Power

y

Create a trendline by using the power equation. This option is not available when your
data includes negative or zero values.

Use a specific number of points (set by the Period option), average them, and use the

nl

Moving Average

average value as a point in the line.

O

A detailed description of the above methods is beyond the scope of this courseware.

As well as choosing the type of trendline, you can select an option to forecast (forward or backward) beyond
the time period specified in your data. You can also change the color of the trendlines to make the chart

Learn the Skill

n

more readable.

the future.
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This exercise demonstrates how to create a trendline in a chart, and use it to create a forecast into

1

Open the Sales by Type and Year – (your name) workbook.

2

Click in a blank area of the chart to select it.

You will now add two different types of trendlines to your chart.
3

Under the Chart Tools, on the Design tab, in the Chart Layouts group, click Add Chart Element, hover
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over Trendline and click Linear.

In the Add Trendline dialog box, click American Vacation Packages, and click OK.
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Your worksheet should look similar to the following:

This line shows a declining trend in the sales between the beginning and end of the period being
analyzed. The line is calculated using a sophisticated mathematical formula. However, the most recent
years indicate an increasing trend. Perhaps a different trendline may be better suited to this data.
5

Right-click on the trendline, and click Format Trendline in the shortcut menu.

6

In the Format Trendline pane, click Moving Average, then change the number of Periods to 4.
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Your chart should now appear similar to the following:

The trendline depicts a four year moving average. For example, the first data point in the trendline is the
average of the past four years from 2005 to 2008. The second data point is the average from 2006 to
2009. This trendline indicates that the sales for American vacation packages has overcome its low point
and is now on an increasing trend.
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7

Click on each of the other trendline options and observe how the trendline changes in the chart.
The trendline can also be used to create a forecast of future values, based on the direction and rate of
change in the current data.

8

Click the Polynomial trendline option.

9

Scroll down the Format Trendline pane, click in the Forecast Forward entry box, replace the current
value with: 5 and press the

key.

y

The chart has now widened to add another 5 years to the X-axis. Because the data table does not have

nl

any numbers for those additional years, the data labels do not appear along that axis.
11 Increase the Polynomial Order value to 3.

Notice that the scale on the primary Y-axis has changed to accommodate the new trendline range, while

O

the scale on the secondary Y-axis remains unchanged. As a result, the clustered column bars are now
much shorter, while the line appears much higher but in fact has not moved.
Add another trendline on a different data series in the chart.

n

12 Click in a blank area of the chart to de-select the trendline.
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13 Under the Chart Tools, on the Design tab, in the Chart Layouts group, click Add Chart Element, hover
over Trendline and click Exponential.

14 In the Add Trendline dialog box, click Cruises, and click OK.
15 Click the new blue trendline (cruises) to select it.

16 In the Format Trendline pane, click the Trendline Options icon, change the Forward Forecast value to 5,
and press the

key.
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Your chart should now appear similar to the following:

The green trendline indicates sales of American vacation packages will approach $1,000,000 by the year
2021, while the blue trendline indicates sales of cruises will drift down to about $180,000.
Now assume that you are not satisfied with these forecasts, and that the two trendlines need
adjustments.
3254-1 v1.00 © CCI Learning Solutions Inc.
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17 With the blue trendline still selected, click Polynomial, and increase the Order to 3.
18 Click the green trendline (American vacation packages), and click Exponential in the Format Trendline
pane.
The forecast has now switched drastically: the green trendline indicates sales of American vacation
packages will drift down to about $320,000 by the year 2021, while the blue trendline indicates sales of
cruises will explode up to about $440,000.

y

This exercise demonstrates that the statistical analysis tools in Excel are powerful, but must be used
correctly by knowledgeable analysts. Otherwise people will make incorrect decisions, which could lead

nl

to disastrous results.

Objective 2.2

Basic Conditional Formatting

n

Conditional Formatting

O

19 Save and close the workbook.

You can use conditional formatting to change the appearance of a cell (within certain limitations), depending

lu
at
io

on that cell’s value. The cell format will change automatically when the cell value changes, triggering a
different conditional formatting rule. This saves time for you and eliminates errors in having to make the

rE
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format changes manually.

Fo

The Excel 2013 Core courseware covered the topic of using the Ribbon to create conditional formats. The
Ribbon method is easy to use and enables you to create the most frequently used conditional formats. Behind
the scenes, the Ribbon method creates conditional formatting rules. You can also create these rules directly
by using the New Formatting Rule dialog box, which is launched by clicking on the More Rules or New Rule
options in the drop down menus.
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The New Formatting Rule dialog box has the following rule types available:
Format all cells based on

The main application of this rule is to display indicators that show how the

their values

values in a range of cells relate to each other. For example, you may want cells
with the highest values to show in red (hot), while the cells with the lowest
values show in blue (cold). Excel will choose gradient colors between the red
and blue for all other cells with the data values in between the two extremes.
You can choose one of four main types of indicators: a 2-color scale, a 3-color

y

scale, a data bar, or an icon set. Further, you can choose from several different
types of icons for the icon set.

The most commonly used rule, offering a wide variety of operators to select

contain

the cells to highlight, such as between, greater than, and equal to. All cells that

nl

Format only cells that

O

meet that rule will be highlighted with the same formatting.
Format only top or

Apply a specific format to the cells with the highest or lowest values or

bottom ranked values

percentile in a range of cells. For example, you can use this rule to identify the
10% of students with the highest ranking scores in a course.
Apply a specific format to cells that are above or below the average of a range

are above or below

of cells. Excel allows you to choose from the mean average or various degrees

average

of standard deviation from the mean average.
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Format only unique or
duplicate values
Use a formula to

n

Format only values that

Identify all cells within a range with duplicate or unique values.
Enter a formula that evaluates to TRUE or FALSE to enable or disable the

determine which cells to

conditional formatting for the cells within the range. This formula may

format

reference another cell in the same worksheet, but not another worksheet or
workbook.

A cell may have both a manual format as well as a conditional format. If the cell is not affected by a conditional

va

format, the cell will use the manual format.

Formatting options include only the font styles (regular, bold, italics, or bold and italics), font colors, borders,
and background fill patterns. You may not choose different font names or font sizes in a conditional format.

rE

Manage Conditional Formatting Rules
All conditional formatting rules for a worksheet are displayed in the Rules Manager window. You can use the
Rules Manager to create new rules, modify existing ones, and delete rules that are no longer needed.

Fo

You may apply multiple conditional formats to a range of cells at the same time. For example, one rule may
be to display a certain color if the value is less than 3,000; another rule to display a different color if the value
is between 3,000 and 10,000; and a third rule if the value is greater than 10,000. In this situation, the rules do
not conflict with each other and one of them will be in effect at any one time.
Suppose instead that one rule is where the value is less than 10,000 and another rule is where the value is
greater than 3,000. In this case, the two rules overlap. Generally, the rule listed higher than the other in the
Rules Manager will over-ride the other. This is known as rule precedence. However, both will take effect if

they do not conflict; for example, one rule is to display an icon set and the other is to display a background
fill color.
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In the example below, the top two rules conflict with each other because both are setting background fill
formats. Because the rule at the top takes precedence, all cells with a value greater than 3,000 have an orange
background. The remaining cells have a green background because they meet the second condition of <
10,000.
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The third rule applies to all cells because an icon set format does not conflict with the background fill.

The rules in the Rules Manager window apply in reverse sequence to when they were added; that is, the
latest rule added is always placed at the top of the list, and takes precedence over any rules below it. The

va

sequence of these rules can be changed; simply choose the rule and click Move Up or Move Down.
Note that you can also apply manual formatting to a cell using the Format Cells dialog box or by changing
the formatting settings directly from the Ribbon. If the cell also has a conditional format, then the conditional
format will always take precedence over the manual formatting.

rE

The conditional formatting feature changed drastically in Excel 2007 compared to earlier versions of Excel. In
the earlier versions you were limited to colors, fonts, and borders, and have only a maximum of three rules.

In addition, the new rule precedence procedure dealt with overlapping rules by applying only the first rule
that was evaluated to be true. Any other rule listed lower was ignored. If you need the conditional formatting

Fo

to behave like the Excel versions earlier than 2007, click the Stop If True check boxes in the Rules Manager

window.
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Learn the Skill
This exercise is a quick refresher of basic conditional cell formatting.
1

Open the New York Temperatures workbook and save it as New York Temperatures – (your name).
This worksheet shows the average monthly temperature for New York City from 2000 to 2012. Create a
conditional format to set the fill color to blue for any cell that contains a temperature value of less than

y

32 degrees Fahrenheit (when water turns to ice).
Select the cell range B2:M14.

3

On the Home tab, in the Styles group, click Conditional Formatting, then click Highlight Cells Rules,

nl

2

Less Than.

4

O

The Less Than dialog box is displayed with default values entered for you.

In the Less Than dialog box, enter: 32 in the left entry box, then click the drop down button in the right

n

list box and click Custom Format.

Because the Custom Format option was selected, the Format Cells dialog box is now displayed.
In the Format Cells dialog box, click the Fill tab, then click the blue standard color (bottom line, third

lu
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5

from the right) and click OK.
6

In the Less Than dialog box, click OK.

va

Create another conditional cell format to set the fill color to red for any cell that contains a temperature
value of greater than 75 degrees Fahrenheit.
On the Home tab, in the Styles group, click Conditional Formatting, then click New Rule.

8

In the New Formatting Rule dialog box, click Format only cells that contain in the Select a Rule Type

rE

7

list.

9

In the Edit the Rule Description section, click the drop down button in the second list box and click
greater than. In the right-most text box, enter: 75.

Fo

10 Click the Format button.
11 In the Format Cells dialog box, click the red standard color (bottom row, second from the left), and click
OK.
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12 In the New Formatting Rule dialog box, click OK to complete the creation of the conditional formatting
rule.

n

Assume that the blue color is too dark. You can change an existing rule at any time.

lu
at
io

13 On the Home tab, in the Styles group, click Conditional Formatting, then click Manage Rules.
14 Click the bottom rule (Cell Value < 32), then click Edit Rule.

You can change the formatting criteria rule in this window, or move deeper to change the format.
15 In the Edit Formatting Rule dialog box, click Format.

16 In the Format Cells dialog box, click the light blue standard color (bottom row, fourth from the right),
then click OK.

17 In the Edit Formatting Rule dialog box, click OK. In the Conditional Formatting Rules Manager dialog

va

box, click OK.

18 Click in a blank cell of the worksheet.

Fo

rE

The screen should now look similar to the following example:

You can also format a cell manually. However, it will be over-ridden by the conditional format.
19 Click on cell B6, then click the Fill Color drop down button in the Ribbon. In the Theme Colors section
of the drop down menu, click the Gold, Accent 4, Lighter 40% color.
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Now test the conditional formatting rules in some of the cells.
20 Click cell F5, and enter: 31.
21 Click cell C5, and enter: 75.1.
22 Click cell B6, and enter: 40.

23 Click the Undo button in the Quick Access Toolbar three times to undo the changes to the cell values.

y

You can remove the conditional formatting from a selected range of cells or from the entire worksheet.
24 On the Home tab, in the Styles group, click Conditional Formatting, then click Clear Rules, Clear Rules

nl

from Entire Sheet.

Notice that the manual formatting in cell B6 from step 19 is now taking effect because the conditional

O

formatting has been removed.

25 With cell B6 still selected, click the Fill Color drop down button in the Ribbon, then click No Fill in the
drop down menu.

n

26 Leave the workbook open for the next exercise.

lu
at
io

Custom Conditional Formatting Using a Formula
If the predefined conditional formatting rules cannot accommodate what you are looking for, you can also
create a customized one using a formula.

Fo

rE

va

In the example below, the formula =A$1=$B$16 is used for a new conditional format on the cell range A1:M14.

There are two important rules to remember about this formula:

•

The formula must result in a TRUE or FALSE value.

•

If the formula contains any cell references, the formula must be entered as if it was being entered into
the upper left corner cell of the selected range. In the example above, the upper left corner cell for this
range of cells receiving the conditional formatting is cell A1. Therefore the cell formula =A$1=$B$16 is

evaluated for that cell. However, if the cell range selected for the conditional format is B2:M14, the
equivalent formula must be =B$2=$B$16.
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Notice that if the formula contains cell references, these references may be relative, absolute or mixed. For
all other cells in the cell range in which the conditional format rules apply, Excel will automatically adjust the
relative and mixed cell references. Absolute cell references and the absolute part of mixed cell references will
not change from cell to cell. Using the above example again, in cell C1 the formula will adjust to =C$1=$B$16,
but for cell C2 the formula will also be =C$1=$B$16. For both cells C1 and C2, the formula evaluates to TRUE

Learn the Skill
1

Ensure the New Your Temperatures – (your name) workbook is open.

nl

This exercise demonstrates how to use the Insert Function feature.

y

and therefore the conditional format will activate for these cells.

O

Using the same New York City temperatures, create a conditional format to highlight an entire column
based on the month value you enter into a cell.

Cell

Value

B16

Feb

C16

2001

n

Enter the following values into the worksheet:
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2

Excel automatically formatted cell C16 using the same settings as the cells above containing numbers.
Clear this formatting so that it shows as a year value.
3

Select cell C16 again, then on the Home tab, in the Editing group, click Clear, and click Clear Formats.

4

Select the cell range A1:M14.

5

On the Home tab, in the Styles group, click Conditional Formatting, then click New Rule.

6

In the New Formatting Rule dialog box, click Use a formula to determine which cells to format in the
Select a Rule Type list.

In the Format values where this formula is true text box, type: =A1=$B$16.

8

Click the Format button.

9

In the Format Cells dialog box, under the Fill tab, click the green standard color (bottom row, fifth from

va

7

rE

the right), and click OK.

10 In the New Formatting Rule dialog box, click OK to complete the creation of the conditional formatting
rule.

Fo

In the worksheet, only cell C1 is highlighted in green, because it is the only cell in which the formula
entered in step 7 evaluates to the value of True (for this cell the formula is adjusted to =C1=$B$16). The
conditional format can be modified so that the entire column is highlighted in green.

11 Click Conditional Formatting in the Ribbon, then click Manage Rules.
12 With the sole rule already selected, click Edit Rule.
13 In the Format values where this formula is true text box, change the formula to: =A$1=$B$16 and click
OK.

14 In the Conditional Formatting Rules Manager dialog box, click OK.
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The entire column is now highlighted: every cell (not just C1) in the cell range C1:C14 will now have the
formula in the conditional format adjusted to =C1=$B$16.
Add another custom conditional format to highlight the entire row for the year value entered into cell
C16.
15 Ensure that the range A1:M14 is still selected, then click Conditional Formatting in the Ribbon, then
click New Rule.
Select a Rule Type list.

nl

17 In the Format values where this formula is true text box, type: =$A1=$C$16.

y

16 In the New Formatting Rule dialog box, click Use a formula to determine which cells to format in the

18 Click the Format button, then click the orange standard color (bottom row, third from the left), and click

O

OK.

19 In the New Formatting Rule dialog box, click OK to complete the creation of the conditional formatting
rule.

n

20 Click in any blank cell outside of the range A1:M14 to view the results of the conditional formatting.

va
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The screen should now look similar to the following example:

rE

Change the values in the cells containing the month and year values.
21 Click cell B16, and enter: Sep.

22 Click cell C16, and enter: 2009.
With these changes, every cell in column J is green, except cell J11. Every cell in row 11 is orange,

Fo

including cell J11.

23 Click Conditional Formatting in the Ribbon, then click Manage Rules.
24 In the Show formatting rules for list box, click the arrow and select This Worksheet.
25 With the top-most rule already selected, click the Move Down button, then click OK.
By switching the sequence of the conditional formatting rules, the one that highlights in green is now
performed first. The entire column is now green including cell J11.
26 Save and close the workbook.
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Custom Conditional Formatting Using a Function
A formula entered for a custom conditional format can also make use of functions.

Learn the Skill
This exercise demonstrates how to create a custom conditional format using a function.
Open the Airport Departures workbook and save it as Airport Departures – (your name).

2

nl

This worksheet lists the departure time for a variety of flights out of an airport.

y

1

Scroll down the worksheet to view the rest of the data.

You can enter a formula that will display the word “Departed” for any flight with a departure time that is

O

earlier than the current time. The current time can be calculated by subtracting today’s date from the
current date and time, which leaves only the current time value. Copy this formula down to the other
rows.

Click in cell F2, and enter: =IF((NOW()-TODAY())>D2,"Departed","")

4

Copy the formula in cell F2 down to the cell range F3:F70.
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n

3

Create a conditional format on column F, using the same logical test as the formula in step 3.
5

Select the cell range F2:F70.

6

On the Home tab, in the Styles group, click Conditional Formatting, then click New Rule.

7

In the New Formatting Rule dialog box, click Use a formula to determine which cells to format in the
Select a Rule Type list.

In the Format values where this formula is true text box, type: =(NOW()-TODAY())>D2.

9

Click the Format button.

va

8

10 In the Format Cells dialog box, click the dark red standard color (bottom row, first on the left), and click
OK.

11 In the New Formatting Rule dialog box, click OK to complete the creation of the conditional formatting

rE

rule.

The screen should now look similar to the following example, except the status and conditional

Fo

highlighting will automatically adjust to your current time:
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key. Excel will then update the formulas and the conditional
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formatting in the worksheet, and the next cell in column F will change to “Departed”.
12 Save and close the workbook.

Checking for Formula Errors
Objective 1.3

Users automatically assume that spreadsheets are correct and base decisions on the information provided.
Spreadsheet usage is pervasive in business and personal applications, ranging in size from major corporate
investments to individual life insurance policies and everything in between. The impact from errors in

va

spreadsheets can range from minor inconveniences to major implications on the livelihoods of thousands of
employees. The simple checking of formulas should be performed on any worksheet before it is printed or
saved.

rE

Using the Error Checking Tool
Excel has an error checking feature that greatly reduces time spent auditing formulas for accuracy. If
background error checking is enabled, Excel displays a dark green triangle in the upper left corner of a cell

Fo

to indicate that it contains an inappropriate formula. Possible errors that Excel will highlight include:
•

formulas that are inconsistent with others in the same row or column.

•

formulas that refer to a range but omit a cell that is within or adjacent to the range.

•

formulas that evaluate to an error.

•

numbers stored as text.

When you select a cell with a green triangle, a box with an exclamation mark (the Trace Error icon) appears
beside it. Click the button to display a drop-down menu that describes the problem and offers to fix it.
Alternatively, on the Formulas tab, in the Formula Auditing group, click Error Checking.
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Learn the Skill
This exercise demonstrates how to use Excel’s Error Checking tool to find errors in formulas.
1

Open the Rocky Mountains Tour workbook and save it as Rocky Mountains Tour – (your name).
Tolano Adventures is using this spreadsheet to compare the revenues to the expenses for a planned
tour. The numbers appear to indicate that a healthy profit will be made.

y

However, this worksheet has formulas with errors in them. Wherever Excel believes that a formula is

incorrect, it displays an Error Indicator (green triangle at the upper left corner) in the cell. By default, this
Click File and then click Options. In the Excel Options dialog box, click the Formulas category.

rE
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2

nl

background error checking is turned on. You can verify this by looking in the Options dialog box.

Ensure that the Enable background error checking check box is turned on.

Fo

3

Notice that you can also change the color of the Error Indicator triangle or toggle various error checking
rules on or off.

4

Click the Reset Ignored Errors button and then click OK to close the dialog box.

An error indicator (the small green triangle) is now visible in the upper left corner of cell D21, indicating
that it contains a possible formula error.
5

80

Select cell D21 and click the Trace Error icon to the left of this cell.
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y

At the top row of the Trace Error menu, Excel describes the problem it has identified: the formula in this

nl

cell does not include adjacent cells containing data that you may have wanted to include. At this point,
you should check the contents of the formula bar to determine whether to change this formula.
6

Look at the Formula Bar for this cell.

7

O

The formula in this cell is =SUM(D13:D19). However, cells D12 to D20 contain expense numbers.
In the Trace Error menu, click Update Formula to Include Cells.

If you select Ignore Error, the green triangle disappears and the error is not identified in future error
Click Undo in the Quick Access Toolbar to revert the formula back to its previous value.
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8

n

checks (unless you click Reset Ignored Errors in the Excel Options window).

Instead of checking each cell one by one, you can use the Error Checking tool to automatically select the
next one.
9

Select cell A1 or any cell at the top of the worksheet.

This step demonstrates how Excel behaves when you use the error checking tool. In fact, it doesn’t matter
where the cell pointer is when you carry out the next step.

10 On the Formulas tab, in the Formula Auditing group, click Error Checking.

Fo

rE
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The cursor jumps to the first cell that Excel finds with a potential error in it.

Excel has found the formula error again in cell D21.

11 Click Update Formula to Include Cells.
When Excel can no longer find any problems with formulas, it displays the following:
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12 Click OK.
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Your worksheet should now look like the following:

This updated worksheet shows that the profit has been substantially reduced, but there is still a small
profit being made. The worksheet actually has more formula errors, but the Error Checking Tool has
found as many errors as it could.
13 Save the workbook.

Tracing Formula Errors

Another method of finding formula errors is to use tracing tools. These tools draw arrows to help you trace
cells that are precedents or dependents of the current cell. By following the lines and dots in the arrows, you

va

can determine which cells are referenced in formulas.

When you select a cell and trace its precedents, Excel draws lines from other cells leading to the current active
cell (that is, preceding it). Excel also draws box outlines around these cells. This is a visual way of examining

rE

a worksheet to see which cells are being referenced by formulas. In a complex worksheet with many formulas,
this is a very useful tool to ensure they are all correct.
The reverse can also be done by selecting a cell and tracing its dependent cells; Excel draws lines to any cells
that use the data in the current active cell, directly and indirectly. Dependent cells contain formulas that

Fo

reference the current active cell (that is, depending on it).
You can extend the tracing of precedent or dependent cells by selecting Trace Precedents or Trace

Dependents again in the Ribbon.
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Learn the Skill
In this exercise, you will use the auditing tools on the Rocky Mountains Tour workbook to see if
there are any other formula errors.
1

If necessary, open the Rocky Mountains Tour – Student workbook.
Start by selecting the most important cell in the entire workbook—the one that calculates the profit of
Revenues less Expenses.
Select cell D23 and then, on the Formulas tab, in the Formula Auditing group, click Trace Precedents.

y

2

nl

Notice the thin line and the dots drawn from cell D9 to D23. The dots in cells D9 and D21 indicate that

With cell D23 still selected, click Trace Precedents again.

va

3
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O

these cells are referenced in the formula in cell D23. These appear to be correct.

As the Trace Precedents tool drives down through the next layer of detail, Excel draws boxes above cells
D9 and D21. The boxes indicate that these cell ranges are referenced in the formulas in the two cells.

rE

These also appear to be correct.
4

Click Trace Precedents one more time.

Another set of lines and dots are drawn as the Trace Precedents tool drives down through another layer

Fo

of detail. These indicate the cells referenced in the formulas entered into the cell range D6:D8.
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n

Looking at the last set of lines and dots drawn, you should see that they do not appear correct. The Fare
used at all.
5

Select cell D7.
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value in cell B6 is used to calculate the total in cells D6 to D8, but the fares in cells B7 and B8 are not

By selecting cell D7, you can see that the formula is incorrect.
6

Change the formula in cell D7 to: =B7*C7.

7

Select cell D8 and change the formula to: =B8*D8.

8

Select cell D23 and click Trace Precedents again.

The lines and dots now appear in the correct cells. It also now appears that this tour will incur a loss

Fo

rE

va

instead of a profit.
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When you have completed auditing the worksheet, you can remove the arrows.
9

On the Formulas tab, in the Formula Auditing group, click Remove Arrows.
Instead of finding the precedent cells, you can find cells containing formulas that depend on the value
in a selected cell, either directly or indirectly. This is the reverse method: tracing dependent cells.

10 Select cell B6 and, on the Formulas tab, in the Formula Auditing group, click Trace Dependents.

y

11 Click Trace Dependents two more times.
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nl

The worksheet now appears similar to the following:

12 Save and close the workbook.

va

Evaluate Formulas

Excel formulas do an excellent job of performing calculations that are sometimes very complex. Even when a
formula is seemingly simple, you may be puzzled about why the result is different than what you expected.
You can use the Evaluate Formula feature to force Excel to slow down and perform each of the internal

rE

calculations in a formula one step at a time. As it performs each step, you can see the intermediate results,

Fo

which will help you understand where the data is coming from.
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The Evaluate Formula dialog box shows the formula that is in the selected cell in the Evaluation text box. An
underline appears under the cell reference (or expression) that is about to be evaluated. You can then choose
one of three buttons:
Evaluate

If the underline appears under a cell reference, press this button to obtain the value from that
cell and display it in the formula. If the underline is under an arithmetical expression, press this
button to perform the arithmetic and display the result.

Step In

If an underlined cell reference contains an intermediate formula, you can click this button to

Step Out

y

display and evaluate that formula in a separate box.

nl

If you have stepped into a cell to evaluate its formula, press this button to return to the original
formula in the upper box.

You may find the Evaluate Formula feature difficult to use. It is time-consuming to track every step inside the

O

formula as it performs each calculation or cell reference. You will most likely have to repeat the evaluation
several times before identifying the errant calculation. As a result, you may want to use the Evaluate Formula

Learn the Skill

n

feature only as a last resort (i.e., if you are unable to debug it any other way).

1
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This exercise demonstrates how to use the Evaluate Formula feature.
Open the Travel Miles workbook and save it as Travel Miles – (your name).

This worksheet combines the contents of two cells, C1 and C2, to form a sentence, as shown in cell C4.
The intention is to enter different points values in cell C1 for different customer transactions and display
2

va

a friendly message from cell C4 on a document, such as an e-mail or statement for the customer.
Select cell C4.

rE

This formula looks very intimidating, as it contains three levels of nested functions (the topic of nesting
functions is covered in detail in Lesson 5) in some parts. The purpose of this function is to replace the
“XX” in the template wording in cell C2 with the number from cell C1.
Although there are easier ways of achieving this result, for this exercise we will assume that this is the

Fo

optimal method. However, the displayed text in the cell is incorrect because there is an extra “X” still in
place before the value 300. You will need to find out what to fix in the formula to remove that “X”.

3

On the Formulas tab, in the Formula Auditing group, click Evaluate Formula.

The Evaluate Formula dialog box first shows the full formula. The underline under the first cell reference
indicates that it will be the first to be evaluated. The Evaluate button will show the result of that cell
reference as it is translated.

4

86

Click Evaluate.
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The Evaluation box now shows a current value of ”Travel miles points earned – XX” where C2 used to be.
The underline is now under the next cell reference, which is a reference to cell C2 again. The Evaluation

O

box helps you by translating the formula piece by piece as it executes each calculation and cell reference.
Pressing the Evaluate button forces Excel to perform one calculation at a time.
Click Evaluate again.

n

5

The underline is now under FIND(“XX”,”Travel miles points earned – XX”). If you recall your text functions,
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io

you will know that this finds the position of the characters “XX” in the text string and returns the number
representing that position.
6

Click Evaluate again.

Note: If you lose track of what the original formula looks like, look up at the Formula Bar.
The underline is now under MID(”Travel miles points earned – XX”,1,30). The previous FIND function
returned the value 30.
Click Evaluate again.

Fo
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7

The result of the MID function is ”Travel miles points earned – X”. You have now found the location of
the error because the extra “X” appears here. The MID function needs to extract one less character at the
far right end. By looking in the Formula Bar, you will notice that it is the FIND function that calculates the
number of characters to extract. The correction is to subtract 1 from that number.

8

Click Close.

9

If necessary, select cell C4 again. Change the formula to:
=CONCATENATE(MID(C2,1,FIND("XX",C2)-1),TEXT(C1,"#,##0"))
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Notice the “-1” is added at the right of the FIND function.
The worksheet should now appear similar to the following:

y

The text displayed in cell C4 is now correct.
In evaluating this formula, you only used the Evaluate button. There are also the Step In and Step Out

nl

buttons.

10 Select cell C4 again and, on Formulas tab, in the Formula Auditing group, click Evaluate Formula.
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11 Click Step In.

When you used the Evaluate button earlier, the C2 was simply replaced with the cell value in the
Evaluation box. The Step In button shows you the contents of the cell in C2 in a separate box before
completing that replacement.

va

12 Click Step Out.

13 Click Evaluate seven more times to perform this function.
The Evaluation window now shows the completed result of the entire formula, and the Evaluate button

Fo

rE

has changed to a Restart button.

14 Click Restart.
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When you press the Restart button, the evaluation starts over again.
15 Click Close.
16 Select cell C2 and change the text to: Travel miles points you earned today – XX.
17 Select cell C1 and enter: 1500.

The displayed text in cell C4 automatically adjusts itself to the new template wording and points value,

y

because of the flexibility of the function used in that cell.

Manual Checking and Displaying Formulas

nl

18 Save and close the workbook.

As demonstrated earlier, the Error Checking tool is not 100% reliable. For example, if all of the formulas in a

O

row refer to values in the same incorrect row, Excel will not find the error. Also, Excel ignores inconsistencies
if formulas reference other formulas rather than values. Therefore, you should still manually check formulas
for accuracy.

n

Manually checking a worksheet means selecting every cell in the worksheet to determine if it contains the
right value or formula. If it is a formula that references other cells, you should look and verify that the correct
to help you verify that these formulas are correct.

va

border when you press
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cells are being referenced. Excel displays cell range references visually by highlighting them with a colored

A useful feature to help you review all of the formulas in a worksheet at the same time is the Show Formulas
option. This feature forces every cell to display the formula instead of the calculated value.

rE

Learn the Skill

This exercise demonstrates how to check worksheets to ensure there are no formula errors.

Open the Rocky Mountains Tour workbook.

Fo

1

Select cells containing SUM formulas to verify that are correct.

2

Select cell C9 and then press the

3

Press the

4

Repeat steps 2 and 3 for cells D9 and D21.

key to switch to edit mode for this cell.

key to exit from edit mode.

Repeating these steps for each cell is tedious work. Activate the Show Formulas feature to speed things
up.
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5

On the Formulas tab, in the Formula Auditing group, click Show Formulas.

6

If necessary, adjust the size of the Excel workbook window so that you can see the cell range A1:D23.
Select cells containing SUM formulas to verify that they are correct.

7

Select cell C9, D9, and then D21.
As you select each of these cells, note the range of cells that are highlighted and ask yourself if the

y

selection appears to be correct.
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The worksheet should appear as follows:

8

Click on some of the other cells that appear to be incorrect, such as cells D6, D7 and D8.

9

On the Formulas tab, in the Formula Auditing group, click Show Formulas again to turn the formula

va

display off.

10 Close the workbook and discard any changes made.

rE

Lesson Summary

In this lesson, you learned how to use advanced Excel features in creating charts and conditional formatting
rules, and to check for errors in formulas. You should now be able to:
format a simple chart



add a secondary vertical axis



use dynamic and animated charts



create and apply chart templates



create and modify a chart trendline



trace formula errors



use basic conditional formatting



use the evaluate formula feature to debug a formula



manage conditional formatting rules



check the worksheet manually for formula errors is

Fo


90



create custom conditional formatting rules using
formulas and functions



use the Error Checking Tool to mark possible incorrect
formulas
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Review Questions
Add and remove data rows.

b.

Change the chart type after the chart has been created.

c.

Add and remove the legend.

d.

Switch between showing the data rows or columns on the X-axis.

e.

Move the chart to a different location on the worksheet or a different worksheet.

f.

All of the above customizations can be performed on a chart.

nl

A line chart can have both a primary and secondary Y-axis, even though it is not a combo chart.
a.

3.

y

a.

True

b.

False

O

2.

Which of the following customizations is not possible with an Excel chart:

Which of the following changes to the data will cause the chart to change immediately:
a.

The data is set up as a table, and the AutoFilter is used to remove some of the rows of data from
being displayed.

The data is not set up as a table, and the AutoFilter is used to remove some of the rows of data from

lu
at
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b.

n

1.

being displayed.

4.

c.

A new row of data is added to a table.

d.

Two of the cells are updated with new data.

e.

All of the above.

f.

None of the above.

Once you have created a chart template, can you apply it to almost any worksheet containing similar
data?

Why would you want to include a trendline in a chart?

6.

Which of the following is not a valid conditional format?
a.

va

5.

Display a dark gray background color if the cell contains a text string with the three character text

rE

“con” in it.

b.

Display a dark blue background color in a chart if the cell value is greater than 10,000.

c.

Display a color that could range from dark green to dark red, with lighter shades between these two
extremes, depending on the numeric value in the cell.
Display an icon set that resembles a pie, with a solid black circle representing the largest values in

Fo

d.

the range to a solid white circle for the smallest value, with varying portions of black and white for
values in between.

7.

Suppose you create two conditional format rules on a range of cells:
a.

Display an orange background color if the cell has a value > 7.5.

b.

Display a green background color if the cell has a value >= 7.4.

What background color will display if every value had a minimum value of 8?
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Which of the following is not a valid conditional format:
a.

Display a dark gray background color if the cell contains a text string with the three character text
“con” in it.

b.

Display a dark blue background color in a chart if the cell value is greater than 10,000.

c.

Display a color that could range from dark green to dark red, with lighter shades between these two
extremes, depending on the numeric value in the cell.
Display an icon set that resembles a pie, with a solid black circle representing the largest values in

y

d.

the range to a solid white circle for the smallest value, with varying portions of black and white for

=$C2

b.

=$F$5 > TODAY()

c.

=A$16<>SUM(A$1:A$15)

d.

=ISNUMBER(A1)

e.

All of the above.

f.

None of the above.

n

a.

O

Which of the following are valid formulas to use in a conditional formatting rule (circle all that apply):
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9.

nl

values in between.

10. What are some of the suspicious conditions that the Excel Error Checking tool will flag for you?
11. Why should you check the formulas in your worksheet manually?

12. How can you display all the formulas in a worksheet at once in order to identify all errors in the formulas,

Fo

rE

va

or do you need to check each cell individually?
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